Merge /dists/sid/linux-2.6.

This should include all changes up to 2.6.31-2, except patches merged upstream.
Fix up ARM patches to apply to 2.6.32.

svn path=/dists/trunk/linux-2.6/; revision=14642
This commit is contained in:
Ben Hutchings 2009-11-17 01:18:56 +00:00
commit b575145097
13 changed files with 507 additions and 13 deletions

View File

@ -76,7 +76,7 @@ class main(object):
f = self.retrieve_package(self.url, filename)
d = self.extract_package(f, "linux-headers-%s_%s" % (prefix, arch))
f1 = d + "/usr/src/linux-headers-%s-%s/Module.symvers" % (self.version_abi, prefix)
s = Symbols(f1)
s = Symbols(open(f1))
shutil.rmtree(d)
return s
@ -93,11 +93,7 @@ class main(object):
u = url(self.source, filename)
filename_out = self.dir + "/" + filename
try:
f_in = urllib2.urlopen(u)
except urllib2.HTTPError, e:
raise RuntimeError('Failed to retrieve %s: %s' % (e.filename, e))
f_in = urllib2.urlopen(u)
f_out = file(filename_out, 'w')
while 1:
r = f_in.read()
@ -111,7 +107,7 @@ class main(object):
if not os.path.exists(dir):
os.makedirs(dir)
out = "%s/%s_%s_%s" % (dir, arch, featureset, flavour)
Symbols.write(file(out, 'w'))
symbols.write(open(out, 'w'))
def update_arch(self, config, arch):
if self.override_featureset:
@ -150,8 +146,12 @@ class main(object):
abi = self.get_abi(arch, localversion)
self.save_abi(abi, arch, featureset, flavour)
self.log("Ok.\n")
except urllib2.HTTPError, e:
self.log("Failed to retrieve %s: %s\n" % (e.filename, e))
except StandardError, e:
self.log("FAILED! (%s)\n" % str(e))
self.log("FAILED!\n")
import traceback
traceback.print_exc(None, sys.stdout)
if __name__ == '__main__':
options = optparse.OptionParser()

View File

@ -124,7 +124,6 @@ class CheckAbi(object):
s_new = new[name]
if s_ref != s_new:
print "cmp", s_ref.__dict__, s_new.__dict__
change.add(name)
symbols[name] = self.SymbolChangeInfo(s_ref, s_new)

39
debian/changelog vendored
View File

@ -33,6 +33,45 @@ linux-2.6 (2.6.32~rc7-1) UNRELEASED; urgency=low
-- Ben Hutchings <ben@decadent.org.uk> Mon, 26 Oct 2009 01:18:26 +0000
linux-2.6 (2.6.31-2) unstable; urgency=low
[ Martin Michlmayr ]
* [armel/orion5x, armel/kirkwood] Make sure VGA_CONSOLE is disabled,
otherwise the kernel won't boot.
* [armel/kirkwood] Enable CRYPTO_DEV_MV_CESA (Closes: #552270).
* [armel/kirkwood, armel/orion5x] Enable ORION_WATCHDOG (the
name of the config variable changed).
* Add OpenRD-Client support again.
* Add QNAP TS-41x support.
* [armel/orion5x, armel/kirkwood] Enable ISDN (requested by Markus
Krebs).
* Fix a build failure of the ISDN hisax elsa driver on ARM.
* mips: fix build of vmlinux.lds (Closes: #552422).
[ Ben Hutchings ]
* postinst: Accept absolute paths in modules.dep generated by the
lenny version of module-init-tools (Closes: #552610)
* aufs2: Remove incorrect static assertion (Closes: #554120)
* Add stable release 2.6.31.6:
- fs: pipe.c null pointer dereference (CVE-2009-3547)
- KEYS: get_instantiation_keyring() should inc the keyring refcount
in all cases (CVE-2009-3624)
- netlink: fix typo in initialization (CVE-2009-3612)
* Undo PCMCIA ABI change in 2.6.31.6
* Hide wireless keys and wake-on-LAN password when including network
configuration in bug reports
* Add Geode LX/NX to list of 686-class processors
[ Bastian Blank ]
* [powerpc] Remove SMP warning from PowerMac cpufreq (Closes: #554124)
[ maximilian Attems ]
* Really fix making a debian kernel installable without kernel-img.conf.
Thanks for patch to Sebastian Andrzej Siewior <sebastian@breakpoint.cc>.
(closes: #555093).
-- Ben Hutchings <ben@decadent.org.uk> Sun, 15 Nov 2009 18:47:49 +0000
linux-2.6 (2.6.31-1) unstable; urgency=low
[ Ben Hutchings ]

View File

@ -59,6 +59,7 @@ CONFIG_MACH_RD88F6192_NAS=y
CONFIG_MACH_RD88F6281=y
CONFIG_MACH_SHEEVAPLUG=y
CONFIG_MACH_TS219=y
CONFIG_MACH_TS41X=y
CONFIG_MACH_OPENRD_BASE=y
##

View File

@ -25,7 +25,7 @@ configs:
[686_description]
hardware: modern PCs
hardware-long: PCs with Intel Pentium Pro/II/III/4/4M/D/M, Xeon, Celeron, Core or Atom; AMD K6, Athlon (K7), Duron, Opteron, Sempron, Turion or Phenom; Transmeta Efficeon; VIA C3 "Nehemiah" or C7 processors
hardware-long: PCs with Intel Pentium Pro/II/III/4/4M/D/M, Xeon, Celeron, Core or Atom; AMD K6, Geode LX/NX, Athlon (K7), Duron, Opteron, Sempron, Turion or Phenom; Transmeta Efficeon; VIA C3 "Nehemiah" or C7 processors
[686_image]
configs:

View File

@ -640,6 +640,11 @@ CONFIG_PD6729=m
CONFIG_I82092=m
CONFIG_TCIC=m
##
## file: drivers/power/Kconfig
##
CONFIG_BATTERY_PMU=m
##
## file: drivers/rtc/Kconfig
##

View File

@ -0,0 +1,15 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: [PATCH] aufs2: Remove incorrect static assertion
This should allow aufs2 to build on alpha.
--- a/fs/aufs/vdir.c
+++ b/fs/aufs/vdir.c
@@ -25,7 +25,6 @@
static unsigned int calc_size(int nlen)
{
- BUILD_BUG_ON(sizeof(ino_t) != sizeof(long));
return ALIGN(sizeof(struct au_vdir_de) + nlen, sizeof(ino_t));
}

View File

@ -0,0 +1,134 @@
--- a/arch/arm/mach-kirkwood/Kconfig 2009-09-25 19:49:01.000000000 +0000
+++ b/arch/arm/mach-kirkwood/Kconfig 2009-09-25 19:50:08.000000000 +0000
@@ -44,6 +44,12 @@
Say 'Y' here if you want your kernel to support the
Marvell OpenRD Base Board.
+config MACH_OPENRD_CLIENT
+ bool "Marvell OpenRD Client Board"
+ help
+ Say 'Y' here if you want your kernel to support the
+ Marvell OpenRD Client Board.
+
endmenu
endif
--- a/arch/arm/mach-kirkwood/Makefile 2009-09-25 19:49:07.000000000 +0000
+++ b/arch/arm/mach-kirkwood/Makefile 2009-09-25 19:49:29.000000000 +0000
@@ -7,5 +7,6 @@
obj-$(CONFIG_MACH_SHEEVAPLUG) += sheevaplug-setup.o
obj-$(CONFIG_MACH_TS219) += ts219-setup.o
obj-$(CONFIG_MACH_OPENRD_BASE) += openrd_base-setup.o
+obj-$(CONFIG_MACH_OPENRD_CLIENT) += openrd_client-setup.o
obj-$(CONFIG_CPU_IDLE) += cpuidle.o
--- /dev/null 2008-06-15 07:07:41.000000000 +0000
+++ b/arch/arm/mach-kirkwood/openrd_client-setup.c 2009-09-25 19:52:36.000000000 +0000
@@ -0,0 +1,107 @@
+/*
+ * arch/arm/mach-kirkwood/openrd_client-setup.c
+ *
+ * Marvell OpenRD Base Client Setup
+ *
+ * This file is licensed under the terms of the GNU General Public
+ * License version 2. This program is licensed "as is" without any
+ * warranty of any kind, whether express or implied.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/partitions.h>
+#include <linux/ata_platform.h>
+#include <linux/mv643xx_eth.h>
+#include <linux/gpio.h>
+#include <asm/mach-types.h>
+#include <asm/mach/arch.h>
+#include <mach/kirkwood.h>
+#include <plat/mvsdio.h>
+#include "common.h"
+#include "mpp.h"
+
+static struct mtd_partition openrd_client_nand_parts[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = SZ_1M
+ }, {
+ .name = "uImage",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_4M
+ }, {
+ .name = "root",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = MTDPART_SIZ_FULL
+ },
+};
+
+static struct mv643xx_eth_platform_data openrd_client_ge00_data = {
+ .phy_addr = MV643XX_ETH_PHY_ADDR(8),
+};
+
+static struct mv643xx_eth_platform_data openrd_client_ge01_data = {
+ .phy_addr = MV643XX_ETH_PHY_ADDR(24),
+};
+
+static struct mv_sata_platform_data openrd_client_sata_data = {
+ .n_ports = 2,
+};
+
+static struct mvsdio_platform_data openrd_client_mvsdio_data = {
+ .gpio_card_detect = 29, /* MPP29 used as SD card detect */
+};
+
+static unsigned int openrd_client_mpp_config[] __initdata = {
+ MPP29_GPIO,
+ 0
+};
+
+static void __init openrd_client_init(void)
+{
+ /*
+ * Basic setup. Needs to be called early.
+ */
+ kirkwood_init();
+ kirkwood_mpp_conf(openrd_client_mpp_config);
+
+ kirkwood_uart0_init();
+ kirkwood_uart1_init();
+ kirkwood_nand_init(ARRAY_AND_SIZE(openrd_client_nand_parts), 25);
+
+ kirkwood_ehci_init();
+
+ /* initialize gbe0 and gbe1 */
+ kirkwood_ge00_init(&openrd_client_ge00_data);
+ kirkwood_ge01_init(&openrd_client_ge01_data);
+
+ kirkwood_sata_init(&openrd_client_sata_data);
+ kirkwood_sdio_init(&openrd_client_mvsdio_data);
+
+ kirkwood_i2c_init();
+}
+
+static int __init openrd_client_pci_init(void)
+{
+if (machine_is_openrd_client())
+ kirkwood_pcie_init();
+
+ return 0;
+}
+subsys_initcall(openrd_client_pci_init);
+
+
+
+
+MACHINE_START(OPENRD_CLIENT, "Marvell OpenRD Client Board")
+ /* Maintainer: Dhaval Vasa <dhaval.vasa@einfochips.com> */
+ .phys_io = KIRKWOOD_REGS_PHYS_BASE,
+ .io_pg_offst = ((KIRKWOOD_REGS_VIRT_BASE) >> 18) & 0xfffc,
+ .boot_params = 0x00000100,
+ .init_machine = openrd_client_init,
+ .map_io = kirkwood_map_io,
+ .init_irq = kirkwood_init_irq,
+ .timer = &kirkwood_timer,
+MACHINE_END

294
debian/patches/features/arm/ts41x.patch vendored Normal file
View File

@ -0,0 +1,294 @@
diff --git a/arch/arm/mach-kirkwood/Kconfig b/arch/arm/mach-kirkwood/Kconfig
index 0aca451..d58e8b0 100644
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
@@ -38,6 +38,13 @@ config MACH_TS219
Say 'Y' here if you want your kernel to support the
QNAP TS-119 and TS-219 Turbo NAS devices.
+config MACH_TS41X
+ bool "QNAP TS-410, TS-410U, TS-419P and TS-419U Turbo NAS"
+ help
+ Say 'Y' here if you want your kernel to support the
+ QNAP TS-410, TS-410U, TS-419P and TS-419U Turbo NAS
+ devices.
+
config MACH_OPENRD_BASE
bool "Marvell OpenRD Base Board"
help
diff --git a/arch/arm/mach-kirkwood/Makefile b/arch/arm/mach-kirkwood/Makefile
index 80ab0ec..0c79ced 100644
--- a/arch/arm/mach-kirkwood/Makefile
+++ b/arch/arm/mach-kirkwood/Makefile
@@ -6,6 +6,7 @@ obj-$(CONFIG_MACH_RD88F6281) += rd88f6281-setup.o
obj-$(CONFIG_MACH_MV88F6281GTW_GE) += mv88f6281gtw_ge-setup.o
obj-$(CONFIG_MACH_SHEEVAPLUG) += sheevaplug-setup.o
obj-$(CONFIG_MACH_TS219) += ts219-setup.o
+obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o
obj-$(CONFIG_MACH_OPENRD_BASE) += openrd_base-setup.o
obj-$(CONFIG_MACH_OPENRD_CLIENT) += openrd_client-setup.o
obj-$(CONFIG_CPU_IDLE) += cpuidle.o
--- /dev/null 2008-06-15 07:07:41.000000000 +0000
+++ b/arch/arm/mach-kirkwood/ts41x-setup.c 2009-11-03 16:45:13.000000000 +0000
@@ -0,0 +1,253 @@
+/*
+ *
+ * QNAP TS-410, TS-410U, TS-419P and TS-419U Turbo NAS Board Setup
+ *
+ * Copyright (C) 2009 Martin Michlmayr <tbm@cyrius.com>
+ * Copyright (C) 2008 Byron Bradley <byron.bbradley@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version
+ * 2 of the License, or (at your option) any later version.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/physmap.h>
+#include <linux/spi/flash.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/orion_spi.h>
+#include <linux/i2c.h>
+#include <linux/mv643xx_eth.h>
+#include <linux/ata_platform.h>
+#include <linux/gpio_keys.h>
+#include <linux/input.h>
+#include <linux/timex.h>
+#include <linux/serial_reg.h>
+#include <linux/pci.h>
+#include <asm/mach-types.h>
+#include <asm/mach/arch.h>
+#include <mach/kirkwood.h>
+#include "common.h"
+#include "mpp.h"
+
+/****************************************************************************
+ * 16 MiB NOR flash. The struct mtd_partition is not in the same order as the
+ * partitions on the device because we want to keep compatability with
+ * the QNAP firmware.
+ * Layout as used by QNAP:
+ * 0x00000000-0x00080000 : "U-Boot"
+ * 0x00200000-0x00400000 : "Kernel"
+ * 0x00400000-0x00d00000 : "RootFS"
+ * 0x00d00000-0x01000000 : "RootFS2"
+ * 0x00080000-0x000c0000 : "U-Boot Config"
+ * 0x000c0000-0x00200000 : "NAS Config"
+ *
+ * We'll use "RootFS1" instead of "RootFS" to stay compatible with the layout
+ * used by the QNAP TS-109/TS-209.
+ *
+ ***************************************************************************/
+
+static struct mtd_partition qnap_ts41x_partitions[] = {
+ {
+ .name = "U-Boot",
+ .size = 0x00080000,
+ .offset = 0,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "Kernel",
+ .size = 0x00200000,
+ .offset = 0x00200000,
+ }, {
+ .name = "RootFS1",
+ .size = 0x00900000,
+ .offset = 0x00400000,
+ }, {
+ .name = "RootFS2",
+ .size = 0x00300000,
+ .offset = 0x00d00000,
+ }, {
+ .name = "U-Boot Config",
+ .size = 0x00040000,
+ .offset = 0x00080000,
+ }, {
+ .name = "NAS Config",
+ .size = 0x00140000,
+ .offset = 0x000c0000,
+ },
+};
+
+static const struct flash_platform_data qnap_ts41x_flash = {
+ .type = "m25p128",
+ .name = "spi_flash",
+ .parts = qnap_ts41x_partitions,
+ .nr_parts = ARRAY_SIZE(qnap_ts41x_partitions),
+};
+
+static struct spi_board_info __initdata qnap_ts41x_spi_slave_info[] = {
+ {
+ .modalias = "m25p80",
+ .platform_data = &qnap_ts41x_flash,
+ .irq = -1,
+ .max_speed_hz = 20000000,
+ .bus_num = 0,
+ .chip_select = 0,
+ },
+};
+
+static struct i2c_board_info __initdata qnap_ts41x_i2c_rtc = {
+ I2C_BOARD_INFO("s35390a", 0x30),
+};
+
+static struct mv643xx_eth_platform_data qnap_ts41x_ge00_data = {
+ .phy_addr = MV643XX_ETH_PHY_ADDR(8),
+};
+
+static struct mv643xx_eth_platform_data qnap_ts41x_ge01_data = {
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
+};
+
+static struct mv_sata_platform_data qnap_ts41x_sata_data = {
+ .n_ports = 2,
+};
+
+static struct gpio_keys_button qnap_ts41x_buttons[] = {
+ {
+ .code = KEY_COPY,
+ .gpio = 43,
+ .desc = "USB Copy",
+ .active_low = 1,
+ },
+ {
+ .code = KEY_RESTART,
+ .gpio = 37,
+ .desc = "Reset",
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_platform_data qnap_ts41x_button_data = {
+ .buttons = qnap_ts41x_buttons,
+ .nbuttons = ARRAY_SIZE(qnap_ts41x_buttons),
+};
+
+static struct platform_device qnap_ts41x_button_device = {
+ .name = "gpio-keys",
+ .id = -1,
+ .num_resources = 0,
+ .dev = {
+ .platform_data = &qnap_ts41x_button_data,
+ }
+};
+
+static unsigned int qnap_ts41x_mpp_config[] __initdata = {
+ MPP0_SPI_SCn,
+ MPP1_SPI_MOSI,
+ MPP2_SPI_SCK,
+ MPP3_SPI_MISO,
+ MPP6_SYSRST_OUTn,
+ MPP7_PEX_RST_OUTn,
+ MPP8_TW_SDA,
+ MPP9_TW_SCK,
+ MPP10_UART0_TXD,
+ MPP11_UART0_RXD,
+ MPP13_UART1_TXD, /* PIC controller */
+ MPP14_UART1_RXD, /* PIC controller */
+ MPP15_SATA0_ACTn,
+ MPP16_SATA1_ACTn,
+ MPP20_GE1_0,
+ MPP21_GE1_1,
+ MPP22_GE1_2,
+ MPP23_GE1_3,
+ MPP24_GE1_4,
+ MPP25_GE1_5,
+ MPP26_GE1_6,
+ MPP27_GE1_7,
+ MPP30_GE1_10,
+ MPP31_GE1_11,
+ MPP32_GE1_12,
+ MPP33_GE1_13,
+ MPP36_GPIO, /* RAM: 0: 256 MB, 1: 512 MB */
+ MPP37_GPIO, /* Reset button */
+ MPP43_GPIO, /* USB Copy button */
+ MPP44_GPIO, /* Board ID: 0: TS-419U, 1: TS-419 */
+ MPP45_GPIO, /* JP1: 0: console, 1: LCD */
+ MPP46_GPIO, /* External SATA HDD1 error indicator */
+ MPP47_GPIO, /* External SATA HDD2 error indicator */
+ MPP48_GPIO, /* External SATA HDD3 error indicator */
+ MPP49_GPIO, /* External SATA HDD4 error indicator */
+ 0
+};
+
+
+/*****************************************************************************
+ * QNAP TS-x19 specific power off method via UART1-attached PIC
+ ****************************************************************************/
+
+#define UART1_REG(x) (UART1_VIRT_BASE + ((UART_##x) << 2))
+
+void qnap_ts41x_power_off(void)
+{
+ /* 19200 baud divisor */
+ const unsigned divisor = ((kirkwood_tclk + (8 * 19200)) / (16 * 19200));
+
+ pr_info("%s: triggering power-off...\n", __func__);
+
+ /* hijack UART1 and reset into sane state (19200,8n1) */
+ writel(0x83, UART1_REG(LCR));
+ writel(divisor & 0xff, UART1_REG(DLL));
+ writel((divisor >> 8) & 0xff, UART1_REG(DLM));
+ writel(0x03, UART1_REG(LCR));
+ writel(0x00, UART1_REG(IER));
+ writel(0x00, UART1_REG(FCR));
+ writel(0x00, UART1_REG(MCR));
+
+ /* send the power-off command 'A' to PIC */
+ writel('A', UART1_REG(TX));
+}
+
+static void __init qnap_ts41x_init(void)
+{
+ /*
+ * Basic setup. Needs to be called early.
+ */
+ kirkwood_init();
+ kirkwood_mpp_conf(qnap_ts41x_mpp_config);
+
+ kirkwood_uart0_init();
+ kirkwood_uart1_init(); /* A PIC controller is connected here. */
+ spi_register_board_info(qnap_ts41x_spi_slave_info,
+ ARRAY_SIZE(qnap_ts41x_spi_slave_info));
+ kirkwood_spi_init();
+ kirkwood_i2c_init();
+ i2c_register_board_info(0, &qnap_ts41x_i2c_rtc, 1);
+ kirkwood_ge00_init(&qnap_ts41x_ge00_data);
+ kirkwood_ge01_init(&qnap_ts41x_ge01_data);
+ kirkwood_sata_init(&qnap_ts41x_sata_data);
+ kirkwood_ehci_init();
+ platform_device_register(&qnap_ts41x_button_device);
+
+ pm_power_off = qnap_ts41x_power_off;
+
+}
+
+static int __init ts41x_pci_init(void)
+{
+ if (machine_is_ts41x())
+ kirkwood_pcie_init();
+
+ return 0;
+}
+subsys_initcall(ts41x_pci_init);
+
+MACHINE_START(TS41X, "QNAP TS-41x")
+ /* Maintainer: Martin Michlmayr <tbm@cyrius.com> */
+ .phys_io = KIRKWOOD_REGS_PHYS_BASE,
+ .io_pg_offst = ((KIRKWOOD_REGS_VIRT_BASE) >> 18) & 0xfffc,
+ .boot_params = 0x00000100,
+ .init_machine = qnap_ts41x_init,
+ .map_io = kirkwood_map_io,
+ .init_irq = kirkwood_init_irq,
+ .timer = &kirkwood_timer,
+MACHINE_END
--- a/arch/arm/tools/mach-types
+++ b/arch/arm/tools/mach-types
@@ -2421,3 +2421,4 @@
mh355 MACH_MH355 MH355 2435
pc7802 MACH_PC7802 PC7802 2436
gnet_sgc MACH_GNET_SGC GNET_SGC 2437
+ts41x MACH_TS41X TS41X 2502

View File

@ -24,6 +24,7 @@
+ features/all/aufs2/aufs2-add.patch
# mark as staging/crap
+ features/all/aufs2/mark-as-staging.patch
+ bugfix/all/aufs2-remove-incorrect-static-assertion.patch
# content of src/ from speakup package; generated with:
# diff -ur --unidirectional-new-file nonexistent src | filterdiff --strip=1 --addoldprefix=a/drivers/staging/speakup/ --addnewprefix=b/drivers/staging/speakup/
@ -45,3 +46,5 @@
+ debian/dfsg/radeon-add-clarifying-comment-to-r600-blit.patch
+ features/arm/compression-use-generic-gzip.patch
+ features/arm/compression-add-lzmo.patch
+ features/arm/openrd-client.patch
+ features/arm/ts41x.patch

View File

@ -1,7 +1,7 @@
Section: kernel
Priority: optional
Maintainer: Debian Kernel Team <debian-kernel@lists.debian.org>
Uploaders: Bastian Blank <waldi@debian.org>, Frederik Schüler <fs@debian.org>, maximilian attems <maks@debian.org>
Uploaders: Bastian Blank <waldi@debian.org>, Frederik Schüler <fs@debian.org>, maximilian attems <maks@debian.org>, Ben Hutchings <ben@decadent.org.uk>
Standards-Version: 3.8.3
Build-Depends: debhelper (>> 7), cpio, module-init-tools, python, lzma [armel]
Build-Depends-Indep: bzip2, python-central, xmlto

View File

@ -36,8 +36,8 @@ add_1tainted() {
printf "$result_long" >&3
else
echo '** Not tainted' >&3
echo >&3
fi
echo >&3
}
ask_1tainted() {

View File

@ -3,7 +3,11 @@ add_network() {
test $REPLY = yep || return 0
echo '** Network interface configuration:' >&3
cat /etc/network/interfaces >&3
# Hide passwords/keys
awk '$1 ~ /^wireless-key/ { gsub(".", "*", $2); }
$1 == "ethtool-wol" { gsub(".", "*", $3); }
{ print; }
' </etc/network/interfaces >&3
echo >&3
echo '** Network status:' >&3
if command -v ip >/dev/null; then