aufs2: Remove incorrect static assertion (Closes: #554120)

svn path=/dists/sid/linux-2.6/; revision=14559
This commit is contained in:
Ben Hutchings 2009-11-05 01:03:16 +00:00
parent 4b18a52544
commit aac015e39f
3 changed files with 17 additions and 0 deletions

1
debian/changelog vendored
View File

@ -12,6 +12,7 @@ linux-2.6 (2.6.31-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* postinst: Accept absolute paths in modules.dep generated by the
lenny version of module-init-tools (Closes: #552610)
* aufs2: Remove incorrect static assertion (Closes: #554120)
[ Bastian Blank ]
* [powerpc] Remove SMP warning from PowerMac cpufreq (Closes: #554124)

View File

@ -0,0 +1,15 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: [PATCH] aufs2: Remove incorrect static assertion
This should allow aufs2 to build on alpha.
--- a/fs/aufs/vdir.c
+++ b/fs/aufs/vdir.c
@@ -25,7 +25,6 @@
static unsigned int calc_size(int nlen)
{
- BUILD_BUG_ON(sizeof(ino_t) != sizeof(long));
return ALIGN(sizeof(struct au_vdir_de) + nlen, sizeof(ino_t));
}

View File

@ -1,3 +1,4 @@
+ bugfix/mips/fix-build-vmlinuxlds.patch
+ features/arm/openrd-client.patch
+ bugfix/powerpc/Remove-SMP-warning-from-PowerMac-cpufreq.patch
+ bugfix/all/aufs2-remove-incorrect-static-assertion.patch