Build fixdep under debian/build and clean it up properly

Mattia Dongili noted that it's currently built under tools/build
(upstream bug).  Build it under the current output directory
(which means we build it multiple times) and clean all copies.
This commit is contained in:
Ben Hutchings 2016-02-19 01:14:37 +00:00
parent d97f0b3ee8
commit b0a0319c86
4 changed files with 25 additions and 0 deletions

View File

@ -19,3 +19,6 @@ all-recursive: all-local
clean-local::
rm -rf generated include out
# fixdep may be built in several places since we don't set the output directory
# consistently (XXX)
find -name fixdep -delete

1
debian/changelog vendored
View File

@ -3,6 +3,7 @@ linux-tools (4.4-2) UNRELEASED; urgency=medium
* linux-perf: Include version number in strace groups installation directory
(Closes: #813080)
* [alpha,sh4] Attempt to fix build failures
* Build fixdep under debian/build and clean it up properly
-- Ben Hutchings <ben@decadent.org.uk> Thu, 18 Feb 2016 21:46:41 +0000

View File

@ -22,3 +22,4 @@ perf-tools-fix-unused-variables-x86_-32-64-_regoffse.patch
perf-remove-wrong-semicolon-in-while-loop.patch
revert-perf-tools-x86-build-perf-on-older-user-space.patch
perf-tools-fix-bpf-feature-check.patch
tools-stop-building-fixdep-in-source.patch

View File

@ -0,0 +1,20 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 19 Feb 2016 01:14:05 +0000
Subject: tools: Stop building fixdep in the source directory
Use the proper target, $(OUTPUT)fixdep, not fixdep.
Reported-by: Mattia Dongili <malattia@linux.it>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/build/Makefile.include
+++ b/tools/build/Makefile.include
@@ -4,7 +4,7 @@ ifdef CROSS_COMPILE
fixdep:
else
fixdep:
- $(Q)$(MAKE) -C $(srctree)/tools/build fixdep
+ $(Q)$(MAKE) -C $(srctree)/tools/build $(OUTPUT)fixdep
endif
.PHONY: fixdep