[alpha,sh4] Attempt to fix build failures

This commit is contained in:
Ben Hutchings 2016-02-18 22:05:18 +00:00
parent 2b1e87a61f
commit d97f0b3ee8
4 changed files with 81 additions and 0 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux-tools (4.4-2) UNRELEASED; urgency=medium
* linux-perf: Include version number in strace groups installation directory
(Closes: #813080)
* [alpha,sh4] Attempt to fix build failures
-- Ben Hutchings <ben@decadent.org.uk> Thu, 18 Feb 2016 21:46:41 +0000

View File

@ -0,0 +1,21 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 18 Feb 2016 22:03:03 +0000
Subject: perf tools: Fix bpf feature check
Check that the bpf() system call is actually wired up for the target
architecture using #ifdef __NR_bpf.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/build/feature/test-bpf.c
+++ b/tools/build/feature/test-bpf.c
@@ -1,4 +1,9 @@
#include <linux/bpf.h>
+#include <asm/unistd.h>
+
+#ifndef __NR_bpf
+#error "bpf system call not wired for this architecture"
+#endif
int main(void)
{

View File

@ -0,0 +1,57 @@
From d9ea89d8408f647c05c720bf35a1fba4992dd4a8 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 18 Feb 2016 23:37:19 +0000
Subject: [PATCH] Revert "perf tools, x86: Build perf on older user-space as
well"
This reverts commit eae7a755ee81129370c8f555b0d5672e6673735d.
The empty unistd_{32,64}.h headers prevent building on sh, which also
now splits its unistd.h this way.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/perf/perf-sys.h | 6 ------
tools/perf/util/include/asm/unistd_32.h | 1 -
tools/perf/util/include/asm/unistd_64.h | 1 -
3 files changed, 8 deletions(-)
delete mode 100644 tools/perf/util/include/asm/unistd_32.h
delete mode 100644 tools/perf/util/include/asm/unistd_64.h
diff --git a/tools/perf/perf-sys.h b/tools/perf/perf-sys.h
index 83a25cef82fd..182a84eb5bd6 100644
--- a/tools/perf/perf-sys.h
+++ b/tools/perf/perf-sys.h
@@ -11,9 +11,6 @@
#if defined(__i386__)
#define cpu_relax() asm volatile("rep; nop" ::: "memory");
#define CPUINFO_PROC {"model name"}
-#ifndef __NR_perf_event_open
-# define __NR_perf_event_open 336
-#endif
#ifndef __NR_futex
# define __NR_futex 240
#endif
@@ -25,9 +22,6 @@
#if defined(__x86_64__)
#define cpu_relax() asm volatile("rep; nop" ::: "memory");
#define CPUINFO_PROC {"model name"}
-#ifndef __NR_perf_event_open
-# define __NR_perf_event_open 298
-#endif
#ifndef __NR_futex
# define __NR_futex 202
#endif
diff --git a/tools/perf/util/include/asm/unistd_32.h b/tools/perf/util/include/asm/unistd_32.h
deleted file mode 100644
index 8b137891791f..000000000000
--- a/tools/perf/util/include/asm/unistd_32.h
+++ /dev/null
@@ -1 +0,0 @@
-
diff --git a/tools/perf/util/include/asm/unistd_64.h b/tools/perf/util/include/asm/unistd_64.h
deleted file mode 100644
index 8b137891791f..000000000000
--- a/tools/perf/util/include/asm/unistd_64.h
+++ /dev/null
@@ -1 +0,0 @@
-

View File

@ -20,3 +20,5 @@ perf-fix-misleadingly-indented-assignment-whitespace.patch
perf-add-missing-braces-to-if-statement.patch
perf-tools-fix-unused-variables-x86_-32-64-_regoffse.patch
perf-remove-wrong-semicolon-in-while-loop.patch
revert-perf-tools-x86-build-perf-on-older-user-space.patch
perf-tools-fix-bpf-feature-check.patch