linux/debian/patches/tools-stop-building-fixdep-...

21 lines
556 B
Diff

From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 19 Feb 2016 01:14:05 +0000
Subject: tools: Stop building fixdep in the source directory
Use the proper target, $(OUTPUT)fixdep, not fixdep.
Reported-by: Mattia Dongili <malattia@linux.it>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/build/Makefile.include
+++ b/tools/build/Makefile.include
@@ -4,7 +4,7 @@ ifdef CROSS_COMPILE
fixdep:
else
fixdep:
- $(Q)$(MAKE) -C $(srctree)/tools/build fixdep
+ $(Q)$(MAKE) -C $(srctree)/tools/build $(OUTPUT)fixdep
endif
.PHONY: fixdep