Update to 4.5-rc5

This commit is contained in:
Ben Hutchings 2016-02-21 04:12:42 +00:00
parent 416a13b622
commit aae9cf4b6f
5 changed files with 53 additions and 136 deletions

5
debian/changelog vendored
View File

@ -1,5 +1,8 @@
linux (4.5~rc4-1~exp2) UNRELEASED; urgency=medium linux (4.5~rc5-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
[ Ben Hutchings ]
* [armel/versatile] Enable GPIOLIB, needed to build smc91x driver with * [armel/versatile] Enable GPIOLIB, needed to build smc91x driver with
OF enabled (fixes FTBFS) OF enabled (fixes FTBFS)
* [powerpc] mm: Fix HAVE_ARCH_SOFT_DIRTY dependencies (fixes FTBFS) * [powerpc] mm: Fix HAVE_ARCH_SOFT_DIRTY dependencies (fixes FTBFS)

View File

@ -1,30 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 20 Feb 2016 17:24:36 +0000
Subject: powerpc/mm: Fix HAVE_ARCH_SOFT_DIRTY dependencies
Soft dirty bit support was only implemented for 64-bit Book3S, and
32-bit configurations currently fail to build.
Fixes: 7207f43665b8 ("powerpc/mm: Add page soft dirty tracking")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/arch/powerpc/Kconfig
+++ b/arch/powerpc/Kconfig
@@ -557,7 +557,7 @@ choice
config PPC_4K_PAGES
bool "4k page size"
- select HAVE_ARCH_SOFT_DIRTY if CHECKPOINT_RESTORE && PPC_BOOK3S
+ select HAVE_ARCH_SOFT_DIRTY if CHECKPOINT_RESTORE && PPC_BOOK3S_64
config PPC_16K_PAGES
bool "16k page size"
@@ -566,7 +566,7 @@ config PPC_16K_PAGES
config PPC_64K_PAGES
bool "64k page size"
depends on !PPC_FSL_BOOK3E && (44x || PPC_STD_MMU_64 || PPC_BOOK3E_64)
- select HAVE_ARCH_SOFT_DIRTY if CHECKPOINT_RESTORE && PPC_BOOK3S
+ select HAVE_ARCH_SOFT_DIRTY if CHECKPOINT_RESTORE && PPC_BOOK3S_64
config PPC_256K_PAGES
bool "256k page size"

View File

@ -8,11 +8,9 @@ Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN mmap patch aufs4.x-rcN mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 4f764c2..229de5e 100644
--- a/fs/proc/base.c --- a/fs/proc/base.c
+++ b/fs/proc/base.c +++ b/fs/proc/base.c
@@ -1933,7 +1933,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path) @@ -1933,7 +1933,7 @@ static int map_files_get_link(struct den
down_read(&mm->mmap_sem); down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end); vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) { if (vma && vma->vm_file) {
@ -21,11 +19,9 @@ index 4f764c2..229de5e 100644
path_get(path); path_get(path);
rc = 0; rc = 0;
} }
diff --git a/fs/proc/nommu.c b/fs/proc/nommu.c
index f8595e8..cb8eda0 100644
--- a/fs/proc/nommu.c --- a/fs/proc/nommu.c
+++ b/fs/proc/nommu.c +++ b/fs/proc/nommu.c
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_file *m, struct vm_region *region) @@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_
file = region->vm_file; file = region->vm_file;
if (file) { if (file) {
@ -37,11 +33,9 @@ index f8595e8..cb8eda0 100644
dev = inode->i_sb->s_dev; dev = inode->i_sb->s_dev;
ino = inode->i_ino; ino = inode->i_ino;
} }
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index fa95ab2..d440354 100644
--- a/fs/proc/task_mmu.c --- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c +++ b/fs/proc/task_mmu.c
@@ -298,7 +298,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid) @@ -298,7 +298,10 @@ show_map_vma(struct seq_file *m, struct
const char *name = NULL; const char *name = NULL;
if (file) { if (file) {
@ -53,7 +47,7 @@ index fa95ab2..d440354 100644
dev = inode->i_sb->s_dev; dev = inode->i_sb->s_dev;
ino = inode->i_ino; ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT; pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1576,7 +1579,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid) @@ -1576,7 +1579,7 @@ static int show_numa_map(struct seq_file
struct proc_maps_private *proc_priv = &numa_priv->proc_maps; struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v; struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md; struct numa_maps *md = &numa_priv->md;
@ -62,11 +56,9 @@ index fa95ab2..d440354 100644
struct mm_struct *mm = vma->vm_mm; struct mm_struct *mm = vma->vm_mm;
struct mm_walk walk = { struct mm_walk walk = {
.hugetlb_entry = gather_hugetlb_stats, .hugetlb_entry = gather_hugetlb_stats,
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index faacb0c..17b43be 100644
--- a/fs/proc/task_nommu.c --- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c +++ b/fs/proc/task_nommu.c
@@ -163,7 +163,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma, @@ -163,7 +163,10 @@ static int nommu_vma_show(struct seq_fil
file = vma->vm_file; file = vma->vm_file;
if (file) { if (file) {
@ -78,11 +70,9 @@ index faacb0c..17b43be 100644
dev = inode->i_sb->s_dev; dev = inode->i_sb->s_dev;
ino = inode->i_ino; ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT; pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 516e149..ddd5454 100644
--- a/include/linux/mm.h --- a/include/linux/mm.h
+++ b/include/linux/mm.h +++ b/include/linux/mm.h
@@ -1217,6 +1217,28 @@ static inline int fixup_user_fault(struct task_struct *tsk, @@ -1217,6 +1217,28 @@ static inline int fixup_user_fault(struc
} }
#endif #endif
@ -111,8 +101,6 @@ index 516e149..ddd5454 100644
extern int access_process_vm(struct task_struct *tsk, unsigned long addr, void *buf, int len, int write); extern int access_process_vm(struct task_struct *tsk, unsigned long addr, void *buf, int len, int write);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr, extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
void *buf, int len, int write); void *buf, int len, int write);
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 624b78b..1be91c5 100644
--- a/include/linux/mm_types.h --- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h +++ b/include/linux/mm_types.h
@@ -269,6 +269,7 @@ struct vm_region { @@ -269,6 +269,7 @@ struct vm_region {
@ -131,11 +119,9 @@ index 624b78b..1be91c5 100644
void * vm_private_data; /* was vm_pte (shared mem) */ void * vm_private_data; /* was vm_pte (shared mem) */
#ifndef CONFIG_MMU #ifndef CONFIG_MMU
diff --git a/kernel/fork.c b/kernel/fork.c
index 2e391c7..6c4215c 100644
--- a/kernel/fork.c --- a/kernel/fork.c
+++ b/kernel/fork.c +++ b/kernel/fork.c
@@ -464,7 +464,7 @@ static int dup_mmap(struct mm_struct *mm, struct mm_struct *oldmm) @@ -464,7 +464,7 @@ static int dup_mmap(struct mm_struct *mm
struct inode *inode = file_inode(file); struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping; struct address_space *mapping = file->f_mapping;
@ -144,11 +130,9 @@ index 2e391c7..6c4215c 100644
if (tmp->vm_flags & VM_DENYWRITE) if (tmp->vm_flags & VM_DENYWRITE)
atomic_dec(&inode->i_writecount); atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping); i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index 2ed4319..e3a53f5 100644
--- a/mm/Makefile --- a/mm/Makefile
+++ b/mm/Makefile +++ b/mm/Makefile
@@ -21,7 +21,7 @@ obj-y := filemap.o mempool.o oom_kill.o \ @@ -21,7 +21,7 @@ obj-y := filemap.o mempool.o oom_kill.
mm_init.o mmu_context.o percpu.o slab_common.o \ mm_init.o mmu_context.o percpu.o slab_common.o \
compaction.o vmacache.o \ compaction.o vmacache.o \
interval_tree.o list_lru.o workingset.o \ interval_tree.o list_lru.o workingset.o \
@ -157,11 +141,9 @@ index 2ed4319..e3a53f5 100644
obj-y += init-mm.o obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index bc94386..25cdcef 100644
--- a/mm/filemap.c --- a/mm/filemap.c
+++ b/mm/filemap.c +++ b/mm/filemap.c
@@ -2209,7 +2209,7 @@ int filemap_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf) @@ -2210,7 +2210,7 @@ int filemap_page_mkwrite(struct vm_area_
int ret = VM_FAULT_LOCKED; int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb); sb_start_pagefault(inode->i_sb);
@ -170,11 +152,9 @@ index bc94386..25cdcef 100644
lock_page(page); lock_page(page);
if (page->mapping != inode->i_mapping) { if (page->mapping != inode->i_mapping) {
unlock_page(page); unlock_page(page);
diff --git a/mm/memory.c b/mm/memory.c
index 635451a..f589a4e 100644
--- a/mm/memory.c --- a/mm/memory.c
+++ b/mm/memory.c +++ b/mm/memory.c
@@ -2042,7 +2042,7 @@ static inline int wp_page_reuse(struct mm_struct *mm, @@ -2042,7 +2042,7 @@ static inline int wp_page_reuse(struct m
} }
if (!page_mkwrite) if (!page_mkwrite)
@ -183,11 +163,9 @@ index 635451a..f589a4e 100644
} }
return VM_FAULT_WRITE; return VM_FAULT_WRITE;
diff --git a/mm/mmap.c b/mm/mmap.c
index 2f2415a..d5943a1 100644
--- a/mm/mmap.c --- a/mm/mmap.c
+++ b/mm/mmap.c +++ b/mm/mmap.c
@@ -290,7 +290,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma) @@ -290,7 +290,7 @@ static struct vm_area_struct *remove_vma
if (vma->vm_ops && vma->vm_ops->close) if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma); vma->vm_ops->close(vma);
if (vma->vm_file) if (vma->vm_file)
@ -196,7 +174,7 @@ index 2f2415a..d5943a1 100644
mpol_put(vma_policy(vma)); mpol_put(vma_policy(vma));
kmem_cache_free(vm_area_cachep, vma); kmem_cache_free(vm_area_cachep, vma);
return next; return next;
@@ -909,7 +909,7 @@ again: remove_next = 1 + (end > next->vm_end); @@ -909,7 +909,7 @@ again: remove_next = 1 + (end > next->
if (remove_next) { if (remove_next) {
if (file) { if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end); uprobe_munmap(next, next->vm_start, next->vm_end);
@ -215,7 +193,7 @@ index 2f2415a..d5943a1 100644
/* Undo any partial mapping done by a device driver. */ /* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end); unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2479,7 +2479,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma, @@ -2479,7 +2479,7 @@ static int __split_vma(struct mm_struct
goto out_free_mpol; goto out_free_mpol;
if (new->vm_file) if (new->vm_file)
@ -224,7 +202,7 @@ index 2f2415a..d5943a1 100644
if (new->vm_ops && new->vm_ops->open) if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new); new->vm_ops->open(new);
@@ -2498,7 +2498,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma, @@ -2498,7 +2498,7 @@ static int __split_vma(struct mm_struct
if (new->vm_ops && new->vm_ops->close) if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new); new->vm_ops->close(new);
if (new->vm_file) if (new->vm_file)
@ -233,7 +211,7 @@ index 2f2415a..d5943a1 100644
unlink_anon_vmas(new); unlink_anon_vmas(new);
out_free_mpol: out_free_mpol:
mpol_put(vma_policy(new)); mpol_put(vma_policy(new));
@@ -2640,7 +2640,6 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size, @@ -2640,7 +2640,6 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
struct vm_area_struct *vma; struct vm_area_struct *vma;
unsigned long populate = 0; unsigned long populate = 0;
unsigned long ret = -EINVAL; unsigned long ret = -EINVAL;
@ -241,8 +219,8 @@ index 2f2415a..d5943a1 100644
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. " pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. "
"See Documentation/vm/remap_file_pages.txt.\n", "See Documentation/vm/remap_file_pages.txt.\n",
@@ -2684,10 +2683,10 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size, @@ -2708,10 +2707,10 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
munlock_vma_pages_range(vma, start, start + size); }
} }
- file = get_file(vma->vm_file); - file = get_file(vma->vm_file);
@ -254,7 +232,7 @@ index 2f2415a..d5943a1 100644
out: out:
up_write(&mm->mmap_sem); up_write(&mm->mmap_sem);
if (populate) if (populate)
@@ -2958,7 +2957,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap, @@ -2982,7 +2981,7 @@ struct vm_area_struct *copy_vma(struct v
if (anon_vma_clone(new_vma, vma)) if (anon_vma_clone(new_vma, vma))
goto out_free_mempol; goto out_free_mempol;
if (new_vma->vm_file) if (new_vma->vm_file)
@ -263,11 +241,9 @@ index 2f2415a..d5943a1 100644
if (new_vma->vm_ops && new_vma->vm_ops->open) if (new_vma->vm_ops && new_vma->vm_ops->open)
new_vma->vm_ops->open(new_vma); new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent); vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index fbf6f0f1..1a4a06d 100644
--- a/mm/nommu.c --- a/mm/nommu.c
+++ b/mm/nommu.c +++ b/mm/nommu.c
@@ -671,7 +671,7 @@ static void __put_nommu_region(struct vm_region *region) @@ -671,7 +671,7 @@ static void __put_nommu_region(struct vm
up_write(&nommu_region_sem); up_write(&nommu_region_sem);
if (region->vm_file) if (region->vm_file)
@ -276,7 +252,7 @@ index fbf6f0f1..1a4a06d 100644
/* IO memory and memory shared directly out of the pagecache /* IO memory and memory shared directly out of the pagecache
* from ramfs/tmpfs mustn't be released here */ * from ramfs/tmpfs mustn't be released here */
@@ -829,7 +829,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma) @@ -829,7 +829,7 @@ static void delete_vma(struct mm_struct
if (vma->vm_ops && vma->vm_ops->close) if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma); vma->vm_ops->close(vma);
if (vma->vm_file) if (vma->vm_file)
@ -307,9 +283,6 @@ index fbf6f0f1..1a4a06d 100644
kmem_cache_free(vm_area_cachep, vma); kmem_cache_free(vm_area_cachep, vma);
return ret; return ret;
diff --git a/mm/prfile.c b/mm/prfile.c
new file mode 100644
index 0000000..b323b8a
--- /dev/null --- /dev/null
+++ b/mm/prfile.c +++ b/mm/prfile.c
@@ -0,0 +1,86 @@ @@ -0,0 +1,86 @@

View File

@ -8,8 +8,6 @@ Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN standalone patch aufs4.x-rcN standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index 63b22d7..4dcd979 100644
--- a/fs/dcache.c --- a/fs/dcache.c
+++ b/fs/dcache.c +++ b/fs/dcache.c
@@ -1272,6 +1272,7 @@ rename_retry: @@ -1272,6 +1272,7 @@ rename_retry:
@ -20,11 +18,9 @@ index 63b22d7..4dcd979 100644
/* /*
* Search for at least 1 mount point in the dentry's subdirs. * Search for at least 1 mount point in the dentry's subdirs.
diff --git a/fs/exec.c b/fs/exec.c
index dcd4ac7..f4e040f 100644
--- a/fs/exec.c --- a/fs/exec.c
+++ b/fs/exec.c +++ b/fs/exec.c
@@ -103,6 +103,7 @@ bool path_noexec(const struct path *path) @@ -103,6 +103,7 @@ bool path_noexec(const struct path *path
return (path->mnt->mnt_flags & MNT_NOEXEC) || return (path->mnt->mnt_flags & MNT_NOEXEC) ||
(path->mnt->mnt_sb->s_iflags & SB_I_NOEXEC); (path->mnt->mnt_sb->s_iflags & SB_I_NOEXEC);
} }
@ -32,8 +28,6 @@ index dcd4ac7..f4e040f 100644
#ifdef CONFIG_USELIB #ifdef CONFIG_USELIB
/* /*
diff --git a/fs/file_table.c b/fs/file_table.c
index ad17e05..38e046a 100644
--- a/fs/file_table.c --- a/fs/file_table.c
+++ b/fs/file_table.c +++ b/fs/file_table.c
@@ -147,6 +147,7 @@ over: @@ -147,6 +147,7 @@ over:
@ -68,11 +62,9 @@ index ad17e05..38e046a 100644
void __init files_init(void) void __init files_init(void)
{ {
diff --git a/fs/namespace.c b/fs/namespace.c
index 4fb1691..765ebc3 100644
--- a/fs/namespace.c --- a/fs/namespace.c
+++ b/fs/namespace.c +++ b/fs/namespace.c
@@ -463,6 +463,7 @@ void __mnt_drop_write(struct vfsmount *mnt) @@ -463,6 +463,7 @@ void __mnt_drop_write(struct vfsmount *m
mnt_dec_writers(real_mount(mnt)); mnt_dec_writers(real_mount(mnt));
preempt_enable(); preempt_enable();
} }
@ -80,7 +72,7 @@ index 4fb1691..765ebc3 100644
/** /**
* mnt_drop_write - give up write access to a mount * mnt_drop_write - give up write access to a mount
@@ -1811,6 +1812,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg, @@ -1811,6 +1812,7 @@ int iterate_mounts(int (*f)(struct vfsmo
} }
return 0; return 0;
} }
@ -88,8 +80,6 @@ index 4fb1691..765ebc3 100644
static void cleanup_group_ids(struct mount *mnt, struct mount *end) static void cleanup_group_ids(struct mount *mnt, struct mount *end)
{ {
diff --git a/fs/notify/group.c b/fs/notify/group.c
index d16b62c..06ca6bc 100644
--- a/fs/notify/group.c --- a/fs/notify/group.c
+++ b/fs/notify/group.c +++ b/fs/notify/group.c
@@ -22,6 +22,7 @@ @@ -22,6 +22,7 @@
@ -100,7 +90,7 @@ index d16b62c..06ca6bc 100644
#include <linux/fsnotify_backend.h> #include <linux/fsnotify_backend.h>
#include "fsnotify.h" #include "fsnotify.h"
@@ -72,6 +73,7 @@ void fsnotify_get_group(struct fsnotify_group *group) @@ -72,6 +73,7 @@ void fsnotify_get_group(struct fsnotify_
{ {
atomic_inc(&group->refcnt); atomic_inc(&group->refcnt);
} }
@ -108,7 +98,7 @@ index d16b62c..06ca6bc 100644
/* /*
* Drop a reference to a group. Free it if it's through. * Drop a reference to a group. Free it if it's through.
@@ -81,6 +83,7 @@ void fsnotify_put_group(struct fsnotify_group *group) @@ -81,6 +83,7 @@ void fsnotify_put_group(struct fsnotify_
if (atomic_dec_and_test(&group->refcnt)) if (atomic_dec_and_test(&group->refcnt))
fsnotify_final_destroy_group(group); fsnotify_final_destroy_group(group);
} }
@ -116,7 +106,7 @@ index d16b62c..06ca6bc 100644
/* /*
* Create a new fsnotify_group and hold a reference for the group returned. * Create a new fsnotify_group and hold a reference for the group returned.
@@ -109,6 +112,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops) @@ -109,6 +112,7 @@ struct fsnotify_group *fsnotify_alloc_gr
return group; return group;
} }
@ -124,11 +114,9 @@ index d16b62c..06ca6bc 100644
int fsnotify_fasync(int fd, struct file *file, int on) int fsnotify_fasync(int fd, struct file *file, int on)
{ {
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index cfcbf11..2c024528 100644
--- a/fs/notify/mark.c --- a/fs/notify/mark.c
+++ b/fs/notify/mark.c +++ b/fs/notify/mark.c
@@ -106,6 +106,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark) @@ -113,6 +113,7 @@ void fsnotify_put_mark(struct fsnotify_m
mark->free_mark(mark); mark->free_mark(mark);
} }
} }
@ -136,7 +124,7 @@ index cfcbf11..2c024528 100644
/* Calculate mask of events for a list of marks */ /* Calculate mask of events for a list of marks */
u32 fsnotify_recalc_mask(struct hlist_head *head) u32 fsnotify_recalc_mask(struct hlist_head *head)
@@ -211,6 +212,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark, @@ -213,6 +214,7 @@ void fsnotify_destroy_mark(struct fsnoti
mutex_unlock(&group->mark_mutex); mutex_unlock(&group->mark_mutex);
fsnotify_free_mark(mark); fsnotify_free_mark(mark);
} }
@ -144,24 +132,22 @@ index cfcbf11..2c024528 100644
void fsnotify_destroy_marks(struct hlist_head *head, spinlock_t *lock) void fsnotify_destroy_marks(struct hlist_head *head, spinlock_t *lock)
{ {
@@ -391,6 +393,7 @@ err: @@ -398,6 +400,7 @@ err:
call_srcu(&fsnotify_mark_srcu, &mark->g_rcu, fsnotify_mark_free_rcu);
return ret; return ret;
} }
+EXPORT_SYMBOL_GPL(fsnotify_add_mark); +EXPORT_SYMBOL_GPL(fsnotify_add_mark);
int fsnotify_add_mark(struct fsnotify_mark *mark, struct fsnotify_group *group, int fsnotify_add_mark(struct fsnotify_mark *mark, struct fsnotify_group *group,
struct inode *inode, struct vfsmount *mnt, int allow_dups) struct inode *inode, struct vfsmount *mnt, int allow_dups)
@@ -491,3 +494,4 @@ void fsnotify_init_mark(struct fsnotify_mark *mark, @@ -516,3 +519,4 @@ static void fsnotify_mark_destroy(struct
atomic_set(&mark->refcnt, 1); fsnotify_put_mark(mark);
mark->free_mark = free_mark; }
} }
+EXPORT_SYMBOL_GPL(fsnotify_init_mark); +EXPORT_SYMBOL_GPL(fsnotify_init_mark);
diff --git a/fs/open.c b/fs/open.c
index 55bdc75..e0606c6 100644
--- a/fs/open.c --- a/fs/open.c
+++ b/fs/open.c +++ b/fs/open.c
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs, @@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, l
inode_unlock(dentry->d_inode); inode_unlock(dentry->d_inode);
return ret; return ret;
} }
@ -177,8 +163,6 @@ index 55bdc75..e0606c6 100644
static int do_dentry_open(struct file *f, static int do_dentry_open(struct file *f,
struct inode *inode, struct inode *inode,
diff --git a/fs/read_write.c b/fs/read_write.c
index d38892e..fbd7169 100644
--- a/fs/read_write.c --- a/fs/read_write.c
+++ b/fs/read_write.c +++ b/fs/read_write.c
@@ -543,6 +543,7 @@ vfs_readf_t vfs_readf(struct file *file) @@ -543,6 +543,7 @@ vfs_readf_t vfs_readf(struct file *file)
@ -189,7 +173,7 @@ index d38892e..fbd7169 100644
vfs_writef_t vfs_writef(struct file *file) vfs_writef_t vfs_writef(struct file *file)
{ {
@@ -554,6 +555,7 @@ vfs_writef_t vfs_writef(struct file *file) @@ -554,6 +555,7 @@ vfs_writef_t vfs_writef(struct file *fil
return new_sync_write; return new_sync_write;
return ERR_PTR(-ENOSYS); return ERR_PTR(-ENOSYS);
} }
@ -197,11 +181,9 @@ index d38892e..fbd7169 100644
ssize_t __kernel_write(struct file *file, const char *buf, size_t count, loff_t *pos) ssize_t __kernel_write(struct file *file, const char *buf, size_t count, loff_t *pos)
{ {
diff --git a/fs/splice.c b/fs/splice.c
index 93aee51..5316378 100644
--- a/fs/splice.c --- a/fs/splice.c
+++ b/fs/splice.c +++ b/fs/splice.c
@@ -1121,6 +1121,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out, @@ -1121,6 +1121,7 @@ long do_splice_from(struct pipe_inode_in
return splice_write(pipe, out, ppos, len, flags); return splice_write(pipe, out, ppos, len, flags);
} }
@ -209,7 +191,7 @@ index 93aee51..5316378 100644
/* /*
* Attempt to initiate a splice from a file to a pipe. * Attempt to initiate a splice from a file to a pipe.
@@ -1147,6 +1148,7 @@ long do_splice_to(struct file *in, loff_t *ppos, @@ -1147,6 +1148,7 @@ long do_splice_to(struct file *in, loff_
return splice_read(in, ppos, pipe, len, flags); return splice_read(in, ppos, pipe, len, flags);
} }
@ -217,11 +199,9 @@ index 93aee51..5316378 100644
/** /**
* splice_direct_to_actor - splices data directly between two non-pipes * splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/xattr.c b/fs/xattr.c
index 07d0e47..20c8815 100644
--- a/fs/xattr.c --- a/fs/xattr.c
+++ b/fs/xattr.c +++ b/fs/xattr.c
@@ -207,6 +207,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value, @@ -207,6 +207,7 @@ vfs_getxattr_alloc(struct dentry *dentry
*xattr_value = value; *xattr_value = value;
return error; return error;
} }
@ -229,8 +209,6 @@ index 07d0e47..20c8815 100644
ssize_t ssize_t
vfs_getxattr(struct dentry *dentry, const char *name, void *value, size_t size) vfs_getxattr(struct dentry *dentry, const char *name, void *value, size_t size)
diff --git a/kernel/task_work.c b/kernel/task_work.c
index 53fa971..f80d564 100644
--- a/kernel/task_work.c --- a/kernel/task_work.c
+++ b/kernel/task_work.c +++ b/kernel/task_work.c
@@ -118,3 +118,4 @@ void task_work_run(void) @@ -118,3 +118,4 @@ void task_work_run(void)
@ -238,8 +216,6 @@ index 53fa971..f80d564 100644
} }
} }
+EXPORT_SYMBOL_GPL(task_work_run); +EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index 48071ed..bf82414 100644
--- a/security/commoncap.c --- a/security/commoncap.c
+++ b/security/commoncap.c +++ b/security/commoncap.c
@@ -1058,12 +1058,14 @@ int cap_mmap_addr(unsigned long addr) @@ -1058,12 +1058,14 @@ int cap_mmap_addr(unsigned long addr)
@ -257,8 +233,6 @@ index 48071ed..bf82414 100644
#ifdef CONFIG_SECURITY #ifdef CONFIG_SECURITY
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 03c1652..b00aa76 100644
--- a/security/device_cgroup.c --- a/security/device_cgroup.c
+++ b/security/device_cgroup.c +++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@ @@ -7,6 +7,7 @@
@ -269,7 +243,7 @@ index 03c1652..b00aa76 100644
#include <linux/list.h> #include <linux/list.h>
#include <linux/uaccess.h> #include <linux/uaccess.h>
#include <linux/seq_file.h> #include <linux/seq_file.h>
@@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct inode *inode, int mask) @@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct
return __devcgroup_check_permission(type, imajor(inode), iminor(inode), return __devcgroup_check_permission(type, imajor(inode), iminor(inode),
access); access);
} }
@ -277,11 +251,9 @@ index 03c1652..b00aa76 100644
int devcgroup_inode_mknod(int mode, dev_t dev) int devcgroup_inode_mknod(int mode, dev_t dev)
{ {
diff --git a/security/security.c b/security/security.c
index e8ffd92..6f07901 100644
--- a/security/security.c --- a/security/security.c
+++ b/security/security.c +++ b/security/security.c
@@ -433,6 +433,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry) @@ -433,6 +433,7 @@ int security_path_rmdir(struct path *dir
return 0; return 0;
return call_int_hook(path_rmdir, 0, dir, dentry); return call_int_hook(path_rmdir, 0, dir, dentry);
} }
@ -289,7 +261,7 @@ index e8ffd92..6f07901 100644
int security_path_unlink(struct path *dir, struct dentry *dentry) int security_path_unlink(struct path *dir, struct dentry *dentry)
{ {
@@ -449,6 +450,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry, @@ -449,6 +450,7 @@ int security_path_symlink(struct path *d
return 0; return 0;
return call_int_hook(path_symlink, 0, dir, dentry, old_name); return call_int_hook(path_symlink, 0, dir, dentry, old_name);
} }
@ -297,7 +269,7 @@ index e8ffd92..6f07901 100644
int security_path_link(struct dentry *old_dentry, struct path *new_dir, int security_path_link(struct dentry *old_dentry, struct path *new_dir,
struct dentry *new_dentry) struct dentry *new_dentry)
@@ -457,6 +459,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir, @@ -457,6 +459,7 @@ int security_path_link(struct dentry *ol
return 0; return 0;
return call_int_hook(path_link, 0, old_dentry, new_dir, new_dentry); return call_int_hook(path_link, 0, old_dentry, new_dir, new_dentry);
} }
@ -305,7 +277,7 @@ index e8ffd92..6f07901 100644
int security_path_rename(struct path *old_dir, struct dentry *old_dentry, int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
struct path *new_dir, struct dentry *new_dentry, struct path *new_dir, struct dentry *new_dentry,
@@ -484,6 +487,7 @@ int security_path_truncate(struct path *path) @@ -484,6 +487,7 @@ int security_path_truncate(struct path *
return 0; return 0;
return call_int_hook(path_truncate, 0, path); return call_int_hook(path_truncate, 0, path);
} }
@ -313,7 +285,7 @@ index e8ffd92..6f07901 100644
int security_path_chmod(struct path *path, umode_t mode) int security_path_chmod(struct path *path, umode_t mode)
{ {
@@ -491,6 +495,7 @@ int security_path_chmod(struct path *path, umode_t mode) @@ -491,6 +495,7 @@ int security_path_chmod(struct path *pat
return 0; return 0;
return call_int_hook(path_chmod, 0, path, mode); return call_int_hook(path_chmod, 0, path, mode);
} }
@ -321,7 +293,7 @@ index e8ffd92..6f07901 100644
int security_path_chown(struct path *path, kuid_t uid, kgid_t gid) int security_path_chown(struct path *path, kuid_t uid, kgid_t gid)
{ {
@@ -498,6 +503,7 @@ int security_path_chown(struct path *path, kuid_t uid, kgid_t gid) @@ -498,6 +503,7 @@ int security_path_chown(struct path *pat
return 0; return 0;
return call_int_hook(path_chown, 0, path, uid, gid); return call_int_hook(path_chown, 0, path, uid, gid);
} }
@ -329,7 +301,7 @@ index e8ffd92..6f07901 100644
int security_path_chroot(struct path *path) int security_path_chroot(struct path *path)
{ {
@@ -583,6 +589,7 @@ int security_inode_readlink(struct dentry *dentry) @@ -583,6 +589,7 @@ int security_inode_readlink(struct dentr
return 0; return 0;
return call_int_hook(inode_readlink, 0, dentry); return call_int_hook(inode_readlink, 0, dentry);
} }
@ -337,7 +309,7 @@ index e8ffd92..6f07901 100644
int security_inode_follow_link(struct dentry *dentry, struct inode *inode, int security_inode_follow_link(struct dentry *dentry, struct inode *inode,
bool rcu) bool rcu)
@@ -598,6 +605,7 @@ int security_inode_permission(struct inode *inode, int mask) @@ -598,6 +605,7 @@ int security_inode_permission(struct ino
return 0; return 0;
return call_int_hook(inode_permission, 0, inode, mask); return call_int_hook(inode_permission, 0, inode, mask);
} }
@ -345,7 +317,7 @@ index e8ffd92..6f07901 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr) int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{ {
@@ -736,6 +744,7 @@ int security_file_permission(struct file *file, int mask) @@ -736,6 +744,7 @@ int security_file_permission(struct file
return fsnotify_perm(file, mask); return fsnotify_perm(file, mask);
} }
@ -353,7 +325,7 @@ index e8ffd92..6f07901 100644
int security_file_alloc(struct file *file) int security_file_alloc(struct file *file)
{ {
@@ -795,6 +804,7 @@ int security_mmap_file(struct file *file, unsigned long prot, @@ -795,6 +804,7 @@ int security_mmap_file(struct file *file
return ret; return ret;
return ima_file_mmap(file, prot); return ima_file_mmap(file, prot);
} }

View File

@ -77,4 +77,3 @@ bugfix/x86/x86-efi-build-our-own-page-table-structures.patch
bugfix/x86/x86-efi-setup-separate-efi-page-tables-in-kexec-path.patch bugfix/x86/x86-efi-setup-separate-efi-page-tables-in-kexec-path.patch
debian/i386-686-pae-pci-set-pci-nobios-by-default.patch debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
bugfix/all/iff_no_queue-fix-for-drivers-not-calling-ether_setup.patch bugfix/all/iff_no_queue-fix-for-drivers-not-calling-ether_setup.patch
bugfix/powerpc/powerpc-mm-fix-have_arch_soft_dirty-dependencies.patch