[powerpc] mm: Fix HAVE_ARCH_SOFT_DIRTY dependencies (fixes FTBFS)

Drop the previous attempted fix, which didn't work.
This commit is contained in:
Ben Hutchings 2016-02-20 17:29:46 +00:00
parent 1036674239
commit 416a13b622
4 changed files with 32 additions and 30 deletions

2
debian/changelog vendored
View File

@ -2,7 +2,7 @@ linux (4.5~rc4-1~exp2) UNRELEASED; urgency=medium
* [armel/versatile] Enable GPIOLIB, needed to build smc91x driver with
OF enabled (fixes FTBFS)
* swapops.h: Add #include to fix build failure on powerpc
* [powerpc] mm: Fix HAVE_ARCH_SOFT_DIRTY dependencies (fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 19 Feb 2016 02:02:22 +0000

View File

@ -0,0 +1,30 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 20 Feb 2016 17:24:36 +0000
Subject: powerpc/mm: Fix HAVE_ARCH_SOFT_DIRTY dependencies
Soft dirty bit support was only implemented for 64-bit Book3S, and
32-bit configurations currently fail to build.
Fixes: 7207f43665b8 ("powerpc/mm: Add page soft dirty tracking")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/arch/powerpc/Kconfig
+++ b/arch/powerpc/Kconfig
@@ -557,7 +557,7 @@ choice
config PPC_4K_PAGES
bool "4k page size"
- select HAVE_ARCH_SOFT_DIRTY if CHECKPOINT_RESTORE && PPC_BOOK3S
+ select HAVE_ARCH_SOFT_DIRTY if CHECKPOINT_RESTORE && PPC_BOOK3S_64
config PPC_16K_PAGES
bool "16k page size"
@@ -566,7 +566,7 @@ config PPC_16K_PAGES
config PPC_64K_PAGES
bool "64k page size"
depends on !PPC_FSL_BOOK3E && (44x || PPC_STD_MMU_64 || PPC_BOOK3E_64)
- select HAVE_ARCH_SOFT_DIRTY if CHECKPOINT_RESTORE && PPC_BOOK3S
+ select HAVE_ARCH_SOFT_DIRTY if CHECKPOINT_RESTORE && PPC_BOOK3S_64
config PPC_256K_PAGES
bool "256k page size"

View File

@ -1,28 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 20 Feb 2016 04:19:41 +0000
Subject: swapops.h: Add #include to fix build failure on powerpc
<linux/swapops.h> uses pte_swp_soft_dirty() and
pte_swp_clear_soft_dirty(), which are defined by <ams/pgtable.h>. It
appears that in most cases it is either indirectly included or has
previously been included. However, as of 4.5-rc4 this is not the case
when building kernel/power/swap.c in a 32-bit powerpc configuration.
References: https://buildd.debian.org/status/fetch.php?pkg=linux&arch=powerpc&ver=4.5%7Erc4-1%7Eexp1&stamp=1455791718
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
include/linux/swapops.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/linux/swapops.h b/include/linux/swapops.h
index 5c3a5f3e7eec..bac77160327f 100644
--- a/include/linux/swapops.h
+++ b/include/linux/swapops.h
@@ -3,6 +3,7 @@
#include <linux/radix-tree.h>
#include <linux/bug.h>
+#include <asm/pgtable.h>
/*
* swapcache pages are stored in the swapper_space radix tree. We want to

View File

@ -77,4 +77,4 @@ bugfix/x86/x86-efi-build-our-own-page-table-structures.patch
bugfix/x86/x86-efi-setup-separate-efi-page-tables-in-kexec-path.patch
debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
bugfix/all/iff_no_queue-fix-for-drivers-not-calling-ether_setup.patch
bugfix/powerpc/swapops.h-add-include-to-fix-build-failure-on-powerp.patch
bugfix/powerpc/powerpc-mm-fix-have_arch_soft_dirty-dependencies.patch