Update to 4.5.2

As this includes changes to header_ops and dentry_operations, bump
the ABI number to 2.
This commit is contained in:
Ben Hutchings 2016-04-21 15:42:10 +01:00
parent c5cec59895
commit fe835b64b1
27 changed files with 105 additions and 326766 deletions

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

File diff suppressed because it is too large Load Diff

105
debian/changelog vendored
View File

@ -1,4 +1,106 @@
linux (4.5.1-2) UNRELEASED; urgency=medium
linux (4.5.2-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.5.2
- hwmon: (max1111) Return -ENODEV from max1111_read_channel if not
instantiated
- PKCS#7: pkcs7_validate_trust(): initialize the _trusted output argument
- [hppa] Fix SIGSYS signals in compat case
- [hppa] Fix and enable seccomp filter support
- [hppa] Avoid function pointers for kernel exception routines
- [hppa] Fix kernel crash with reversed copy_from_user()
- [hppa] Unbreak handling exceptions from kernel modules
- ALSA: timer: Use mod_timer() for rearming the system timer
- mm: fix invalid node in alloc_migrate_target()
- [powerpc*] mm: Fixup preempt underflow with huge pages
- [s390x] /mm: handle PTE-mapped tail pages in fast gup
- [x86] libnvdimm: fix smart data retrieval
- [x86] libnvdimm, pfn: fix uuid validation
- [powerpc*] process: Fix altivec SPR not being saved
- compiler-gcc: disable -ftracer for __noclone functions
- drm/dp: move hw_mutex up the call stack
- drm/udl: Use unlocked gem unreferencing
- [x86] drm/amd/powerplay: fix segment fault issue in multi-display case.
- [x86] drm/amdgpu/gmc: move vram type fetching into sw_init
- [x86] drm/amdgpu/gmc: use proper register for vram type on Fiji
- xen/events: Mask a moving irq
- net: validate variable length ll headers
- ax25: add link layer header validation function
- packet: validate variable length ll headers
- bpf: avoid copying junk bytes in bpf_get_current_comm()
- qlcnic: Remove unnecessary usage of atomic_t
- qlcnic: Fix mailbox completion handling during spurious interrupt
- macvtap: always pass ethernet header in linear
- bridge: allow zero ageing time
- ipv4: Don't do expensive useless work during inetdev destroy.
- net: Fix use after free in the recvmmsg exit path
- mlx4: add missing braces in verify_qp_parameters
- farsync: fix off-by-one bug in fst_add_one
- ath9k: fix buffer overrun for ar9287
- [armhf] net: mvneta: Fix spinlock usage
- ppp: ensure file->private_data can't be overridden
- tcp/dccp: remove obsolete WARN_ON() in icmp handlers
- qlge: Fix receive packets drop.
- bonding: fix bond_get_stats()
- ipv4: fix broadcast packets reception
- ipv4: initialize flowi4_flags before calling fib_lookup()
- ppp: take reference on channels netns
- xfrm: Fix crash observed during device unregistration and decryption
- ipv6: udp: fix UDP_MIB_IGNOREDMULTI updates
- bridge: Allow set bridge ageing time when switchdev disabled
- rtnl: fix msg size calculation in if_nlmsg_size()
- tun, bpf: fix suspicious RCU usage in tun_{attach, detach}_filter
- tuntap: restore default qdisc
- ipv4: l2tp: fix a potential issue in l2tp_ip_recv
- ipv6: l2tp: fix a potential issue in l2tp_ip6_recv
- ip6_tunnel: set rtnl_link_ops before calling register_netdevice
- ipv6: Count in extension headers in skb->network_header
- mpls: find_outdev: check for err ptr in addition to NULL check
- USB: uas: Limit qdepth at the scsi-host level
- USB: uas: Add a new NO_REPORT_LUNS quirk
- [x86] KVM: Inject pending interrupt even if pending nmi exist
- [x86] KVM: reduce default value of halt_poll_ns parameter
- pinctrl: pistachio: fix mfio84-89 function description and pinmux.
- pinctrl: sunxi: Fix A33 external interrupts not working
- pinctrl: freescale: imx: fix bogus check of of_iomap() return value
- au0828: fix au0828_v4l2_close() dev_state race condition
- au0828: Fix dev_state handling
- coda: fix error path in case of missing pdata on non-DT platform
- v4l: vsp1: Set the SRU CTRL0 register when starting the stream
- pcmcia: db1xxx_ss: fix last irq_to_gpio user
- rbd: use GFP_NOIO consistently for request allocations
- mac80211: properly deal with station hashtable insert errors
- mac80211: avoid excessive stack usage in sta_info
- mac80211: fix ibss scan parameters
- mac80211: fix unnecessary frame drops in mesh fwding
- mac80211: fix txq queue related crashes
- [armhf] gpio: pca953x: Use correct u16 value for register word write
- scsi: Do not attach VPD to devices that don't support it
- [armel,armhf]: 8550/1: protect idiv patching against undefined
gcc behavior
- iio: fix config watermark initial value
- iio: st_magn: always define ST_MAGN_TRIGGER_SET_STATE
- iio: accel: bmc150: fix endianness when reading axes
- iio: gyro: bmg160: fix buffer read values
- iio: gyro: bmg160: fix endianness when reading axes
- sd: Fix excessive capacity printing on devices with blocks bigger than
512 bytes
- fs: add file_dentry()
- nfs: use file_dentry()
- ext4 crypto: use dget_parent() in ext4_d_revalidate()
- ext4: use dget_parent() in ext4_file_open()
- ext4: use file_dentry()
- btrfs: fix crash/invalid memory access on fsync when using overlayfs
- ext4: ignore quota mount options if the quota feature is enabled
- iommu: Don't overwrite domain pointer when there is no default_domain
- Btrfs: fix file/data loss caused by fsync after rename and new inode
- [arm64] replace read_lock to rcu lock in call_step_hook
- mmc: sdhci: Fix regression setting power on Trats2 board
- ALSA: hda - Fix regression of monitor_present flag in eld proc file
- [x86] ALSA: usb-audio: Skip volume controls triggers hangup on Dell
USB Dock
- HID: wacom: fix Bamboo ONE oops
- HID: usbhid: fix inconsistent reset/resume/reset-resume behavior
[ Salvatore Bonaccorso ]
* [x86] xen: suppress hugetlbfs in PV guests (CVE-2016-3961)
@ -6,6 +108,7 @@ linux (4.5.1-2) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* fs: Consolidate softdep declarations in each module
* Bump ABI to 2
[ Aurelien Jarno ]
* [mips*] Emulate unaligned LDXC1 and SDXC1 instructions.

View File

@ -1,5 +1,5 @@
[abi]
abiname: 1
abiname: 2
[base]
arches:

View File

@ -1,94 +0,0 @@
From: "David S. Miller" <davem@davemloft.net>
Date: Sun, 13 Mar 2016 23:28:00 -0400
Subject: ipv4: Don't do expensive useless work during inetdev destroy.
Origin: https://git.kernel.org/linus/fbd40ea0180a2d328c5adc61414dc8bab9335ce2
When an inetdev is destroyed, every address assigned to the interface
is removed. And in this scenerio we do two pointless things which can
be very expensive if the number of assigned interfaces is large:
1) Address promotion. We are deleting all addresses, so there is no
point in doing this.
2) A full nf conntrack table purge for every address. We only need to
do this once, as is already caught by the existing
masq_dev_notifier so masq_inet_event() can skip this.
Reported-by: Solar Designer <solar@openwall.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
Tested-by: Cyrill Gorcunov <gorcunov@openvz.org>
---
net/ipv4/devinet.c | 4 ++++
net/ipv4/fib_frontend.c | 4 ++++
net/ipv4/netfilter/nf_nat_masquerade_ipv4.c | 12 ++++++++++--
3 files changed, 18 insertions(+), 2 deletions(-)
diff --git a/net/ipv4/devinet.c b/net/ipv4/devinet.c
index 65e76a48382c..e333bc86bd39 100644
--- a/net/ipv4/devinet.c
+++ b/net/ipv4/devinet.c
@@ -334,6 +334,9 @@ static void __inet_del_ifa(struct in_device *in_dev, struct in_ifaddr **ifap,
ASSERT_RTNL();
+ if (in_dev->dead)
+ goto no_promotions;
+
/* 1. Deleting primary ifaddr forces deletion all secondaries
* unless alias promotion is set
**/
@@ -380,6 +383,7 @@ static void __inet_del_ifa(struct in_device *in_dev, struct in_ifaddr **ifap,
fib_del_ifaddr(ifa, ifa1);
}
+no_promotions:
/* 2. Unlink it */
*ifap = ifa1->ifa_next;
diff --git a/net/ipv4/fib_frontend.c b/net/ipv4/fib_frontend.c
index 473447593060..21add552e56a 100644
--- a/net/ipv4/fib_frontend.c
+++ b/net/ipv4/fib_frontend.c
@@ -922,6 +922,9 @@ void fib_del_ifaddr(struct in_ifaddr *ifa, struct in_ifaddr *iprim)
subnet = 1;
}
+ if (in_dev->dead)
+ goto no_promotions;
+
/* Deletion is more complicated than add.
* We should take care of not to delete too much :-)
*
@@ -997,6 +1000,7 @@ void fib_del_ifaddr(struct in_ifaddr *ifa, struct in_ifaddr *iprim)
}
}
+no_promotions:
if (!(ok & BRD_OK))
fib_magic(RTM_DELROUTE, RTN_BROADCAST, ifa->ifa_broadcast, 32, prim);
if (subnet && ifa->ifa_prefixlen < 31) {
diff --git a/net/ipv4/netfilter/nf_nat_masquerade_ipv4.c b/net/ipv4/netfilter/nf_nat_masquerade_ipv4.c
index c6eb42100e9a..ea91058b5f6f 100644
--- a/net/ipv4/netfilter/nf_nat_masquerade_ipv4.c
+++ b/net/ipv4/netfilter/nf_nat_masquerade_ipv4.c
@@ -108,10 +108,18 @@ static int masq_inet_event(struct notifier_block *this,
unsigned long event,
void *ptr)
{
- struct net_device *dev = ((struct in_ifaddr *)ptr)->ifa_dev->dev;
+ struct in_device *idev = ((struct in_ifaddr *)ptr)->ifa_dev;
struct netdev_notifier_info info;
- netdev_notifier_info_init(&info, dev);
+ /* The masq_dev_notifier will catch the case of the device going
+ * down. So if the inetdev is dead and being destroyed we have
+ * no work to do. Otherwise this is an individual address removal
+ * and we have to perform the flush.
+ */
+ if (idev->dead)
+ return NOTIFY_DONE;
+
+ netdev_notifier_info_init(&info, idev->dev);
return masq_device_event(this, event, &info);
}

View File

@ -122,7 +122,6 @@ bugfix/x86/x86-mm-pat-fix-boot-crash-when-1gb-pages-are-not-supported.patch
bugfix/all/netfilter-x_tables-check-for-size-overflow.patch
bugfix/all/netfilter-x_tables-validate-e-target_offset-early.patch
bugfix/all/netfilter-x_tables-make-sure-e-next_offset-covers-re.patch
bugfix/all/ipv4-don-t-do-expensive-useless-work-during-inetdev-.patch
bugfix/x86/x86-mm-32-enable-full-randomization-on-i386-and-x86_.patch
bugfix/x86/x86-xen-suppress-hugetlbfs-in-PV-guests.patch
bugfix/all/USB-usbip-fix-potential-out-of-bounds-write.patch