add stable 2.6.32.9

svn path=/dists/sid/linux-2.6/; revision=15264
This commit is contained in:
Maximilian Attems 2010-02-23 16:44:54 +00:00
parent 143e861735
commit f45325a5fc
2 changed files with 1 additions and 60 deletions

2
debian/changelog vendored
View File

@ -18,7 +18,7 @@ linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
* hwmon: Add driver for VIA CPU core temperature.
* wireless: report reasonable bitrate for MCS rates through wext.
* efifb: fix framebuffer handoff. (bugzilla.k.o #15151)
* Add stable rc1 2.6.32.9:
* Add stable 2.6.32.9:
- drm/i915: Fix DDC on some systems by clearing BIOS GMBUS setup.
(closes: #567747)
- futex: Handle futex value corruption gracefully. (CVE-2010-0623)

View File

@ -1483,65 +1483,6 @@ index e0efc1a..bd58703 100644
ti->error = "Invalid stripe count";
return -EINVAL;
}
diff --git a/drivers/md/dm.c b/drivers/md/dm.c
index 724efc6..11d3e91 100644
--- a/drivers/md/dm.c
+++ b/drivers/md/dm.c
@@ -1487,11 +1487,15 @@ static int dm_prep_fn(struct request_queue *q, struct request *rq)
return BLKPREP_OK;
}
-static void map_request(struct dm_target *ti, struct request *rq,
- struct mapped_device *md)
+/*
+ * Returns:
+ * 0 : the request has been processed (not requeued)
+ * !0 : the request has been requeued
+ */
+static int map_request(struct dm_target *ti, struct request *clone,
+ struct mapped_device *md)
{
- int r;
- struct request *clone = rq->special;
+ int r, requeued = 0;
struct dm_rq_target_io *tio = clone->end_io_data;
/*
@@ -1516,6 +1520,7 @@ static void map_request(struct dm_target *ti, struct request *rq,
case DM_MAPIO_REQUEUE:
/* The target wants to requeue the I/O */
dm_requeue_unmapped_request(clone);
+ requeued = 1;
break;
default:
if (r > 0) {
@@ -1527,6 +1532,8 @@ static void map_request(struct dm_target *ti, struct request *rq,
dm_kill_unmapped_request(clone, r);
break;
}
+
+ return requeued;
}
/*
@@ -1568,12 +1575,16 @@ static void dm_request_fn(struct request_queue *q)
blk_start_request(rq);
spin_unlock(q->queue_lock);
- map_request(ti, rq, md);
+ if (map_request(ti, rq, md))
+ goto requeued;
spin_lock_irq(q->queue_lock);
}
goto out;
+requeued:
+ spin_lock_irq(q->queue_lock);
+
plug_and_out:
if (!elv_queue_empty(q))
/* Some requests still remain, retry later */
diff --git a/drivers/md/raid5.c b/drivers/md/raid5.c
index d29215d..431b9b2 100644
--- a/drivers/md/raid5.c