add vgaarb followon patch

previous wasn't complete.

svn path=/dists/sid/linux-2.6/; revision=15263
This commit is contained in:
Maximilian Attems 2010-02-23 11:25:51 +00:00
parent 5098f104e3
commit 143e861735
3 changed files with 35 additions and 0 deletions

1
debian/changelog vendored
View File

@ -29,6 +29,7 @@ linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
* vgaarb: fix incorrect dereference of userspace pointer.
* Bump ABI to 3.
* drm/i915: give up on 8xx lid status.
* vgaarb: fix "target=default" passing.
[ Bastian Blank ]
* Restrict access to sensitive SysRq keys by default.

View File

@ -0,0 +1,33 @@
From 2cc9116c2b37c525965d76a3e6def38913259427 Mon Sep 17 00:00:00 2001
From: Kyle McMartin <kyle@redhat.com>
Date: Tue, 16 Feb 2010 16:18:37 -0500
Subject: [PATCH] vgaarb: fix "target=default" passing
Commit 77c1ff3982c6b36961725dd19e872a1c07df7f3b fixed the userspace
pointer dereference, but introduced another bug pointed out by Eugene Teo
in RH bug #564264. Instead of comparing the point we were at in the string,
we instead compared the beginning of the string to "default".
Signed-off-by: Kyle McMartin <kyle@redhat.com>
Reported-by: Eugene Teo <eteo@redhat.com>
Signed-off-by: Dave Airlie <airlied@redhat.com>
---
drivers/gpu/vga/vgaarb.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/gpu/vga/vgaarb.c b/drivers/gpu/vga/vgaarb.c
index 24b56dc..2f6cf69 100644
--- a/drivers/gpu/vga/vgaarb.c
+++ b/drivers/gpu/vga/vgaarb.c
@@ -961,7 +961,7 @@ static ssize_t vga_arb_write(struct file *file, const char __user * buf,
remaining -= 7;
pr_devel("client 0x%p called 'target'\n", priv);
/* if target is default */
- if (!strncmp(kbuf, "default", 7))
+ if (!strncmp(curr_pos, "default", 7))
pdev = pci_dev_get(vga_default_device());
else {
if (!vga_pci_str_to_vars(curr_pos, remaining,
--
1.6.6.1

View File

@ -21,3 +21,4 @@
+ bugfix/all/drm-i915-give-up-on-8xx-lid-status.patch
+ features/arm/openrd-base-uart.patch
+ features/arm/dns323-rev-a1-powerled.patch
+ bugfix/all/vgaarb-fix-target-default-passing.patch