[armhf] deb-pkg: Add automatic support for armhf architecture

svn path=/dists/sid/linux/; revision=21827
This commit is contained in:
Ben Hutchings 2014-09-12 14:29:43 +00:00
parent 39f03a5534
commit ec2241f23d
3 changed files with 46 additions and 0 deletions

1
debian/changelog vendored
View File

@ -63,6 +63,7 @@ linux (3.16.2-3) UNRELEASED; urgency=medium
spectrum_cs to nic-wireless-modules
* builddeb: put the dbg files into the correct directory
* [ppc64el] deb-pkg: Add support for powerpc little endian
* [armhf] deb-pkg: Add automatic support for armhf architecture
[ Ian Campbell ]
* [armel/orion5x] udeb: Include mvmdio in nic-modules udeb.

View File

@ -0,0 +1,44 @@
Subject: deb-pkg: Add automatic support for armhf architecture
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 09 Jun 2014 01:21:34 +0100
Forwarded: http://mid.gmane.org/1402273294.23860.59.camel@deadeye.wl.decadent.org.uk
The Debian armhf architecture uses the ARM EABI hard-float variant,
whereas armel uses the soft-float variant. Although the kernel
doesn't use FP itself, CONFIG_VFP must be enabled to support
hard-float userland and will probably be disabled when supporting a
soft-float userland. So set the architecture to armhf by default when
CONFIG_AEABI and CONFIG_VFP are both enabled.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
v2: rebased
After discussion with Hector, we agreed this would be a worthwhile
change. Hector may later improve this by using gcc specs.
Ben.
scripts/package/builddeb | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
--- a/scripts/package/builddeb
+++ b/scripts/package/builddeb
@@ -45,7 +45,16 @@ create_package() {
arm64)
debarch=arm64 ;;
arm*)
- debarch=arm$(grep -q CONFIG_AEABI=y $KCONFIG_CONFIG && echo el || true) ;;
+ if grep -q CONFIG_AEABI=y $KCONFIG_CONFIG; then
+ if grep -q CONFIG_VFP=y $KCONFIG_CONFIG; then
+ debarch=armhf
+ else
+ debarch=armel
+ fi
+ else
+ debarch=arm
+ fi
+ ;;
*)
echo "" >&2
echo "** ** ** WARNING ** ** **" >&2

View File

@ -95,6 +95,7 @@ features/powerpc/KVM-PPC-Enable-IRQFD-support-for-the-XICS-interrupt-.patch
features/powerpc/deb-pkg-add-support-for-powerpc-little-endian.patch
features/x86/x86-memtest-WARN-if-bad-RAM-found.patch
features/x86/x86-make-x32-syscall-support-conditional.patch
features/arm/deb-pkg-add-automatic-support-for-armhf-architecture.patch
# Miscellaneous bug fixes
bugfix/all/misc-bmp085-Enable-building-as-a-module.patch