[ppc64el] deb-pkg: Add support for powerpc little endian

svn path=/dists/sid/linux/; revision=21826
This commit is contained in:
Ben Hutchings 2014-09-12 14:24:52 +00:00
parent a3b4639c85
commit 39f03a5534
3 changed files with 27 additions and 0 deletions

1
debian/changelog vendored
View File

@ -62,6 +62,7 @@ linux (3.16.2-3) UNRELEASED; urgency=medium
r8192u_usb, r8723au, rtl8188eu, rtl818x_pci, rtl8723be, rtl8821ae,
spectrum_cs to nic-wireless-modules
* builddeb: put the dbg files into the correct directory
* [ppc64el] deb-pkg: Add support for powerpc little endian
[ Ian Campbell ]
* [armel/orion5x] udeb: Include mvmdio in nic-modules udeb.

View File

@ -0,0 +1,25 @@
From: Michael Neuling <mikey@neuling.org>
Subject: deb-pkg: Add support for powerpc little endian
Origin: http://marc.info/?l=linux-kernel&m=140989493729069&w=2
The Debian powerpc little endian architecture is called ppc64le. This
is the default architecture used by Ubuntu for powerpc.
The below checks the kernel config to see if we are compiling little
endian and sets the Debian arch appropriately.
Signed-off-by: Michael Neuling <mikey@neuling.org>
diff --git a/scripts/package/builddeb b/scripts/package/builddeb
index 35d5a58..6f4a1af 100644
--- a/scripts/package/builddeb
+++ b/scripts/package/builddeb
@@ -37,7 +37,7 @@ create_package() {
s390*)
debarch=s390$(grep -q CONFIG_64BIT=y $KCONFIG_CONFIG && echo x || true) ;;
ppc*)
- debarch=powerpc ;;
+ debarch=$(grep -q CPU_LITTLE_ENDIAN=y $KCONFIG_CONFIG && echo ppc64el || echo powerpc) ;;
parisc*)
debarch=hppa ;;
mips*)

View File

@ -92,6 +92,7 @@ features/powerpc/KVM-Move-all-accesses-to-kvm-irq_routing-into-irqchi.patch
features/powerpc/KVM-Move-irq-notifier-implementation-into-eventfd.c.patch
features/powerpc/KVM-Give-IRQFD-its-own-separate-enabling-Kconfig-opt.patch
features/powerpc/KVM-PPC-Enable-IRQFD-support-for-the-XICS-interrupt-.patch
features/powerpc/deb-pkg-add-support-for-powerpc-little-endian.patch
features/x86/x86-memtest-WARN-if-bad-RAM-found.patch
features/x86/x86-make-x32-syscall-support-conditional.patch