[x86] drm: Enable DRM_MGAG200 as module

Disable autoloading as it is incompatible with older versions of xserver-xorg-video-mga

svn path=/dists/trunk/linux/; revision=19646
This commit is contained in:
Ben Hutchings 2012-12-24 00:10:56 +00:00
parent d2bb26f367
commit df5911f385
5 changed files with 34 additions and 3 deletions

6
debian/changelog vendored
View File

@ -48,9 +48,9 @@ linux (3.7.1-1~experimental.1) UNRELEASED; urgency=low
* drm: Enable DRM_UDL as module
- Disable autoloading as it is incompatible with older versions of
xserver-xorg-video-displaylink
* [x86] drm: Enable DRM_AST as module
- Disable autoloading as it is incompatible with older versions of
xserver-xorg-video-ast
* [x86] drm: Enable DRM_AST, DRM_MGAG200 as modules
- Disable autoloading as they are incompatible with older versions of
xserver-xorg-video-ast and xserver-xorg-video-mga
-- maximilian attems <maks@debian.org> Thu, 06 Dec 2012 18:14:33 +0100

View File

@ -404,6 +404,11 @@ CONFIG_DRM_SAVAGE=m
##
CONFIG_DRM_CIRRUS_QEMU=m
##
## file: drivers/gpu/drm/mgag200/Kconfig
##
# CONFIG_DRM_MGAG200 is not set
##
## file: drivers/gpu/drm/nouveau/Kconfig
##

View File

@ -448,6 +448,11 @@ CONFIG_DRM_GMA500=m
CONFIG_DRM_GMA600=y
CONFIG_DRM_GMA3600=y
##
## file: drivers/gpu/drm/mgag200/Kconfig
##
CONFIG_DRM_MGAG200=m
##
## file: drivers/gpu/drm/nouveau/Kconfig
##

View File

@ -0,0 +1,20 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: mgag200: Disable autoload
Date: Mon, 24 Dec 2012 00:10:05 +0000
This kernel driver is incompatible with older versions of
xserver-xorg-video-mga, so do not autoload it yet. It will have to be
loaded either by local configuration or as part of a package of a
compatible X driver.
--- a/drivers/gpu/drm/mgag200/mgag200_drv.c
+++ b/drivers/gpu/drm/mgag200/mgag200_drv.c
@@ -38,7 +38,7 @@ static DEFINE_PCI_DEVICE_TABLE(pciidlist
{0,}
};
-MODULE_DEVICE_TABLE(pci, pciidlist);
+/*MODULE_DEVICE_TABLE(pci, pciidlist);*/
static void mgag200_kick_out_firmware_fb(struct pci_dev *pdev)
{

View File

@ -67,3 +67,4 @@ bugfix/all/sfc-Select-PTP_1588_CLOCK.patch
bugfix/all/pch_gbe-ptp_pch-Fix-the-dependency-direction-between.patch
debian/udl-disable-autoload.patch
debian/ast-disable-autoload.patch
debian/mgag200-disable-autoload.patch