[x86] drm: Enable DRM_AST as module

Disable autoloading as it is incompatible with older versions of xserver-xorg-video-ast

svn path=/dists/trunk/linux/; revision=19645
This commit is contained in:
Ben Hutchings 2012-12-24 00:06:20 +00:00
parent 38726ed91f
commit d2bb26f367
5 changed files with 34 additions and 0 deletions

3
debian/changelog vendored
View File

@ -48,6 +48,9 @@ linux (3.7.1-1~experimental.1) UNRELEASED; urgency=low
* drm: Enable DRM_UDL as module
- Disable autoloading as it is incompatible with older versions of
xserver-xorg-video-displaylink
* [x86] drm: Enable DRM_AST as module
- Disable autoloading as it is incompatible with older versions of
xserver-xorg-video-ast
-- maximilian attems <maks@debian.org> Thu, 06 Dec 2012 18:14:33 +0100

View File

@ -394,6 +394,11 @@ CONFIG_FIREWIRE_NOSY=m
CONFIG_DRM_VIA=m
CONFIG_DRM_SAVAGE=m
##
## file: drivers/gpu/drm/ast/Kconfig
##
# CONFIG_DRM_AST is not set
##
## file: drivers/gpu/drm/cirrus/Kconfig
##

View File

@ -436,6 +436,11 @@ CONFIG_DRM_I915_KMS=y
CONFIG_DRM_MGA=m
CONFIG_DRM_SIS=m
##
## file: drivers/gpu/drm/ast/Kconfig
##
CONFIG_DRM_AST=m
##
## file: drivers/gpu/drm/gma500/Kconfig
##

View File

@ -0,0 +1,20 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: ast: Disable autoload
Date: Mon, 24 Dec 2012 00:05:07 +0000
This kernel driver is incompatible with older versions of
xserver-xorg-video-ast, so do not autoload it yet. It will
have to be loaded either by local configuration or as part of a
package of a compatible X driver.
--- a/drivers/gpu/drm/ast/ast_drv.c
+++ b/drivers/gpu/drm/ast/ast_drv.c
@@ -58,7 +58,7 @@ static DEFINE_PCI_DEVICE_TABLE(pciidlist
{0, 0, 0},
};
-MODULE_DEVICE_TABLE(pci, pciidlist);
+/*MODULE_DEVICE_TABLE(pci, pciidlist);*/
static int __devinit
ast_pci_probe(struct pci_dev *pdev, const struct pci_device_id *ent)

View File

@ -66,3 +66,4 @@ bugfix/all/ptp-Enable-clock-drivers-along-with-associated-net-P.patch
bugfix/all/sfc-Select-PTP_1588_CLOCK.patch
bugfix/all/pch_gbe-ptp_pch-Fix-the-dependency-direction-between.patch
debian/udl-disable-autoload.patch
debian/ast-disable-autoload.patch