net: ipv4: current group_info should be put after using. (CVE-2014-2851)

svn path=/dists/sid/linux/; revision=21325
This commit is contained in:
Ben Hutchings 2014-05-13 15:32:26 +00:00
parent bac020c049
commit d326c007c7
3 changed files with 63 additions and 0 deletions

1
debian/changelog vendored
View File

@ -109,6 +109,7 @@ linux (3.14.4-1) UNRELEASED; urgency=medium
* [x86] udeb: Add hyperv-keyboard to hyperv-modules
* drm: Enable auto-loading of ast, udl
* [ppc64el] Build a linux-libc-dev package (Closes: #747367)
* net: ipv4: current group_info should be put after using. (CVE-2014-2851)
-- Ben Hutchings <ben@decadent.org.uk> Thu, 01 May 2014 01:50:30 +0100

View File

@ -0,0 +1,61 @@
From: "Wang, Xiaoming" <xiaoming.wang@intel.com>
Date: Mon, 14 Apr 2014 12:30:45 -0400
Subject: net: ipv4: current group_info should be put after using.
Origin: https://git.kernel.org/linus/b04c46190219a4f845e46a459e3102137b7f6cac
Plug a group_info refcount leak in ping_init.
group_info is only needed during initialization and
the code failed to release the reference on exit.
While here move grabbing the reference to a place
where it is actually needed.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Zhang Dongxing <dongxing.zhang@intel.com>
Signed-off-by: xiaoming wang <xiaoming.wang@intel.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/ipv4/ping.c | 15 +++++++++++----
1 file changed, 11 insertions(+), 4 deletions(-)
diff --git a/net/ipv4/ping.c b/net/ipv4/ping.c
index f4b19e5..8210964 100644
--- a/net/ipv4/ping.c
+++ b/net/ipv4/ping.c
@@ -252,26 +252,33 @@ int ping_init_sock(struct sock *sk)
{
struct net *net = sock_net(sk);
kgid_t group = current_egid();
- struct group_info *group_info = get_current_groups();
- int i, j, count = group_info->ngroups;
+ struct group_info *group_info;
+ int i, j, count;
kgid_t low, high;
+ int ret = 0;
inet_get_ping_group_range_net(net, &low, &high);
if (gid_lte(low, group) && gid_lte(group, high))
return 0;
+ group_info = get_current_groups();
+ count = group_info->ngroups;
for (i = 0; i < group_info->nblocks; i++) {
int cp_count = min_t(int, NGROUPS_PER_BLOCK, count);
for (j = 0; j < cp_count; j++) {
kgid_t gid = group_info->blocks[i][j];
if (gid_lte(low, gid) && gid_lte(gid, high))
- return 0;
+ goto out_release_group;
}
count -= cp_count;
}
- return -EACCES;
+ ret = -EACCES;
+
+out_release_group:
+ put_group_info(group_info);
+ return ret;
}
EXPORT_SYMBOL_GPL(ping_init_sock);

View File

@ -82,3 +82,4 @@ features/arm/PHY-sunxi-Add-driver-for-sunxi-usb-phy.patch
features/arm/ARM-sun4i-dt-Add-bindings-for-USB-clocks.patch
features/arm/ARM-sun4i-dt-Add-USB-host-bindings.patch
bugfix/all/net-Start-with-correct-mac_len-in-skb_network_protoc.patch
bugfix/all/net-ipv4-current-group_info-should-be-put-after-usin.patch