Update to 3.14.4

svn path=/dists/sid/linux/; revision=21324
This commit is contained in:
Ben Hutchings 2014-05-13 15:29:53 +00:00
parent 653dca30c5
commit bac020c049
3 changed files with 37 additions and 58 deletions

38
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.14.3-1) UNRELEASED; urgency=medium
linux (3.14.4-1) UNRELEASED; urgency=medium
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.14.3
@ -62,6 +62,42 @@ linux (3.14.3-1) UNRELEASED; urgency=medium
- ext4: note the error in ext4_end_bio()
- ext4: move ext4_update_i_disksize() into mpage_map_and_submit_extent()
- ext4: use i_size_read in ext4_unaligned_aio()
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.14.4
- tty: Fix lockless tty buffer race
- n_tty: Fix n_tty_write crash when echoing in raw mode (CVE-2014-0196)
(Closes: #747166)
- floppy: ignore kernel-only members in FDRAWCMD ioctl input (CVE-2014-1737)
- floppy: don't write kernel-only members to FDRAWCMD ioctl output
(CVE-2014-1738)
- KVM: async_pf: mm->mm_users can not pin apf->mm
- KVM: ioapic: fix assignment of ioapic->rtc_status.pending_eoi
(CVE-2014-0155)
- [powerpc] KVM: Book3S HV: Fix KVM hang with CONFIG_KVM_XICS=n
(regression in 3.14)
- [mips] Hibernate: Flush TLB entries in swsusp_arch_resume()
- [powerpc] Fix Oops in rtas_stop_self() (regression in 3.14)
- [s390] bpf,jit: initialize A register if 1st insn is BPF_S_LDX_B_MSH
- SUNRPC: Ensure that call_connect times out correctly (regression in 3.13)
- SUNRPC: Ensure call_connect_status() deals correctly with SOFTCONN tasks
(regression in 3.13)
- Revert "net: mvneta: fix usage as a module on RGMII configurations"
(regression in 3.14)
- iwlwifi: dvm: take mutex when sending SYNC BT config command
- mac80211: fix potential use-after-free
- mac80211: fix WPA with VLAN on AP side with ps-sta again
- locks: allow __break_lease to sleep even when break_time is 0
- rtlwifi: rtl8192se: Fix regression due to commit 1bf4bbb
(regression in 3.13)
- dm cache: prevent corruption caused by discard_block_size >
cache_block_size
- dm transaction manager: fix corruption due to non-atomic transaction
commit
- dm: take care to copy the space map roots before locking the superblock
- dm thin: fix dangling bio in process_deferred_bios error path
- aio: v4 ensure access to ctx->ring_pages is correctly serialised for
migration
- cpufreq: loongson2_cpufreq: don't declare local variable as static
(regression in 3.14)
[ Ben Hutchings ]
* [or1k] Build a linux-libc-dev package (Closes: #746309)

View File

@ -1,56 +0,0 @@
Subject: ACPI/Processor: Fix failure of loading acpi-cpufreq driver
From: "lan,Tianyu" <tianyu.lan@intel.com>
Date: Wed, 30 Apr 2014 15:46:33 +0800
Origin: https://patchwork.kernel.org/patch/4091711/
According commit d640113fe(ACPI: processor: fix acpi_get_cpuid for UP
processor), Bios may not provide _MAT or MADT tables and acpi_get_apicid()
always returns -1. For these cases, original code will pass apic_id with
vaule of -1 to acpi_map_cpuid() and it will check the acpi_id. If acpi_id
is equal to zero, ignores apic_id and return zero for CPU0.
Commit b981513(ACPI / scan: bail out early if failed to parse APIC
ID for CPU) changed the behavior. Return ENODEV when find apic_id is
less than zero after calling acpi_get_apicid(). This causes acpi-cpufreq
driver fails to be loaded on some machines. This patch is to fix it.
Reference:https://bugzilla.kernel.org/show_bug.cgi?id=73781
Cc: stable@vger.kernel.org v3.14
Reported-and-tested-by: KATO Hiroshi <katoh@mikage.ne.jp>
Reported-and-tested-by: Stuart Foster <smf.linux@ntlworld.com>
Signed-off-by: Lan Tianyu <tianyu.lan@intel.com>
---
Change since V1:
Add a check for pr->apic_id in the acpi_processor_hotadd_init()
to avoid invalid memory access.
drivers/acpi/acpi_processor.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/acpi/acpi_processor.c b/drivers/acpi/acpi_processor.c
index c29c2c3..b06f5f5 100644
--- a/drivers/acpi/acpi_processor.c
+++ b/drivers/acpi/acpi_processor.c
@@ -170,6 +170,9 @@ static int acpi_processor_hotadd_init(struct acpi_processor *pr)
acpi_status status;
int ret;
+ if (pr->apic_id == -1)
+ return -ENODEV;
+
status = acpi_evaluate_integer(pr->handle, "_STA", NULL, &sta);
if (ACPI_FAILURE(status) || !(sta & ACPI_STA_DEVICE_PRESENT))
return -ENODEV;
@@ -260,10 +263,8 @@ static int acpi_processor_get_info(struct acpi_device *device)
}
apic_id = acpi_get_apicid(pr->handle, device_declaration, pr->acpi_id);
- if (apic_id < 0) {
+ if (apic_id < 0)
acpi_handle_debug(pr->handle, "failed to get CPU APIC ID.\n");
- return -ENODEV;
- }
pr->apic_id = apic_id;
cpu_index = acpi_map_cpuid(pr->apic_id, pr->acpi_id);

View File

@ -82,4 +82,3 @@ features/arm/PHY-sunxi-Add-driver-for-sunxi-usb-phy.patch
features/arm/ARM-sun4i-dt-Add-bindings-for-USB-clocks.patch
features/arm/ARM-sun4i-dt-Add-USB-host-bindings.patch
bugfix/all/net-Start-with-correct-mac_len-in-skb_network_protoc.patch
bugfix/x86/ACPI-Processor-Fix-failure-of-loading-acpi-cpufreq-driver.patch