drm: Enable DRM_UDL as module

Disable autoloading as it is incompatible with older versions of xserver-xorg-video-displaylink

svn path=/dists/trunk/linux/; revision=19644
This commit is contained in:
Ben Hutchings 2012-12-23 23:58:46 +00:00
parent f97aa6931e
commit 38726ed91f
4 changed files with 29 additions and 0 deletions

3
debian/changelog vendored
View File

@ -45,6 +45,9 @@ linux (3.7.1-1~experimental.1) UNRELEASED; urgency=low
* wireless/ti: Enable WL18XX as module
* ptp: Enable clock drivers along with associated net/PHY drivers
* [!x86] drm: Disable DRM_VMWGFX
* drm: Enable DRM_UDL as module
- Disable autoloading as it is incompatible with older versions of
xserver-xorg-video-displaylink
-- maximilian attems <maks@debian.org> Thu, 06 Dec 2012 18:14:33 +0100

View File

@ -410,6 +410,11 @@ CONFIG_DRM_NOUVEAU_BACKLIGHT=y
##
# CONFIG_DRM_RADEON_KMS is not set
##
## file: drivers/gpu/drm/udl/Kconfig
##
CONFIG_DRM_UDL=m
##
## file: drivers/gpu/drm/vmwgfx/Kconfig
##

View File

@ -0,0 +1,20 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: udl: Disable autoload
Date: Sun, 23 Dec 2012 23:58:16 +0000
This kernel driver is incompatible with older versions of
xserver-xorg-video-displaylink, so do not autoload it yet. It will
have to be loaded either by local configuration or as part of a
package of a compatible X driver.
--- a/drivers/gpu/drm/udl/udl_drv.c
+++ b/drivers/gpu/drm/udl/udl_drv.c
@@ -30,7 +30,7 @@ static struct usb_device_id id_table[] =
USB_DEVICE_ID_MATCH_INT_PROTOCOL,},
{},
};
-MODULE_DEVICE_TABLE(usb, id_table);
+/*MODULE_DEVICE_TABLE(usb, id_table);*/
MODULE_LICENSE("GPL");

View File

@ -65,3 +65,4 @@ bugfix/all/ptp-Make-PTP_1588_CLOCK-select-rather-than-depend-on.patch
bugfix/all/ptp-Enable-clock-drivers-along-with-associated-net-P.patch
bugfix/all/sfc-Select-PTP_1588_CLOCK.patch
bugfix/all/pch_gbe-ptp_pch-Fix-the-dependency-direction-between.patch
debian/udl-disable-autoload.patch