ds2782_battery: Fix build failure on several architectures

svn path=/dists/trunk/linux-2.6/; revision=16000
This commit is contained in:
Ben Hutchings 2010-07-20 00:09:39 +00:00
parent 9fdab640ee
commit cc97dc48ef
3 changed files with 77 additions and 0 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux-2.6 (2.6.35~rc5-1~experimental.2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [!x86] Disable FB_VIA; these GPUs are only found on x86 motherboards
* ds2782_battery: Fix build failure on several architectures
-- Ben Hutchings <ben@decadent.org.uk> Tue, 13 Jul 2010 14:01:16 +0100

View File

@ -0,0 +1,75 @@
From f091c82e7af664bca8708a919a0e98ddcccc35ee Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 20 Jul 2010 00:55:31 +0100
Subject: [PATCH 2/2] ds2782_battery: Rename get_current and get_voltage operations
Rename get_current operation to get_current_now since get_current()
is defined as a macro on some architectures.
Rename get_voltage operation to get_voltage_now for consistency.
---
drivers/power/ds2782_battery.c | 22 +++++++++++-----------
1 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/drivers/power/ds2782_battery.c b/drivers/power/ds2782_battery.c
index d762a0c..8d0673f 100644
--- a/drivers/power/ds2782_battery.c
+++ b/drivers/power/ds2782_battery.c
@@ -43,8 +43,8 @@
struct ds278x_info;
struct ds278x_battery_ops {
- int (*get_current)(struct ds278x_info *info, int *current_uA);
- int (*get_voltage)(struct ds278x_info *info, int *voltage_uA);
+ int (*get_current_now)(struct ds278x_info *info, int *current_uA);
+ int (*get_voltage_now)(struct ds278x_info *info, int *voltage_uA);
int (*get_capacity)(struct ds278x_info *info, int *capacity_uA);
};
@@ -213,7 +213,7 @@ static int ds278x_get_status(struct ds278x_info *info, int *status)
int current_uA;
int capacity;
- err = info->ops->get_current(info, &current_uA);
+ err = info->ops->get_current_now(info, &current_uA);
if (err)
return err;
@@ -250,11 +250,11 @@ static int ds278x_battery_get_property(struct power_supply *psy,
break;
case POWER_SUPPLY_PROP_VOLTAGE_NOW:
- ret = info->ops->get_voltage(info, &val->intval);
+ ret = info->ops->get_voltage_now(info, &val->intval);
break;
case POWER_SUPPLY_PROP_CURRENT_NOW:
- ret = info->ops->get_current(info, &val->intval);
+ ret = info->ops->get_current_now(info, &val->intval);
break;
case POWER_SUPPLY_PROP_TEMP:
@@ -307,14 +307,14 @@ enum ds278x_num_id {
static struct ds278x_battery_ops ds278x_ops[] = {
[DS2782] = {
- .get_current = ds2782_get_current,
- .get_voltage = ds2782_get_voltage,
- .get_capacity = ds2782_get_capacity,
+ .get_current_now = ds2782_get_current,
+ .get_voltage_now = ds2782_get_voltage,
+ .get_capacity = ds2782_get_capacity,
},
[DS2786] = {
- .get_current = ds2786_get_current,
- .get_voltage = ds2786_get_voltage,
- .get_capacity = ds2786_get_capacity,
+ .get_current_now = ds2786_get_current,
+ .get_voltage_now = ds2786_get_voltage,
+ .get_capacity = ds2786_get_capacity,
}
};
--
1.7.1

View File

@ -1 +1,2 @@
+ bugfix/all/viafb-Depends-on-X86.patch
+ bugfix/all/ds2782_battery-Rename-get_current-and-get_voltage-op.patch