[!x86] Disable FB_VIA; these GPUs are only found on x86 motherboards

svn path=/dists/trunk/linux-2.6/; revision=15999
This commit is contained in:
Ben Hutchings 2010-07-20 00:08:12 +00:00
parent 3cf4012f58
commit 9fdab640ee
3 changed files with 9 additions and 11 deletions

3
debian/changelog vendored
View File

@ -1,8 +1,7 @@
linux-2.6 (2.6.35~rc5-1~experimental.2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [alpha, ia64, mips, mipsel except loongson2f] Disable FB_VIA; it now
depends on GPIOLIB which is not available on these architectures
* [!x86] Disable FB_VIA; these GPUs are only found on x86 motherboards
-- Ben Hutchings <ben@decadent.org.uk> Tue, 13 Jul 2010 14:01:16 +0100

View File

@ -1,17 +1,16 @@
From 98084fc0950600f2d9f22356fc4e16ced03d72f6 Mon Sep 17 00:00:00 2001
From b994ef79fccdcf24182ea375e917ec124c3cfdfa Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 14 Jul 2010 00:09:23 +0100
Subject: [PATCH] viafb: Add transitive dependencies via gpiolib
Date: Tue, 20 Jul 2010 00:31:24 +0100
Subject: [PATCH 1/2] viafb: Depends on X86
FB_VIA now selects GPIOLIB, but that is not available on all
architectures. Change FB_VIA dependencies to include GPIOLIB
dependencies.
VIA UniChrome and Chrome9 GPUs only exist as Integrated Graphics
Processors in x86 chipsets.
---
drivers/video/Kconfig | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/video/Kconfig b/drivers/video/Kconfig
index 3d94a14..bc4534d 100644
index 3d94a14..162a0b7 100644
--- a/drivers/video/Kconfig
+++ b/drivers/video/Kconfig
@@ -1505,7 +1505,7 @@ config FB_SIS_315
@ -19,7 +18,7 @@ index 3d94a14..bc4534d 100644
config FB_VIA
tristate "VIA UniChrome (Pro) and Chrome9 display support"
- depends on FB && PCI
+ depends on FB && PCI && (ARCH_WANT_OPTIONAL_GPIOLIB || ARCH_REQUIRE_GPIOLIB)
+ depends on FB && PCI && X86
select FB_CFB_FILLRECT
select FB_CFB_COPYAREA
select FB_CFB_IMAGEBLIT

View File

@ -1 +1 @@
+ bugfix/all/viafb-Add-transitive-dependencies-via-gpiolib.patch
+ bugfix/all/viafb-Depends-on-X86.patch