[x86] drm/i915:: Disable FBC on SandyBridge (Closes: #675022)

svn path=/dists/sid/linux-2.6/; revision=19046
This commit is contained in:
Ben Hutchings 2012-05-30 13:46:01 +00:00
parent bf73f974c9
commit ca018e7e12
3 changed files with 35 additions and 0 deletions

1
debian/changelog vendored
View File

@ -7,6 +7,7 @@ linux-2.6 (3.2.18-2) UNRELEASED; urgency=low
* net/sched: Add codel and fq_codel from Linux 3.5-rc1
* [x86] udeb: Add hyperv-modules containing Hyper-V paravirtualised drivers
* [x86] ata_piix: defer disks to the Hyper-V drivers by default
* [x86] drm/i915:: Disable FBC on SandyBridge (Closes: #675022)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 27 May 2012 01:12:44 +0100

View File

@ -0,0 +1,32 @@
From: Chris Wilson <chris@chris-wilson.co.uk>
Date: Tue, 8 Nov 2011 23:17:34 +0000
Subject: [PATCH] drm/i915:: Disable FBC on SandyBridge
commit d56d8b28e9247e7e35e02fbb12b12239a2c33ad1 upstream.
Enabling FBC is causing the BLT ring to run between 10-100x slower than
normal and frequently lockup. The interim solution is disable FBC once
more until we know why.
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Signed-off-by: Keith Packard <keithp@keithp.com>
---
drivers/gpu/drm/i915/intel_display.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
index b3b51c4..19f35ec 100644
--- a/drivers/gpu/drm/i915/intel_display.c
+++ b/drivers/gpu/drm/i915/intel_display.c
@@ -1872,7 +1872,7 @@ static void intel_update_fbc(struct drm_device *dev)
if (enable_fbc < 0) {
DRM_DEBUG_KMS("fbc set to per-chip default\n");
enable_fbc = 1;
- if (INTEL_INFO(dev)->gen <= 5)
+ if (INTEL_INFO(dev)->gen <= 6)
enable_fbc = 0;
}
if (!enable_fbc) {
--
1.7.10

View File

@ -307,3 +307,5 @@
+ features/all/codel/0005-net-codel-fix-build-errors.patch
+ features/all/codel/0006-codel-use-u16-field-instead-of-31bits-for-rec_inv_sq.patch
+ features/all/codel/0007-fq_codel-should-use-qdisc-backlog-as-threshold.patch
+ bugfix/all/drm-i915-Disable-FBC-on-SandyBridge.patch