Update to 3.2.32

Drop ite-cir patch applied upstream.
Drop ARM acard workaround; the problem has been fixed differently upstream.

svn path=/dists/sid/linux/; revision=19438
This commit is contained in:
Ben Hutchings 2012-10-20 05:26:29 +00:00
parent 43ae16c40a
commit be2a2afd0e
4 changed files with 52 additions and 59 deletions

53
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.2.31-1) UNRELEASED; urgency=low
linux (3.2.32-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.31
@ -21,6 +21,57 @@ linux (3.2.31-1) UNRELEASED; urgency=low
- ipv6: raw: fix icmpv6_filter()
- ipv6: mip6: fix mip6_mh_filter()
- netrom: copy_datagram_iovec can fail
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.32
- mtd: nand: Use the mirror BBT descriptor when reading its version
- TTY: ttyprintk, don't touch behind tty->write_buf
- n_gsm: fix various serious bugs
- hpsa: Use LUN reset instead of target reset
- staging: comedi: don't dereference user memory for INSN_INTTRIG
- ext4: fix potential deadlock in ext4_nonda_switch()
- staging: comedi: fix memory leak for saved channel list
- scsi_remove_target: fix softlockup regression on hot remove
(Closes: #690990)
- usb: host: xhci: Fix Null pointer dereferencing with 71c731a for
non-x86 systems (regression in 3.2.30)
- ext4: online defrag is not supported for journaled files
- staging: comedi: s626: don't dereference insn->data
- serial: pl011: handle corruption at high clock speeds
- ext4: always set i_op in ext4_mknod()
- ext4: fix fdatasync() for files with only i_size changes
- [x86] drm/i915: use adjusted_mode instead of mode for checking the
6bpc force flag (regression in 3.2.29)
- staging: comedi: jr3_pci: fix iomem dereference
- JFFS2: don't fail on bitflips in OOB
- mtd: nandsim: bugfix: fail if overridesize is too big
- pnfsblock: fix partial page buffer wirte
- target/file: Re-enable optional fd_buffered_io=1 operation
- iscsit: remove incorrect unlock in iscsit_build_sendtargets_resp
- rapidio/rionet: fix multicast packet transmit logic
- ALSA: aloop - add locking to timer access
- [armhf/omap] counter: add locking to read_persistent_clock
- mm: fix invalidate_complete_page2() lock ordering
- mm: thp: fix pmd_present for split_huge_page and PROT_NONE with THP
- mm: hugetlb: fix pgoff computation when unmapping page from vma
- hugetlb: do not use vma_hugecache_offset() for vma_prio_tree_foreach
- [x86] firewire: cdev: fix user memory corruption (i386 userland on
amd64 kernel)
- udf: fix retun value on error path in udf_load_logicalvol
- eCryptfs: Unlink lower inode when ecryptfs_create() fails
- eCryptfs: Initialize empty lower files when opening them
- eCryptfs: Revert to a writethrough cache model
- eCryptfs: Write out all dirty pages just before releasing the lower file
- eCryptfs: Call lower ->flush() from ecryptfs_flush()
- mempolicy: remove mempolicy sharing
- mempolicy: fix a race in shared_policy_replace()
- mempolicy: fix refcount leak in mpol_set_shared_policy()
- mempolicy: fix a memory corruption by refcount imbalance in
alloc_pages_vma()
- hpsa: dial down lockup detection during firmware flash
- netfilter: nf_ct_ipv4: packets with wrong ihl are invalid
- netfilter: nf_nat_sip: fix incorrect handling of EBUSY for RTCP
expectation
- netfilter: nf_ct_expect: fix possible access to uninitialized timer
- ipvs: fix oops on NAT reply in br_nf context
[ Ben Hutchings ]
* codel: refine one condition to avoid a nul rec_inv_sqrt

View File

@ -1,36 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 12 Aug 2012 22:47:41 +0100
Subject: [media] rc: ite-cir: Initialise ite_dev::rdev earlier
Bug-Debian: http://bugs.debian.org/684441
ite_dev::rdev is currently initialised in ite_probe() after
rc_register_device() returns. If a newly registered device is opened
quickly enough, we may enable interrupts and try to use ite_dev::rdev
before it has been initialised. Move it up to the earliest point we
can, right after calling rc_allocate_device().
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/media/rc/ite-cir.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/rc/ite-cir.c b/drivers/media/rc/ite-cir.c
index 0e49c99..c06992e 100644
--- a/drivers/media/rc/ite-cir.c
+++ b/drivers/media/rc/ite-cir.c
@@ -1473,6 +1473,7 @@ static int ite_probe(struct pnp_dev *pdev, const struct pnp_device_id
rdev = rc_allocate_device();
if (!rdev)
goto failure;
+ itdev->rdev = rdev;
ret = -ENODEV;
@@ -1604,7 +1605,6 @@ static int ite_probe(struct pnp_dev *pdev, const struct pnp_device_id
if (ret)
goto failure;
- itdev->rdev = rdev;
ite_pr(KERN_NOTICE, "driver has been successfully loaded\n");
return 0;

View File

@ -1,20 +0,0 @@
From: Gordon Farquharson <gordonfarquharson@gmail.com>
Subject: [arm] Disable SCSI_ACARD
Date: Mon, 12 Nov 2007 04:08:38 +0000
ERROR: "__bad_udelay" [drivers/scsi/atp870u.ko] undefined!
make[1]: *** [__modpost] Error 1
diff --git a/drivers/scsi/Kconfig b/drivers/scsi/Kconfig
index a7a0813..fa6a4fe 100644
--- a/drivers/scsi/Kconfig
+++ b/drivers/scsi/Kconfig
@@ -396,7 +396,7 @@ config SCSI_7000FASST
config SCSI_ACARD
tristate "ACARD SCSI support"
- depends on PCI && SCSI
+ depends on PCI && SCSI && (!ARM || BROKEN)
help
This driver supports the ACARD SCSI host adapter.
Support Chip <ATP870 ATP876 ATP880 ATP885>

View File

@ -19,7 +19,6 @@ features/all/aufs3/aufs3-fix-export-__devcgroup_inode_permission.patch
bugfix/ia64/hardcode-arch-script-output.patch
bugfix/mips/disable-advansys.patch
bugfix/arm/disable-scsi_acard.patch
debian/mips-disable-werror.patch
bugfix/powerpc/lpar-console.patch
@ -390,7 +389,6 @@ features/all/bql/igb-ixgbe-netdev_tx_reset_queue-incorrectly-called-from-tx-init
features/all/bql/skge-add-byte-queue-limit-support.patch
bugfix/all/PCI-PM-Runtime-make-PCI-traces-quieter.patch
bugfix/all/media-rc-ite-cir-Initialise-ite_dev-rdev-earlier.patch
features/all/USB-add-USB_VENDOR_AND_INTERFACE_INFO-macro.patch
bugfix/all/usb-Add-quirk-detection-based-on-interface-informati.patch
bugfix/all/usb-Add-USB_QUIRK_RESET_RESUME-for-all-Logitech-UVC-.patch