[x86] efi: Build EFI stub with EFI-appropriate options

svn path=/dists/sid/linux/; revision=19436
This commit is contained in:
Ben Hutchings 2012-10-12 04:05:04 +00:00
parent fe2316a734
commit 43ae16c40a
3 changed files with 33 additions and 0 deletions

1
debian/changelog vendored
View File

@ -34,6 +34,7 @@ linux (3.2.31-1) UNRELEASED; urgency=low
* udeb: Add hid-logitech-dj to input-modules (Closes: #661379)
* connector: Make CONNECTOR built-in; enable PROC_EVENTS (Closes: #588200)
* e1000e: Change wthresh to 1 to avoid possible Tx stalls
* [x86] efi: Build EFI stub with EFI-appropriate options
-- Ben Hutchings <ben@decadent.org.uk> Sat, 29 Sep 2012 14:19:46 +0200

View File

@ -0,0 +1,31 @@
From: Matthew Garrett <mjg@redhat.com>
Date: Thu, 26 Jul 2012 18:00:00 -0400
Subject: efi: Build EFI stub with EFI-appropriate options
commit 9dead5bbb825d7c25c0400e61de83075046322d0 upstream.
We can't assume the presence of the red zone while we're still in a boot
services environment, so we should build with -fno-red-zone to avoid
problems. Change the size of wchar at the same time to make string handling
simpler.
Signed-off-by: Matthew Garrett <mjg@redhat.com>
Signed-off-by: Matt Fleming <matt.fleming@intel.com>
---
arch/x86/boot/compressed/Makefile | 3 +++
1 file changed, 3 insertions(+)
diff --git a/arch/x86/boot/compressed/Makefile b/arch/x86/boot/compressed/Makefile
index e398bb5..8a84501 100644
--- a/arch/x86/boot/compressed/Makefile
+++ b/arch/x86/boot/compressed/Makefile
@@ -28,6 +28,9 @@ VMLINUX_OBJS = $(obj)/vmlinux.lds $(obj)/head_$(BITS).o $(obj)/misc.o \
$(obj)/string.o $(obj)/cmdline.o $(obj)/early_serial_console.o \
$(obj)/piggy.o
+$(obj)/eboot.o: KBUILD_CFLAGS += -fshort-wchar -mno-red-zone
+$(obj)/efi_stub_$(BITS).o: KBUILD_CLFAGS += -fshort-wchar -mno-red-zone
+
ifeq ($(CONFIG_EFI_STUB), y)
VMLINUX_OBJS += $(obj)/eboot.o $(obj)/efi_stub_$(BITS).o
endif

View File

@ -164,6 +164,7 @@ features/x86/efi-stub/0014-x86-boot-Restrict-CFLAGS-for-hostprogs.patch
features/x86/efi-stub/0015-x86-efi-Fix-endian-issues-and-unaligned-accesses.patch
features/x86/efi-stub/0016-x86-boot-Correct-CFLAGS-for-hostprogs.patch
features/x86/efi-stub/0017-x86-efi-Add-dedicated-EFI-stub-entry-point.patch
features/x86/efi-stub/0018-efi-Build-EFI-stub-with-EFI-appropriate-options.patch
# Update wacom driver to 3.5ish
features/all/wacom/0001-Input-wacom-cleanup-feature-report-for-bamboos.patch