* [mips,mipsel] Update arch/mips/kernel/i8259.c to fix FTBFS.

svn path=/dists/trunk/linux-2.6/; revision=17598
This commit is contained in:
Aurelien Jarno 2011-06-05 22:02:55 +00:00
parent 8783accc60
commit b87788ce09
3 changed files with 78 additions and 0 deletions

3
debian/changelog vendored
View File

@ -6,6 +6,9 @@ linux-2.6 (3.0.0~rc1-1~experimental.2) experimental; urgency=low
[ Hector Oron ]
* [armel/iop32x] Fix FTBFS (Closes: #629342)
[ Aurelien Jarno ]
* [mips,mipsel] Update arch/mips/kernel/i8259.c to fix FTBFS.
-- Ben Hutchings <ben@decadent.org.uk> Wed, 01 Jun 2011 06:41:14 +0100
linux-2.6 (3.0.0~rc1-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,74 @@
From: Yoichi Yuasa <yuasa@linux-mips.org>
Date: Fri, 20 May 2011 13:41:41 +0000 (+0900)
Subject: MIPS: i8259: Use struct syscore_ops instead of sysdevs
X-Git-Tag: linux-3.0-rc1~12
X-Git-Url: http://git.linux-mips.org/?p=linux.git;a=commitdiff_plain;h=297b7fdeac2d202c86e4b731d6e2ba03490ce3dd
MIPS: i8259: Use struct syscore_ops instead of sysdevs
Signed-off-by: Yoichi Yuasa <yuasa@linux-mips.org>
Cc: linux-mips <linux-mips@linux-mips.org>
Patchwork: https://patchwork.linux-mips.org/patch/2394/
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
---
diff --git a/arch/mips/kernel/i8259.c b/arch/mips/kernel/i8259.c
index c018696..5c74eb7 100644
--- a/arch/mips/kernel/i8259.c
+++ b/arch/mips/kernel/i8259.c
@@ -14,7 +14,7 @@
#include <linux/interrupt.h>
#include <linux/kernel.h>
#include <linux/spinlock.h>
-#include <linux/sysdev.h>
+#include <linux/syscore_ops.h>
#include <linux/irq.h>
#include <asm/i8259.h>
@@ -215,14 +215,13 @@ spurious_8259A_irq:
}
}
-static int i8259A_resume(struct sys_device *dev)
+static void i8259A_resume(void)
{
if (i8259A_auto_eoi >= 0)
init_8259A(i8259A_auto_eoi);
- return 0;
}
-static int i8259A_shutdown(struct sys_device *dev)
+static void i8259A_shutdown(void)
{
/* Put the i8259A into a quiescent state that
* the kernel initialization code can get it
@@ -232,26 +231,17 @@ static int i8259A_shutdown(struct sys_device *dev)
outb(0xff, PIC_MASTER_IMR); /* mask all of 8259A-1 */
outb(0xff, PIC_SLAVE_IMR); /* mask all of 8259A-1 */
}
- return 0;
}
-static struct sysdev_class i8259_sysdev_class = {
- .name = "i8259",
+static struct syscore_ops i8259_syscore_ops = {
.resume = i8259A_resume,
.shutdown = i8259A_shutdown,
};
-static struct sys_device device_i8259A = {
- .id = 0,
- .cls = &i8259_sysdev_class,
-};
-
static int __init i8259A_init_sysfs(void)
{
- int error = sysdev_class_register(&i8259_sysdev_class);
- if (!error)
- error = sysdev_register(&device_i8259A);
- return error;
+ register_syscore_ops(&i8259_syscore_ops);
+ return 0;
}
device_initcall(i8259A_init_sysfs);

View File

@ -1 +1,2 @@
+ bugfix/arm/plat-iop-fixes-fail-to-build-from-source.patch
+ bugfix/mips/mips-i8259-use-struct-syscore_ops-instead-of-sysdevs.patch