[armel/iop32x] Fix FTBFS (Closes: #629342)

svn path=/dists/trunk/linux-2.6/; revision=17596
This commit is contained in:
Ben Hutchings 2011-06-05 19:20:03 +00:00
parent ae6bf403da
commit 8783accc60
3 changed files with 31 additions and 0 deletions

3
debian/changelog vendored
View File

@ -2,6 +2,9 @@ linux-2.6 (3.0.0~rc1-1~experimental.2) experimental; urgency=low
[ maximilian attems ]
* Newer Standards-Version 3.9.2 without changes.
[ Hector Oron ]
* [armel/iop32x] Fix FTBFS (Closes: #629342)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 01 Jun 2011 06:41:14 +0100

View File

@ -0,0 +1,27 @@
From: Hector Oron <hector.oron@gmail.com>
Date: Sun, 5 Jun 2011 19:24:09 +0100
Subject: [PATCH] plat-iop: fixes fail to build from source
arch/arm/plat-iop/cp6.c:42: error: 'MODE_MASK' undeclared here (not in a function)
arch/arm/plat-iop/cp6.c:43: error: 'SVC_MODE' undeclared here (not in a function)
Signed-off-by: Hector Oron <hector.oron@gmail.com>
---
arch/arm/plat-iop/cp6.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/arch/arm/plat-iop/cp6.c b/arch/arm/plat-iop/cp6.c
index 9612a87..bab73e2 100644
--- a/arch/arm/plat-iop/cp6.c
+++ b/arch/arm/plat-iop/cp6.c
@@ -18,6 +18,7 @@
*/
#include <linux/init.h>
#include <asm/traps.h>
+#include <asm/ptrace.h>
static int cp6_trap(struct pt_regs *regs, unsigned int instr)
{
--
1.7.4.1

View File

@ -0,0 +1 @@
+ bugfix/arm/plat-iop-fixes-fail-to-build-from-source.patch