[armel/marvell] dts: kirkwood: fix SD slot default configuration for OpenRD (Closes: #811351)

This commit is contained in:
Ben Hutchings 2016-04-22 08:06:49 +01:00
parent fe835b64b1
commit b20f5e22b0
3 changed files with 38 additions and 0 deletions

2
debian/changelog vendored
View File

@ -109,6 +109,8 @@ linux (4.5.2-1) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* fs: Consolidate softdep declarations in each module
* Bump ABI to 2
* [armel/marvell] dts: kirkwood: fix SD slot default configuration for OpenRD
(Closes: #811351)
[ Aurelien Jarno ]
* [mips*] Emulate unaligned LDXC1 and SDXC1 instructions.

View File

@ -0,0 +1,35 @@
From: Aaro Koskinen <aaro.koskinen@iki.fi>
Date: Tue, 12 Jan 2016 22:07:33 +0200
Subject: ARM: dts: kirkwood: fix SD slot default configuration for OpenRD
Origin: https://git.kernel.org/linus/28c494d0c5b7e0993d067086b26c901ae23d3841
The SD card slot was enabled by default with legacy booting.
It does not work anymore with DT boot. Fix by providing GPIO configuration
that matches the old default.
Signed-off-by: Aaro Koskinen <aaro.koskinen@iki.fi>
Reviewed-by: Andrew Lunn <andrew@lunn.ch>
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
---
arch/arm/boot/dts/kirkwood-openrd.dtsi | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/arch/arm/boot/dts/kirkwood-openrd.dtsi b/arch/arm/boot/dts/kirkwood-openrd.dtsi
index 2a3dafdab09a..f65b7273bb0a 100644
--- a/arch/arm/boot/dts/kirkwood-openrd.dtsi
+++ b/arch/arm/boot/dts/kirkwood-openrd.dtsi
@@ -65,6 +65,14 @@
status = "okay";
cd-gpios = <&gpio0 29 9>;
};
+ gpio@10140 {
+ p2 {
+ gpio-hog;
+ gpios = <2 GPIO_ACTIVE_HIGH>;
+ output-high; /* Select SD by default */
+ line-name = "SelUARTorSD";
+ };
+ };
};
};

View File

@ -147,3 +147,4 @@ bugfix/all/tools-build-remove-bpf-run-time-check-at-build-time.patch
bugfix/all/power-cpupower-fix-manpages-NAME.patch
bugfix/all/tools-lib-traceevent-fix-use-of-uninitialized-variables.patch
bugfix/all/scripts-fix-x.509-pem-support-in-sign-file.patch
bugfix/arm/arm-dts-kirkwood-fix-sd-slot-default-configuration-f.patch