wireless: rt2x00: add new rt2800usb device (thanks to Cyril Brulebois) (Closes: #766802)

svn path=/dists/sid/linux/; revision=21997
This commit is contained in:
Ben Hutchings 2014-10-31 02:23:45 +00:00
parent 39b892c92e
commit a4a6a59131
3 changed files with 29 additions and 0 deletions

2
debian/changelog vendored
View File

@ -127,6 +127,8 @@ linux (3.16.7-1) UNRELEASED; urgency=medium
(Closes: #767204)
* [x86] drm/i915: Add some L3 registers to the parser whitelist
(Closes: #767148)
* wireless: rt2x00: add new rt2800usb device (thanks to Cyril Brulebois)
(Closes: #766802)
[ Mauricio Faria de Oliveira ]
* [ppc64el] Disable CONFIG_CMDLINE{,_BOOL} usage for setting consoles

View File

@ -0,0 +1,26 @@
From: Cyril Brulebois <kibi@debian.org>
Date: Sun, 26 Oct 2014 12:33:38 +0100
Subject: wireless: rt2x00: add new rt2800usb device
Bug-Debian: https://bugs.debian.org/766802
Forwarded: http://article.gmane.org/gmane.linux.kernel/1815824
0x1b75 0xa200 AirLive WN-200USB wireless 11b/g/n dongle
References: https://bugs.debian.org/766802
Reported-by: Martin Mokrejs <mmokrejs@fold.natur.cuni.cz>
Cc: stable@vger.kernel.org
Signed-off-by: Cyril Brulebois <kibi@debian.org>
---
drivers/net/wireless/rt2x00/rt2800usb.c | 1 +
1 file changed, 1 insertion(+)
--- a/drivers/net/wireless/rt2x00/rt2800usb.c
+++ b/drivers/net/wireless/rt2x00/rt2800usb.c
@@ -1111,6 +1111,7 @@ static struct usb_device_id rt2800usb_de
/* Ovislink */
{ USB_DEVICE(0x1b75, 0x3071) },
{ USB_DEVICE(0x1b75, 0x3072) },
+ { USB_DEVICE(0x1b75, 0xa200) },
/* Para */
{ USB_DEVICE(0x20b8, 0x8888) },
/* Pegatron */

View File

@ -403,3 +403,4 @@ bugfix/all/mtd-spi-nor-make-spi_nor_scan-take-a-chip-type-name-.patch
bugfix/all/mtd-m25p80-spi-nor-Fix-module-aliases-for-m25p80.patch
bugfix/all/HID-i2c-hid-call-the-hid-driver-s-suspend-and-resume.patch
bugfix/x86/drm-i915-Add-some-L3-registers-to-the-parser-whiteli.patch
features/all/wireless-rt2x00-add-new-rt2800usb-device.patch