[x86] drm/i915: Add some L3 registers to the parser whitelist (Closes: #767148)

svn path=/dists/sid/linux/; revision=21996
This commit is contained in:
Ben Hutchings 2014-10-31 02:17:26 +00:00
parent 4911e738a3
commit 39b892c92e
3 changed files with 41 additions and 0 deletions

2
debian/changelog vendored
View File

@ -125,6 +125,8 @@ linux (3.16.7-1) UNRELEASED; urgency=medium
* m25p80: Fix module device ID table
* HID: i2c-hid: call the hid driver's suspend and resume callbacks
(Closes: #767204)
* [x86] drm/i915: Add some L3 registers to the parser whitelist
(Closes: #767148)
[ Mauricio Faria de Oliveira ]
* [ppc64el] Disable CONFIG_CMDLINE{,_BOOL} usage for setting consoles

View File

@ -0,0 +1,38 @@
From: Brad Volkin <bradley.d.volkin@intel.com>
Date: Tue, 17 Jun 2014 14:10:34 -0700
Subject: drm/i915: Add some L3 registers to the parser whitelist
Origin: https://git.kernel.org/linus/c9224faa59c3071ecfa2d4b24592f4eb61e57069
Beignet needs these in order to program the L3 cache config for
OpenCL workloads, particularly when using SLM.
Signed-off-by: Brad Volkin <bradley.d.volkin@intel.com>
Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
drivers/gpu/drm/i915/i915_cmd_parser.c | 3 +++
drivers/gpu/drm/i915/i915_reg.h | 2 ++
2 files changed, 5 insertions(+)
--- a/drivers/gpu/drm/i915/i915_cmd_parser.c
+++ b/drivers/gpu/drm/i915/i915_cmd_parser.c
@@ -426,6 +426,9 @@ static const u32 gen7_render_regs[] = {
GEN7_SO_WRITE_OFFSET(1),
GEN7_SO_WRITE_OFFSET(2),
GEN7_SO_WRITE_OFFSET(3),
+ GEN7_L3SQCREG1,
+ GEN7_L3CNTLREG2,
+ GEN7_L3CNTLREG3,
};
static const u32 gen7_blt_regs[] = {
--- a/drivers/gpu/drm/i915/i915_reg.h
+++ b/drivers/gpu/drm/i915/i915_reg.h
@@ -4630,6 +4630,8 @@ enum punit_power_well {
#define GEN7_L3CNTLREG1 0xB01C
#define GEN7_WA_FOR_GEN7_L3_CONTROL 0x3C47FF8C
#define GEN7_L3AGDIS (1<<19)
+#define GEN7_L3CNTLREG2 0xB020
+#define GEN7_L3CNTLREG3 0xB024
#define GEN7_L3_CHICKEN_MODE_REGISTER 0xB030
#define GEN7_WA_L3_CHICKEN_MODE 0x20000000

View File

@ -402,3 +402,4 @@ bugfix/all/mtd-m25p80-get-rid-of-spi_get_device_id.patch
bugfix/all/mtd-spi-nor-make-spi_nor_scan-take-a-chip-type-name-.patch
bugfix/all/mtd-m25p80-spi-nor-Fix-module-aliases-for-m25p80.patch
bugfix/all/HID-i2c-hid-call-the-hid-driver-s-suspend-and-resume.patch
bugfix/x86/drm-i915-Add-some-L3-registers-to-the-parser-whiteli.patch