Revert "uapi/linux/keyctl.h: don't use C++ reserved keyword as a struct member name"

Closes: #909813
This commit is contained in:
Ben Hutchings 2018-10-07 21:56:58 +01:00
parent 272a938bb7
commit a2764e86a2
3 changed files with 61 additions and 0 deletions

2
debian/changelog vendored
View File

@ -4,6 +4,8 @@ linux (4.18.10-2) UNRELEASED; urgency=medium
* [rt][arm64,armhf] Fix build failure after rebasing onto 4.18.10
* xen-netback: fix input validation in xenvif_set_hash_mapping()
(CVE-2018-15471)
* Revert "uapi/linux/keyctl.h: don't use C++ reserved keyword as a struct
member name" (Closes: #909813)
[ Salvatore Bonaccorso ]
* [arm64] KVM: Tighten guest core register access from userspace

View File

@ -0,0 +1,58 @@
From: Lubomir Rintel <lkundrak@v3.sk>
Date: Mon, 24 Sep 2018 13:18:34 +0100
Subject: Revert "uapi/linux/keyctl.h: don't use C++ reserved keyword as a
struct member name"
Origin: https://git.kernel.org/linus/8c0f9f5b309d627182d5da72a69246f58bde1026
Bug-Debian: https://bugs.debian.org/909813
This changes UAPI, breaking iwd and libell:
ell/key.c: In function 'kernel_dh_compute':
ell/key.c:205:38: error: 'struct keyctl_dh_params' has no member named 'private'; did you mean 'dh_private'?
struct keyctl_dh_params params = { .private = private,
^~~~~~~
dh_private
This reverts commit 8a2336e549d385bb0b46880435b411df8d8200e8.
Fixes: 8a2336e549d3 ("uapi/linux/keyctl.h: don't use C++ reserved keyword as a struct member name")
Signed-off-by: Lubomir Rintel <lkundrak@v3.sk>
Signed-off-by: David Howells <dhowells@redhat.com>
cc: Randy Dunlap <rdunlap@infradead.org>
cc: Mat Martineau <mathew.j.martineau@linux.intel.com>
cc: Stephan Mueller <smueller@chronox.de>
cc: James Morris <jmorris@namei.org>
cc: "Serge E. Hallyn" <serge@hallyn.com>
cc: Mat Martineau <mathew.j.martineau@linux.intel.com>
cc: Andrew Morton <akpm@linux-foundation.org>
cc: Linus Torvalds <torvalds@linux-foundation.org>
cc: <stable@vger.kernel.org>
Signed-off-by: James Morris <james.morris@microsoft.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
---
include/uapi/linux/keyctl.h | 2 +-
security/keys/dh.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
--- a/include/uapi/linux/keyctl.h
+++ b/include/uapi/linux/keyctl.h
@@ -65,7 +65,7 @@
/* keyctl structures */
struct keyctl_dh_params {
- __s32 dh_private;
+ __s32 private;
__s32 prime;
__s32 base;
};
--- a/security/keys/dh.c
+++ b/security/keys/dh.c
@@ -300,7 +300,7 @@ long __keyctl_dh_compute(struct keyctl_d
}
dh_inputs.g_size = dlen;
- dlen = dh_data_from_key(pcopy.dh_private, &dh_inputs.key);
+ dlen = dh_data_from_key(pcopy.private, &dh_inputs.key);
if (dlen < 0) {
ret = dlen;
goto out2;

View File

@ -98,6 +98,7 @@ bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/netfilter-ipvs-Fix-invalid-bytes-in-IP_VS_MH_TAB_IND.patch
bugfix/all/revert-uapi-linux-keyctl.h-don-t-use-c-reserved-keyw.patch
# Miscellaneous features
features/all/kbuild-add-build-salt-to-the-kernel-and-modules.patch