viafb: Add transitive dependencies via gpiolib

Fix the FTBFS for alpha, ia64 and most mips/mipsel flavours.
Revert the explicit config change for ia64.

svn path=/dists/trunk/linux-2.6/; revision=15985
This commit is contained in:
Ben Hutchings 2010-07-13 23:26:01 +00:00
parent 294fb5ca48
commit 3cf4012f58
4 changed files with 31 additions and 2 deletions

3
debian/changelog vendored
View File

@ -1,7 +1,8 @@
linux-2.6 (2.6.35~rc5-1~experimental.2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* [ia64] Disable FB_VIA; gpiolib cannot be built for ia64
* [alpha, ia64, mips, mipsel except loongson2f] Disable FB_VIA; it now
depends on GPIOLIB which is not available on these architectures
-- Ben Hutchings <ben@decadent.org.uk> Tue, 13 Jul 2010 14:01:16 +0100

View File

@ -695,7 +695,6 @@ CONFIG_FB_SAVAGE_I2C=y
CONFIG_FB_SIS=m
CONFIG_FB_SIS_300=y
CONFIG_FB_SIS_315=y
# CONFIG_FB_VIA is not set
CONFIG_FB_NEOMAGIC=m
CONFIG_FB_KYRO=m
CONFIG_FB_VOODOO1=m

View File

@ -0,0 +1,28 @@
From 98084fc0950600f2d9f22356fc4e16ced03d72f6 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 14 Jul 2010 00:09:23 +0100
Subject: [PATCH] viafb: Add transitive dependencies via gpiolib
FB_VIA now selects GPIOLIB, but that is not available on all
architectures. Change FB_VIA dependencies to include GPIOLIB
dependencies.
---
drivers/video/Kconfig | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/video/Kconfig b/drivers/video/Kconfig
index 3d94a14..bc4534d 100644
--- a/drivers/video/Kconfig
+++ b/drivers/video/Kconfig
@@ -1505,7 +1505,7 @@ config FB_SIS_315
config FB_VIA
tristate "VIA UniChrome (Pro) and Chrome9 display support"
- depends on FB && PCI
+ depends on FB && PCI && (ARCH_WANT_OPTIONAL_GPIOLIB || ARCH_REQUIRE_GPIOLIB)
select FB_CFB_FILLRECT
select FB_CFB_COPYAREA
select FB_CFB_IMAGEBLIT
--
1.7.1

View File

@ -0,0 +1 @@
+ bugfix/all/viafb-Add-transitive-dependencies-via-gpiolib.patch