Drop 0027-RDMA-hns-Fix-the-bug-with-updating-rq-head-pointer-w.patch

This commit is contained in:
Salvatore Bonaccorso 2019-12-17 14:11:29 +01:00
parent b9568ec214
commit 9d10b57769
3 changed files with 1 additions and 50 deletions

1
debian/changelog vendored
View File

@ -326,6 +326,7 @@ linux (4.19.88-1) UNRELEASED; urgency=medium
[ Salvatore Bonaccorso ]
* Refresh powerpc-fix-mcpu-options-for-spe-only-compiler.patch (Context
changes in 4.19.88)
* Drop 0027-RDMA-hns-Fix-the-bug-with-updating-rq-head-pointer-w.patch
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 14 Dec 2019 22:00:16 +0100

View File

@ -1,49 +0,0 @@
From 42472e368c1bbe74d7316d549ae4f83097f54c87 Mon Sep 17 00:00:00 2001
From: Lijun Ou <oulijun@huawei.com>
Date: Wed, 12 Dec 2018 17:49:06 +0800
Subject: [PATCH 27/31] RDMA/hns: Fix the bug with updating rq head pointer
when flush cqe
Origin: https://git.kernel.org/linus/9c6ccc035c209dda07685e8dba829a203ba17499
When flush cqe with srq, the driver disable to update the rq head pointer
into the hardware.
Signed-off-by: Lijun Ou <oulijun@huawei.com>
Signed-off-by: Jason Gunthorpe <jgg@mellanox.com>
---
drivers/infiniband/hw/hns/hns_roce_hw_v2.c | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)
Index: linux/drivers/infiniband/hw/hns/hns_roce_hw_v2.c
===================================================================
--- linux.orig/drivers/infiniband/hw/hns/hns_roce_hw_v2.c
+++ linux/drivers/infiniband/hw/hns/hns_roce_hw_v2.c
@@ -3499,13 +3499,16 @@ static int hns_roce_v2_modify_qp(struct
roce_set_field(qpc_mask->byte_160_sq_ci_pi,
V2_QPC_BYTE_160_SQ_PRODUCER_IDX_M,
V2_QPC_BYTE_160_SQ_PRODUCER_IDX_S, 0);
- roce_set_field(context->byte_84_rq_ci_pi,
+
+ if (!ibqp->srq) {
+ roce_set_field(context->byte_84_rq_ci_pi,
V2_QPC_BYTE_84_RQ_PRODUCER_IDX_M,
V2_QPC_BYTE_84_RQ_PRODUCER_IDX_S,
hr_qp->rq.head);
- roce_set_field(qpc_mask->byte_84_rq_ci_pi,
+ roce_set_field(qpc_mask->byte_84_rq_ci_pi,
V2_QPC_BYTE_84_RQ_PRODUCER_IDX_M,
V2_QPC_BYTE_84_RQ_PRODUCER_IDX_S, 0);
+ }
}
if (attr_mask & IB_QP_AV) {
@@ -3967,7 +3970,8 @@ static void hns_roce_set_qps_to_err(stru
if (hr_qp->ibqp.uobject) {
if (hr_qp->sdb_en == 1) {
hr_qp->sq.head = *(int *)(hr_qp->sdb.virt_addr);
- hr_qp->rq.head = *(int *)(hr_qp->rdb.virt_addr);
+ if (hr_qp->rdb_en == 1)
+ hr_qp->rq.head = *(int *)(hr_qp->rdb.virt_addr);
} else {
dev_warn(hr_dev->dev, "flush cqe is unsupported in userspace!\n");
return;

View File

@ -283,7 +283,6 @@ bugfix/arm64/huawei-taishan/0023-net-hns3-change-default-tc-state-to-close.patch
bugfix/arm64/huawei-taishan/0024-net-hns3-fix-a-bug-caused-by-udelay.patch
bugfix/arm64/huawei-taishan/0025-net-hns3-remove-redundant-variable-initialization.patch
bugfix/arm64/huawei-taishan/0026-net-hns3-call-hns3_nic_net_open-while-doing-HNAE3_UP.patch
bugfix/arm64/huawei-taishan/0027-RDMA-hns-Fix-the-bug-with-updating-rq-head-pointer-w.patch
bugfix/arm64/huawei-taishan/0028-RDMA-hns-Bugfix-for-the-scene-without-receiver-queue.patch
bugfix/arm64/huawei-taishan/0029-RDMA-hns-Add-constraint-on-the-setting-of-local-ACK-.patch
bugfix/arm64/huawei-taishan/0030-RDMA-hns-Modify-the-pbl-ba-page-size-for-hip08.patch