Refresh powerpc-fix-mcpu-options-for-spe-only-compiler.patch (Context changes in 4.19.88)

This commit is contained in:
Salvatore Bonaccorso 2019-12-17 14:05:57 +01:00
parent f73fafb39e
commit b9568ec214
2 changed files with 9 additions and 7 deletions

4
debian/changelog vendored
View File

@ -323,6 +323,10 @@ linux (4.19.88-1) UNRELEASED; urgency=medium
- platform/x86: hp-wmi: Fix ACPI errors caused by passing 0 as input size
- net: fec: fix clock count mis-match
[ Salvatore Bonaccorso ]
* Refresh powerpc-fix-mcpu-options-for-spe-only-compiler.patch (Context
changes in 4.19.88)
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 14 Dec 2019 22:00:16 +0100
linux (4.19.87-1) buster; urgency=medium

View File

@ -13,10 +13,8 @@ error.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
Index: linux/arch/powerpc/Makefile
===================================================================
--- linux.orig/arch/powerpc/Makefile
+++ linux/arch/powerpc/Makefile
--- a/arch/powerpc/Makefile
+++ b/arch/powerpc/Makefile
@@ -12,7 +12,7 @@
# Rewritten by Cort Dougan and Paul Mackerras
#
@ -26,15 +24,15 @@ Index: linux/arch/powerpc/Makefile
# Set default 32 bits cross compilers for vdso and boot wrapper
CROSS32_COMPILE ?=
@@ -148,6 +148,7 @@ CFLAGS-$(CONFIG_PPC64) += $(call cc-opti
CFLAGS-$(CONFIG_PPC32) := -ffixed-r2 $(MULTIPLEWORD)
@@ -155,6 +155,7 @@
CFLAGS-$(CONFIG_PPC32) += $(call cc-option,-mno-readonly-in-sdata)
+ifdef CONFIG_PPC64
ifdef CONFIG_PPC_BOOK3S_64
ifdef CONFIG_CPU_LITTLE_ENDIAN
CFLAGS-$(CONFIG_GENERIC_CPU) += -mcpu=power8
@@ -159,6 +160,7 @@ endif
@@ -166,6 +167,7 @@
else
CFLAGS-$(CONFIG_GENERIC_CPU) += -mcpu=powerpc64
endif