[x86] efivars: Reenable 'paranoid' size check by default, as it should no longer have false positives

svn path=/dists/trunk/linux/; revision=20320
This commit is contained in:
Ben Hutchings 2013-07-01 06:00:13 +00:00
parent 2d05e27b23
commit 97873a332f
3 changed files with 2 additions and 30 deletions

2
debian/changelog vendored
View File

@ -12,6 +12,8 @@ linux (3.10-1~exp1) UNRELEASED; urgency=low
* [rt] genpatch.py: Add Origin header to all patches
* debian/bin/check-patches.sh: Report missing DEP-3 headers
* alx: Use upstream minimal driver
* [x86] efivars: Reenable 'paranoid' size check by default, as it should
no longer have false positives
-- Ben Hutchings <ben@decadent.org.uk> Mon, 01 Jul 2013 00:58:08 +0100

View File

@ -1,29 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: efivars: Remove check for 50% full on write
Date: Sat, 23 Mar 2013 02:18:42 +0000
Forwarded: no
On my EFI-booting system (AMI firmware/Asus board), the firmware does
not garbage-collect the variable store until it is rather more than
50% full, and it also updates a variable at every boot. This check
means that variable writes are guaranteed to fail after the system has
booted more than a few hundred times.
Since pstore integration is now disabled by default in Debian, we will
not normally write that much data before rebooting and giving the
firmware a chance to garbage-collect the variable store. Therefore,
until the check can be restricted to known-bad systems, it seems less
risky to disable it for now.
---
--- a/arch/x86/platform/efi/efi.c
+++ b/arch/x86/platform/efi/efi.c
@@ -114,7 +114,7 @@ static int __init setup_add_efi_memmap(c
}
early_param("add_efi_memmap", setup_add_efi_memmap);
-static bool efi_no_storage_paranoia;
+static bool efi_no_storage_paranoia = true;
static int __init setup_storage_paranoia(char *arg)
{

View File

@ -66,7 +66,6 @@ features/all/xen/microcode-api-update.patch
debian/radeon-firmware-is-required-for-drm-and-kms-on-r600-onward.patch
debian/efi-autoload-efivars.patch
debian/efivars-remove-check-for-50-full-on-write.patch
debian/cdc_ncm-cdc_mbim-use-ncm-by-default.patch
debian/powerpcspe-omit-uimage.patch