Update to 3.10

alx: Use upstream minimal driver

svn path=/dists/trunk/linux/; revision=20319
This commit is contained in:
Ben Hutchings 2013-07-01 05:43:38 +00:00
parent eaba00d52c
commit 2d05e27b23
7 changed files with 5 additions and 13752 deletions

6
debian/changelog vendored
View File

@ -1,5 +1,8 @@
linux (3.10~rc7-1~exp2) UNRELEASED; urgency=low
linux (3.10-1~exp1) UNRELEASED; urgency=low
* New upstream release: http://kernelnewbies.org/Linux_3.10
[ Ben Hutchings ]
* cassini: Make missing firmware non-fatal (Closes: #714128)
* debian/patches: Add DEP-3 headers (From/Author, Subject/Description,
Forwarded/Origin) to all patches
@ -8,6 +11,7 @@ linux (3.10~rc7-1~exp2) UNRELEASED; urgency=low
- Fold convert-series into genpatch.py
* [rt] genpatch.py: Add Origin header to all patches
* debian/bin/check-patches.sh: Report missing DEP-3 headers
* alx: Use upstream minimal driver
-- Ben Hutchings <ben@decadent.org.uk> Mon, 01 Jul 2013 00:58:08 +0100

View File

@ -1,69 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: alx: update for 3.10
Date: Mon, 03 Jun 2013 02:41:11 +0100
Bug-Debian: http://bugs.debian.org/699129
Forwarded: no
The VLAN infrastructure now supports both C-tags or S-tags, so we need
to be explicit that we support C-tags only.
--- a/drivers/net/ethernet/atheros/alx/alx_main.c
+++ b/drivers/net/ethernet/atheros/alx/alx_main.c
@@ -432,7 +432,7 @@ static void alx_receive_skb(struct alx_a
if (vlan_flag) {
u16 vlan;
ALX_TAG_TO_VLAN(vlan_tag, vlan);
- __vlan_hwaccel_put_tag(skb, vlan);
+ __vlan_hwaccel_put_tag(skb, htons(ETH_P_8021Q), vlan);
}
netif_receive_skb(skb);
}
@@ -1465,7 +1465,7 @@ static void alx_vlan_mode(struct net_dev
if (!CHK_ADPT_FLAG(1, STATE_DOWN))
alx_disable_intr(adpt);
- if (features & NETIF_F_HW_VLAN_RX) {
+ if (features & NETIF_F_HW_VLAN_CTAG_RX) {
/* enable VLAN tag insert/strip */
SET_HW_FLAG(VLANSTRIP_EN);
} else {
@@ -2487,10 +2487,10 @@ static netdev_features_t alx_fix_feature
* Since there is no support for separate rx/tx vlan accel
* enable/disable make sure tx flag is always in same state as rx.
*/
- if (features & NETIF_F_HW_VLAN_RX)
- features |= NETIF_F_HW_VLAN_TX;
+ if (features & NETIF_F_HW_VLAN_CTAG_RX)
+ features |= NETIF_F_HW_VLAN_CTAG_TX;
else
- features &= ~NETIF_F_HW_VLAN_TX;
+ features &= ~NETIF_F_HW_VLAN_CTAG_TX;
if (netdev->mtu > ALX_MAX_TSO_PKT_SIZE ||
adpt->hw.mac_type == alx_mac_l1c ||
@@ -2506,7 +2506,7 @@ static int alx_set_features(struct net_d
{
netdev_features_t changed = netdev->features ^ features;
- if (changed & NETIF_F_HW_VLAN_RX)
+ if (changed & NETIF_F_HW_VLAN_CTAG_RX)
alx_vlan_mode(netdev, features);
return 0;
}
@@ -3577,7 +3577,7 @@ static int alx_init(struct pci_dev *pdev
netdev->hw_features = NETIF_F_SG |
NETIF_F_HW_CSUM |
- NETIF_F_HW_VLAN_RX;
+ NETIF_F_HW_VLAN_CTAG_RX;
if (adpt->hw.mac_type != alx_mac_l1c &&
adpt->hw.mac_type != alx_mac_l2c) {
netdev->hw_features = netdev->hw_features |
@@ -3585,7 +3585,7 @@ static int alx_init(struct pci_dev *pdev
NETIF_F_TSO6;
}
netdev->features = netdev->hw_features |
- NETIF_F_HW_VLAN_TX;
+ NETIF_F_HW_VLAN_CTAG_TX;
/* get mac addr and perm mac addr, set to register */
if (hw->cbs.get_mac_addr)

View File

@ -1,69 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: alx: update for 3.8
Date: Mon, 25 Feb 2013 05:27:56 +0000
Bug-Debian: http://bugs.debian.org/699129
Forwarded: no
__devinit and __devexit are no longer defined or needed.
__netdev_printk() has been removed, so use "%pV" to pass a
va_format to netdev_printk().
--- a/drivers/net/ethernet/atheros/alx/alx_main.c
+++ b/drivers/net/ethernet/atheros/alx/alx_main.c
@@ -122,7 +122,7 @@ void alx_hw_printk(const char *level, co
vaf.va = &args;
if (hw && hw->adpt && hw->adpt->netdev)
- __netdev_printk(level, hw->adpt->netdev, &vaf);
+ netdev_printk(level, hw->adpt->netdev, "%pV", &vaf);
else
printk("%salx_hw: %pV", level, &vaf);
@@ -1947,7 +1947,7 @@ static void alx_reset_interrupt_mode(str
}
-static int __devinit alx_init_adapter_special(struct alx_adapter *adpt)
+static int alx_init_adapter_special(struct alx_adapter *adpt)
{
switch (adpt->hw.mac_type) {
case alx_mac_l1f:
@@ -2002,7 +2002,7 @@ init_alf_adapter:
/*
* alx_init_adapter
*/
-static int __devinit alx_init_adapter(struct alx_adapter *adpt)
+static int alx_init_adapter(struct alx_adapter *adpt)
{
struct alx_hw *hw = &adpt->hw;
struct pci_dev *pdev = adpt->pdev;
@@ -3450,8 +3450,8 @@ static const struct net_device_ops alx_n
/*
* alx_init - Device Initialization Routine
*/
-static int __devinit alx_init(struct pci_dev *pdev,
- const struct pci_device_id *ent)
+static int alx_init(struct pci_dev *pdev,
+ const struct pci_device_id *ent)
{
struct net_device *netdev;
struct alx_adapter *adpt = NULL;
@@ -3744,7 +3744,7 @@ err_alloc_device:
/*
* alx_remove - Device Removal Routine
*/
-static void __devexit alx_remove(struct pci_dev *pdev)
+static void alx_remove(struct pci_dev *pdev)
{
struct alx_adapter *adpt = pci_get_drvdata(pdev);
struct alx_hw *hw = &adpt->hw;
@@ -3866,7 +3866,7 @@ static struct pci_driver alx_driver = {
.name = alx_drv_name,
.id_table = alx_pci_tbl,
.probe = alx_init,
- .remove = __devexit_p(alx_remove),
+ .remove = alx_remove,
.shutdown = alx_shutdown,
.err_handler = &alx_err_handler,
.driver.pm = ALX_PM_OPS,

View File

@ -1,36 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: alx: mark as staging
Date: Sun, 27 Jan 2013 23:43:01 +0000
Bug-Debian: http://bugs.debian.org/699129
Forwarded: not-needed
Since alx has not been accepted upstream (or even re-submitted for
many months), it should be treated as staging.
Also remove the netdev list and supported flag from its MAINTAINERS
entry.
---
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -1326,10 +1326,8 @@ M: Cloud Ren <cjren@qca.qualcomm.com>
M: Stevent Li <steventl@qca.qualcomm.com>
M: Wu Ken <kenw@qca.qualcomm.com>
M: David Liu <dwliu@qca.qualcomm.com>
-L: netdev@vger.kernel.org
L: nic-devel@qualcomm.com
W: http://wireless.kernel.org/en/users/Drivers/ethernet/alx
-S: Supported
F: drivers/net/ethernet/atheros/alx/
ATM
--- a/drivers/net/ethernet/atheros/alx/alx_main.c
+++ b/drivers/net/ethernet/atheros/alx/alx_main.c
@@ -41,6 +41,7 @@ MODULE_DEVICE_TABLE(pci, alx_pci_tbl);
MODULE_AUTHOR("Qualcomm Corporation, <nic-devel@qualcomm.com>");
MODULE_DESCRIPTION("Qualcomm Atheros Gigabit Ethernet Driver");
MODULE_LICENSE("Dual BSD/GPL");
+MODULE_INFO(staging, "Y");
static int alx_open_internal(struct alx_adapter *adpt, u32 ctrl);
static void alx_stop_internal(struct alx_adapter *adpt, u32 ctrl);

View File

@ -1,71 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: alx: remove atl1c devices
Date: Sun, 27 Jan 2013 23:37:52 +0000
Bug-Debian: http://bugs.debian.org/699129
Forwarded: not-needed
When alx was first reviewed, upstream demanded that any changes to
support for the currently supported AR8131/8132/8151/8152 chips be
made as a series of patches, not by deprecating or removing atl1c in a
monolithic patch. Therefore:
Luis R. Rodriguez <mcgrof@frijolero.org> wrote:
> The alx driver is to only support the AR8161 and AR8162
> devices. The older devices are supported through atl1c.
I've also changed the Kconfig help text to reflect this.
---
--- a/drivers/net/ethernet/atheros/Kconfig
+++ b/drivers/net/ethernet/atheros/Kconfig
@@ -56,14 +56,13 @@ config ATL1E
will be called atl1e.
config ATL1C
- tristate "Atheros L1C Gigabit Ethernet support (DEPRECATED)"
+ tristate "Atheros L1C Gigabit Ethernet support"
depends on PCI
select CRC32
select NET_CORE
select MII
---help---
This driver supports the Atheros L1C gigabit ethernet adapter.
- This driver is deprecated in favor for the alx (CONFIG_ALX) driver.
This driver supports the following chipsets:
1969:1063 - AR8131 Gigabit Ethernet
@@ -84,18 +83,7 @@ config ALX
select MII
---help---
This driver supports the Atheros L1C/L1D/L1F gigabit ethernet
- adapter. The alx driver is intended to replace completely the
- atl1c driver with proper support and commitment from Qualcomm
- Atheros (QCA). Both atl1c and alx supports the following chipsets:
-
- 1969:1063 - AR8131 Gigabit Ethernet
- 1969:1062 - AR8132 Fast Ethernet (10/100 Mbit/s)
- 1969:2062 - AR8152 v2.0 Fast Ethernet
- 1969:2060 - AR8152 v1.1 Fast Ethernet
- 1969:1073 - AR8151 v1.0 Gigabit Ethernet
- 1969:1083 - AR8151 v2.0 Gigabit Ethernet
-
- Only alx supports the following chipsets:
+ adapter. alx supports the following chipsets:
1969:1091 - AR8161
1969:1090 - AR8162
--- a/drivers/net/ethernet/atheros/alx/alx_main.c
+++ b/drivers/net/ethernet/atheros/alx/alx_main.c
@@ -33,12 +33,6 @@ static const char alx_drv_description[]
#define ALX_ETHER_DEVICE(device_id) {\
PCI_DEVICE(ALX_VENDOR_ID, device_id)}
static DEFINE_PCI_DEVICE_TABLE(alx_pci_tbl) = {
- ALX_ETHER_DEVICE(ALX_DEV_ID_AR8131),
- ALX_ETHER_DEVICE(ALX_DEV_ID_AR8132),
- ALX_ETHER_DEVICE(ALX_DEV_ID_AR8151_V1),
- ALX_ETHER_DEVICE(ALX_DEV_ID_AR8151_V2),
- ALX_ETHER_DEVICE(ALX_DEV_ID_AR8152_V1),
- ALX_ETHER_DEVICE(ALX_DEV_ID_AR8152_V2),
ALX_ETHER_DEVICE(ALX_DEV_ID_AR8161),
ALX_ETHER_DEVICE(ALX_DEV_ID_AR8162),
{0,}

View File

@ -64,13 +64,6 @@ bugfix/all/ath6kl-do-not-use-virt_addr_valid.patch
features/all/xen/microcode-api-update.patch
# alx *still* isn't upstream
features/all/alx/alx-add-new-QCA-ethernet-driver-which-supercedes-atl.patch
features/all/alx/remove-atl1c-devices-from-alx.patch
features/all/alx/mark-as-staging.patch
features/all/alx/alx-update-for-3.8.patch
features/all/alx/alx-update-for-3.10.patch
debian/radeon-firmware-is-required-for-drm-and-kms-on-r600-onward.patch
debian/efi-autoload-efivars.patch
debian/efivars-remove-check-for-50-full-on-write.patch