[rt] Refresh 0199-net-move-xmit_recursion-to-per-task-variable-on-RT.patch (Context changes in 4.19.88)

This commit is contained in:
Salvatore Bonaccorso 2019-12-17 14:23:28 +01:00
parent 60468edbdf
commit 96a8136906
2 changed files with 17 additions and 23 deletions

2
debian/changelog vendored
View File

@ -328,6 +328,8 @@ linux (4.19.88-1) UNRELEASED; urgency=medium
changes in 4.19.88)
* Drop 0027-RDMA-hns-Fix-the-bug-with-updating-rq-head-pointer-w.patch
* Drop 0028-RDMA-hns-Bugfix-for-the-scene-without-receiver-queue.patch
* [rt] Refresh 0199-net-move-xmit_recursion-to-per-task-variable-on-RT.patch
(Context changes in 4.19.88)
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 14 Dec 2019 22:00:16 +0100

View File

@ -23,11 +23,9 @@ Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
net/core/filter.c | 6 +--
4 files changed, 104 insertions(+), 15 deletions(-)
diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h
index 384c63ecb9ae..b6a75296eb46 100644
--- a/include/linux/netdevice.h
+++ b/include/linux/netdevice.h
@@ -587,7 +587,11 @@ struct netdev_queue {
@@ -587,7 +587,11 @@
* write-mostly part
*/
spinlock_t _xmit_lock ____cacheline_aligned_in_smp;
@ -39,7 +37,7 @@ index 384c63ecb9ae..b6a75296eb46 100644
/*
* Time (in jiffies) of last Tx
*/
@@ -2611,14 +2615,53 @@ void netdev_freemem(struct net_device *dev);
@@ -2611,14 +2615,53 @@
void synchronize_net(void);
int init_dummy_netdev(struct net_device *dev);
@ -94,8 +92,8 @@ index 384c63ecb9ae..b6a75296eb46 100644
struct net_device *dev_get_by_index(struct net *net, int ifindex);
struct net_device *__dev_get_by_index(struct net *net, int ifindex);
struct net_device *dev_get_by_index_rcu(struct net *net, int ifindex);
@@ -3794,10 +3837,48 @@ static inline u32 netif_msg_init(int debug_value, int default_msg_enable_bits)
return (1 << debug_value) - 1;
@@ -3794,10 +3837,48 @@
return (1U << debug_value) - 1;
}
+#ifdef CONFIG_PREEMPT_RT_FULL
@ -144,7 +142,7 @@ index 384c63ecb9ae..b6a75296eb46 100644
}
static inline bool __netif_tx_acquire(struct netdev_queue *txq)
@@ -3814,32 +3895,32 @@ static inline void __netif_tx_release(struct netdev_queue *txq)
@@ -3814,32 +3895,32 @@
static inline void __netif_tx_lock_bh(struct netdev_queue *txq)
{
spin_lock_bh(&txq->_xmit_lock);
@ -182,25 +180,21 @@ index 384c63ecb9ae..b6a75296eb46 100644
txq->trans_start = jiffies;
}
diff --git a/include/linux/sched.h b/include/linux/sched.h
index 53d92153700b..5e1cc92c2f5c 100644
--- a/include/linux/sched.h
+++ b/include/linux/sched.h
@@ -1216,6 +1216,9 @@ struct task_struct {
#endif
@@ -1217,6 +1217,9 @@
#ifdef CONFIG_DEBUG_ATOMIC_SLEEP
unsigned long task_state_change;
+#endif
#endif
+#ifdef CONFIG_PREEMPT_RT_FULL
+ int xmit_recursion;
#endif
+#endif
int pagefault_disabled;
#ifdef CONFIG_MMU
diff --git a/net/core/dev.c b/net/core/dev.c
index 794c64b0a6ce..13531bd05ffb 100644
struct task_struct *oom_reaper_list;
--- a/net/core/dev.c
+++ b/net/core/dev.c
@@ -3537,8 +3537,10 @@ static void skb_update_prio(struct sk_buff *skb)
@@ -3537,8 +3537,10 @@
#define skb_update_prio(skb)
#endif
@ -211,7 +205,7 @@ index 794c64b0a6ce..13531bd05ffb 100644
/**
* dev_loopback_xmit - loop back @skb
@@ -3829,9 +3831,12 @@ static int __dev_queue_xmit(struct sk_buff *skb, struct net_device *sb_dev)
@@ -3829,9 +3831,12 @@
if (dev->flags & IFF_UP) {
int cpu = smp_processor_id(); /* ok because BHs are off */
@ -226,7 +220,7 @@ index 794c64b0a6ce..13531bd05ffb 100644
goto recursion_alert;
skb = validate_xmit_skb(skb, dev, &again);
@@ -3841,9 +3846,9 @@ static int __dev_queue_xmit(struct sk_buff *skb, struct net_device *sb_dev)
@@ -3841,9 +3846,9 @@
HARD_TX_LOCK(dev, txq, cpu);
if (!netif_xmit_stopped(txq)) {
@ -238,7 +232,7 @@ index 794c64b0a6ce..13531bd05ffb 100644
if (dev_xmit_complete(rc)) {
HARD_TX_UNLOCK(dev, txq);
goto out;
@@ -8388,7 +8393,7 @@ static void netdev_init_one_queue(struct net_device *dev,
@@ -8402,7 +8407,7 @@
/* Initialize queue lock */
spin_lock_init(&queue->_xmit_lock);
netdev_set_xmit_lockdep_class(&queue->_xmit_lock, dev->type);
@ -247,11 +241,9 @@ index 794c64b0a6ce..13531bd05ffb 100644
netdev_queue_numa_node_write(queue, NUMA_NO_NODE);
queue->dev = dev;
#ifdef CONFIG_BQL
diff --git a/net/core/filter.c b/net/core/filter.c
index e6fa88506c00..b3b9b8d8a28d 100644
--- a/net/core/filter.c
+++ b/net/core/filter.c
@@ -2000,7 +2000,7 @@ static inline int __bpf_tx_skb(struct net_device *dev, struct sk_buff *skb)
@@ -2000,7 +2000,7 @@
{
int ret;
@ -260,7 +252,7 @@ index e6fa88506c00..b3b9b8d8a28d 100644
net_crit_ratelimited("bpf: recursion limit reached on datapath, buggy bpf program?\n");
kfree_skb(skb);
return -ENETDOWN;
@@ -2008,9 +2008,9 @@ static inline int __bpf_tx_skb(struct net_device *dev, struct sk_buff *skb)
@@ -2008,9 +2008,9 @@
skb->dev = dev;