Drop 0028-RDMA-hns-Bugfix-for-the-scene-without-receiver-queue.patch

This commit is contained in:
Salvatore Bonaccorso 2019-12-17 14:18:42 +01:00
parent 9d10b57769
commit 60468edbdf
3 changed files with 1 additions and 30 deletions

1
debian/changelog vendored
View File

@ -327,6 +327,7 @@ linux (4.19.88-1) UNRELEASED; urgency=medium
* Refresh powerpc-fix-mcpu-options-for-spe-only-compiler.patch (Context
changes in 4.19.88)
* Drop 0027-RDMA-hns-Fix-the-bug-with-updating-rq-head-pointer-w.patch
* Drop 0028-RDMA-hns-Bugfix-for-the-scene-without-receiver-queue.patch
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 14 Dec 2019 22:00:16 +0100

View File

@ -1,29 +0,0 @@
From 0adf3f4bef9346c9cd3d1ecb7af4ee8f27d3b48a Mon Sep 17 00:00:00 2001
From: Lijun Ou <oulijun@huawei.com>
Date: Wed, 12 Dec 2018 17:49:07 +0800
Subject: [PATCH 28/31] RDMA/hns: Bugfix for the scene without receiver queue
Origin: https://git.kernel.org/linus/4d103905eb1e4f14cb62fcf962c9d35da7005dea
In some application scenario, the user could not have receive queue when
run rdma write or read operation.
Signed-off-by: Lijun Ou <oulijun@huawei.com>
Signed-off-by: Jason Gunthorpe <jgg@mellanox.com>
---
drivers/infiniband/hw/hns/hns_roce_qp.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Index: linux/drivers/infiniband/hw/hns/hns_roce_qp.c
===================================================================
--- linux.orig/drivers/infiniband/hw/hns/hns_roce_qp.c
+++ linux/drivers/infiniband/hw/hns/hns_roce_qp.c
@@ -503,7 +503,8 @@ static int hns_roce_qp_has_sq(struct ib_
static int hns_roce_qp_has_rq(struct ib_qp_init_attr *attr)
{
if (attr->qp_type == IB_QPT_XRC_INI ||
- attr->qp_type == IB_QPT_XRC_TGT || attr->srq)
+ attr->qp_type == IB_QPT_XRC_TGT || attr->srq ||
+ !attr->cap.max_recv_wr)
return 0;
return 1;

View File

@ -283,7 +283,6 @@ bugfix/arm64/huawei-taishan/0023-net-hns3-change-default-tc-state-to-close.patch
bugfix/arm64/huawei-taishan/0024-net-hns3-fix-a-bug-caused-by-udelay.patch
bugfix/arm64/huawei-taishan/0025-net-hns3-remove-redundant-variable-initialization.patch
bugfix/arm64/huawei-taishan/0026-net-hns3-call-hns3_nic_net_open-while-doing-HNAE3_UP.patch
bugfix/arm64/huawei-taishan/0028-RDMA-hns-Bugfix-for-the-scene-without-receiver-queue.patch
bugfix/arm64/huawei-taishan/0029-RDMA-hns-Add-constraint-on-the-setting-of-local-ACK-.patch
bugfix/arm64/huawei-taishan/0030-RDMA-hns-Modify-the-pbl-ba-page-size-for-hip08.patch
bugfix/arm64/huawei-taishan/0031-RDMA-hns-RDMA-hns-Assign-rq-head-pointer-when-enable.patch