Update to 3.17

usbip userspace moved to tools/usb/usbip.  Update genorig.py,
patch and makefiles accordingly.

svn path=/dists/trunk/linux-tools/; revision=21951
This commit is contained in:
Ben Hutchings 2014-10-17 09:58:05 +00:00
parent 68388906b5
commit 90fbb64333
6 changed files with 15 additions and 12 deletions

View File

@ -144,8 +144,6 @@ class Main(object):
'arch/*/Makefile', 'arch/*/Makefile',
'arch/x86/lib/memcpy_64.S', 'arch/x86/lib/memcpy_64.S',
'arch/x86/lib/memset_64.S', 'arch/x86/lib/memset_64.S',
'drivers/staging/usbip/uapi/',
'drivers/staging/usbip/userspace/',
'include/', 'include/',
'lib/rbtree.c', 'lib/rbtree.c',
'scripts/', 'scripts/',

View File

@ -3,7 +3,6 @@ DATA = \
Makefile \ Makefile \
SUBDIRS = \ SUBDIRS = \
drivers/staging/usbip \
scripts \ scripts \
tools tools

View File

@ -1,4 +1,5 @@
SUBDIRS = \ SUBDIRS = \
perf perf \
usb/usbip
include ../Makefile.inc include ../Makefile.inc

View File

@ -1,4 +1,4 @@
srcdir := $(top_srcdir)/drivers/staging/usbip/userspace srcdir := $(top_srcdir)/tools/usb/usbip
# Make sure we don't override top_srcdir in the sub-make. 'unexport # Make sure we don't override top_srcdir in the sub-make. 'unexport
# top_srcdir' is *not* sufficient; nor is adding 'MAKEFLAGS=' to the # top_srcdir' is *not* sufficient; nor is adding 'MAKEFLAGS=' to the
@ -7,18 +7,16 @@ unexport MAKEFLAGS
all: all:
cd $(srcdir) && ./autogen.sh cd $(srcdir) && ./autogen.sh
mkdir -p userspace $(srcdir)/configure \
cd userspace && $(srcdir)/configure \
--prefix=/usr \ --prefix=/usr \
--with-tcp-wrappers \ --with-tcp-wrappers \
--with-usbids-dir=/usr/share/misc \ --with-usbids-dir=/usr/share/misc \
--disable-shared --disable-shared
$(MAKE) -C userspace $(MAKE)
install: install:
$(MAKE) -C userspace install $(MAKE) install
clean: clean:
rm -rf $(addprefix $(srcdir)/,autom4te.cache aclocal.m4 compile config.guess config.h.in config.sub configure depcomp install-sh ltmain.sh missing) rm -rf $(addprefix $(srcdir)/,autom4te.cache aclocal.m4 compile config.guess config.h.in config.sub configure depcomp install-sh ltmain.sh missing)
find $(srcdir)/ -name Makefile.in -delete find $(srcdir)/ -name Makefile.in -delete
rm -rf userspace

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux-tools (3.17-1~exp1) UNRELEASED; urgency=medium
* New upstream release
- usbip userspace moved to tools/usb/usbip
-- Ben Hutchings <ben@decadent.org.uk> Fri, 17 Oct 2014 11:49:02 +0200
linux-tools (3.16-2) unstable; urgency=medium linux-tools (3.16-2) unstable; urgency=medium
* linux-kbuild: Change the type headers used for devicetable-offsets.c * linux-kbuild: Change the type headers used for devicetable-offsets.c

View File

@ -5,8 +5,8 @@ Forwarded: no
Add references to TCP wrappers configuration in the manual page. Add references to TCP wrappers configuration in the manual page.
--- a/drivers/staging/usbip/userspace/doc/usbipd.8 --- a/tools/usb/usbip/doc/usbipd.8
+++ b/drivers/staging/usbip/userspace/doc/usbipd.8 +++ b/tools/usb/usbip/doc/usbipd.8
@@ -14,7 +14,8 @@ Devices have to explicitly be exported u @@ -14,7 +14,8 @@ Devices have to explicitly be exported u
before usbipd makes them available to other hosts. before usbipd makes them available to other hosts.