[x86] drm/i915: prefer wide & slow to fast & narrow in DP configs (Closes: #658662)

svn path=/dists/sid/linux/; revision=19266
This commit is contained in:
Ben Hutchings 2012-07-21 18:06:28 +00:00
parent f0ee42b4df
commit 8e01cd4b5c
3 changed files with 36 additions and 0 deletions

2
debian/changelog vendored
View File

@ -38,6 +38,8 @@ linux (3.2.23-1) UNRELEASED; urgency=low
- Refactor sub-channel use
- Bump version to 1.0.0
* e100: ucode is optional in some cases
* [x86] drm/i915: prefer wide & slow to fast & narrow in DP configs
(Closes: #658662)
[ Arnaud Patard ]
* [mipsel] add r8169 to d-i udeb.

View File

@ -0,0 +1,33 @@
From: Jesse Barnes <jbarnes@virtuousgeek.org>
Date: Thu, 21 Jun 2012 15:13:50 -0700
Subject: drm/i915: prefer wide & slow to fast & narrow in DP configs
commit 2514bc510d0c3aadcc5204056bb440fa36845147 upstream.
High frequency link configurations have the potential to cause trouble
with long and/or cheap cables, so prefer slow and wide configurations
instead. This patch has the potential to cause trouble for eDP
configurations that lie about available lanes, so if we run into that we
can make it conditional on eDP.
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=45801
Tested-by: peter@colberg.org
Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
drivers/gpu/drm/i915/intel_dp.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/drivers/gpu/drm/i915/intel_dp.c
+++ b/drivers/gpu/drm/i915/intel_dp.c
@@ -708,8 +708,8 @@ intel_dp_mode_fixup(struct drm_encoder *
bpp = adjusted_mode->private_flags & INTEL_MODE_DP_FORCE_6BPC ? 18 : 24;
- for (lane_count = 1; lane_count <= max_lane_count; lane_count <<= 1) {
- for (clock = 0; clock <= max_clock; clock++) {
+ for (clock = 0; clock <= max_clock; clock++) {
+ for (lane_count = 1; lane_count <= max_lane_count; lane_count <<= 1) {
int link_avail = intel_dp_max_data_rate(intel_dp_link_clock(bws[clock]), lane_count);
if (intel_dp_link_required(mode->clock, bpp)

View File

@ -380,3 +380,4 @@ features/all/fermi-accel/drm-nouveau-oops-increase-channel-dispc_vma-to-4.patch
features/all/fermi-accel/drm-nvd0-disp-ignore-clock-set-if-no-pclk.patch
features/all/fermi-accel/drm-nouveau-bump-version-to-1.0.0.patch
bugfix/all/net-e100-ucode-is-optional-in-some-cases.patch
bugfix/x86/drm-i915-prefer-wide-slow-to-fast-narrow-in-DP-confi.patch