[armel/kirkwood] ahci: Add JMicron 362 device IDs (Closes: #634180)

svn path=/dists/sid/linux/; revision=19372
This commit is contained in:
Ben Hutchings 2012-09-10 00:13:53 +00:00
parent 9f46f66c60
commit 80bb8e7fe5
3 changed files with 29 additions and 0 deletions

1
debian/changelog vendored
View File

@ -112,6 +112,7 @@ linux (3.2.28-1) UNRELEASED; urgency=low
any chips that support PAE
* [x86] drm/i915: Fix i8xx interrupt handling (Closes: #655152)
* speakup: Fix crash on 'goto' operation (Closes: #685953)
* [armel/kirkwood] ahci: Add JMicron 362 device IDs (Closes: #634180)
[ Bastian Blank ]
* Make xen-linux-system meta-packages depend on xen-system. This allows

View File

@ -0,0 +1,27 @@
Subject: ahci: Add JMicron 362 device IDs
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 22 Jul 2011 01:43:22 +0200
The JMicron JMB362 controller supports AHCI only, but some revisions
use the IDE class code. These need to be matched by device ID.
These additions have apparently been included by QNAP in their NAS
devices using these controllers.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/ata/ahci.c | 3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
--- a/drivers/ata/ahci.c
+++ b/drivers/ata/ahci.c
@@ -264,6 +264,9 @@ static const struct pci_device_id ahci_p
/* JMicron 360/1/3/5/6, match class to avoid IDE function */
{ PCI_VENDOR_ID_JMICRON, PCI_ANY_ID, PCI_ANY_ID, PCI_ANY_ID,
PCI_CLASS_STORAGE_SATA_AHCI, 0xffffff, board_ahci_ign_iferr },
+ /* JMicron 362B and 362C have an AHCI function with IDE class code */
+ { PCI_VDEVICE(JMICRON, 0x2362), board_ahci_ign_iferr },
+ { PCI_VDEVICE(JMICRON, 0x236f), board_ahci_ign_iferr },
/* ATI */
{ PCI_VDEVICE(ATI, 0x4380), board_ahci_sb600 }, /* ATI SB600 */

View File

@ -395,3 +395,4 @@ bugfix/all/usb-Add-USB_QUIRK_RESET_RESUME-for-all-Logitech-UVC-.patch
bugfix/alpha/alpha-use-large-data-model.diff
bugfix/x86/drm-i915-i8xx-interrupt-handler.patch
bugfix/all/staging-speakup-fix-an-improperly-declared-variable.patch
features/arm/ahci-Add-JMicron-362-device-IDs.patch