speakup: Fix crash on 'goto' operation (Closes: #685953)

svn path=/dists/sid/linux/; revision=19370
This commit is contained in:
Ben Hutchings 2012-09-09 17:07:24 +00:00
parent 662f1a9f77
commit 9f46f66c60
3 changed files with 32 additions and 0 deletions

1
debian/changelog vendored
View File

@ -111,6 +111,7 @@ linux (3.2.28-1) UNRELEASED; urgency=low
* [i386/686-pae] video: Disable Geode framebuffer drivers, not used with
any chips that support PAE
* [x86] drm/i915: Fix i8xx interrupt handling (Closes: #655152)
* speakup: Fix crash on 'goto' operation (Closes: #685953)
[ Bastian Blank ]
* Make xen-linux-system meta-packages depend on xen-system. This allows

View File

@ -0,0 +1,30 @@
From: Christopher Brannon <chris@the-brannons.com>
Date: Sat, 16 Jun 2012 16:55:20 -0500
Subject: Staging: speakup: fix an improperly-declared variable.
commit 4ea418b8b2fa8a70d0fcc8231b65e67b3a72984b upstream.
A local static variable was declared as a pointer to a string
constant. We're assigning to the underlying memory, so it
needs to be an array instead.
Signed-off-by: Christopher Brannon <chris@the-brannons.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/staging/speakup/main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/speakup/main.c b/drivers/staging/speakup/main.c
index 92b34e2..40e2488 100644
--- a/drivers/staging/speakup/main.c
+++ b/drivers/staging/speakup/main.c
@@ -1854,7 +1854,7 @@ static void speakup_bits(struct vc_data *vc)
static int handle_goto(struct vc_data *vc, u_char type, u_char ch, u_short key)
{
- static u_char *goto_buf = "\0\0\0\0\0\0";
+ static u_char goto_buf[8];
static int num;
int maxlen, go_pos;
char *cp;

View File

@ -394,3 +394,4 @@ bugfix/all/usb-Add-quirk-detection-based-on-interface-informati.patch
bugfix/all/usb-Add-USB_QUIRK_RESET_RESUME-for-all-Logitech-UVC-.patch
bugfix/alpha/alpha-use-large-data-model.diff
bugfix/x86/drm-i915-i8xx-interrupt-handler.patch
bugfix/all/staging-speakup-fix-an-improperly-declared-variable.patch