Update to 2.6.37-rc7

svn path=/dists/trunk/linux-2.6/; revision=16728
This commit is contained in:
Ben Hutchings 2010-12-22 02:13:49 +00:00
parent c4bd1958a9
commit 745668d827
10 changed files with 10 additions and 245 deletions

6
debian/changelog vendored
View File

@ -1,4 +1,7 @@
linux-2.6 (2.6.37~rc5-1~experimental.4) UNRELEASED; urgency=low
linux-2.6 (2.6.37~rc7-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
- [mips] Rename mips_dma_cache_sync back to dma_cache_sync (fixes FTBFS)
[ Ben Hutchings ]
* debian/copyright: Add explanation of indirect linking of perf to
@ -6,7 +9,6 @@ linux-2.6 (2.6.37~rc5-1~experimental.4) UNRELEASED; urgency=low
* [powerpc,x86] Enable PATA_PCMCIA (Closes: #606324)
* Disable BLK_DEV_IDECS
* [alpha] Use libata-based drivers for most PATA controllers
* [mips] Restore dma_cache_sync() (fix yet another FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 11 Dec 2010 21:21:10 +0000

View File

@ -1,4 +1,3 @@
From b31595992e52f94bd87c122dfad9cc37f15f82dc Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 28 Nov 2010 23:46:46 +0000
Subject: [PATCH] dm: Deal with merge_bvec_fn in component devices better
@ -22,14 +21,9 @@ known to submit multiple small buffers in a single bio.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/md/dm-table.c | 14 +++++++-------
1 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/md/dm-table.c b/drivers/md/dm-table.c
index 90267f8..776734d 100644
--- a/drivers/md/dm-table.c
+++ b/drivers/md/dm-table.c
@@ -511,15 +511,15 @@ int dm_set_device_limits(struct dm_target *ti, struct dm_dev *dev,
@@ -511,14 +511,15 @@ int dm_set_device_limits(struct dm_target *ti, struct dm_dev *dev,
(unsigned long long) start << SECTOR_SHIFT);
/*
@ -46,12 +40,8 @@ index 90267f8..776734d 100644
+ }
- if (q->merge_bvec_fn && !ti->type->merge)
- limits->max_sectors =
- min_not_zero(limits->max_sectors,
- (unsigned int) (PAGE_SIZE >> 9));
- blk_limits_max_hw_sectors(limits,
- (unsigned int) (PAGE_SIZE >> 9));
return 0;
}
EXPORT_SYMBOL_GPL(dm_set_device_limits);
--
1.7.2.3

View File

@ -1,53 +0,0 @@
From 139eb17428367ad718debc4a6c46feb46f549f9f Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Dec 2010 02:45:03 +0000
Subject: [PATCH 2/3] arm/ixp4xx: Rename FREQ macro to avoid collisions
FREQ is a ridiculously short name for a platform-specific macro,
and it now conflicts with an enumeration in the gspca/ov519 driver.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/arm/mach-ixp4xx/common.c | 4 ++--
arch/arm/mach-ixp4xx/include/mach/timex.h | 5 +++--
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/arch/arm/mach-ixp4xx/common.c b/arch/arm/mach-ixp4xx/common.c
index 0bce097..f5c42fe 100644
--- a/arch/arm/mach-ixp4xx/common.c
+++ b/arch/arm/mach-ixp4xx/common.c
@@ -415,7 +415,7 @@ static struct clocksource clocksource_ixp4xx = {
.flags = CLOCK_SOURCE_IS_CONTINUOUS,
};
-unsigned long ixp4xx_timer_freq = FREQ;
+unsigned long ixp4xx_timer_freq = IXP4XX_TIMER_FREQ;
EXPORT_SYMBOL(ixp4xx_timer_freq);
static void __init ixp4xx_clocksource_init(void)
{
@@ -491,7 +491,7 @@ static struct clock_event_device clockevent_ixp4xx = {
static void __init ixp4xx_clockevent_init(void)
{
- clockevent_ixp4xx.mult = div_sc(FREQ, NSEC_PER_SEC,
+ clockevent_ixp4xx.mult = div_sc(IXP4XX_TIMER_FREQ, NSEC_PER_SEC,
clockevent_ixp4xx.shift);
clockevent_ixp4xx.max_delta_ns =
clockevent_delta2ns(0xfffffffe, &clockevent_ixp4xx);
diff --git a/arch/arm/mach-ixp4xx/include/mach/timex.h b/arch/arm/mach-ixp4xx/include/mach/timex.h
index 2c3f93c..c9e930f 100644
--- a/arch/arm/mach-ixp4xx/include/mach/timex.h
+++ b/arch/arm/mach-ixp4xx/include/mach/timex.h
@@ -10,6 +10,7 @@
* 66.66... MHz. We do a convulted calculation of CLOCK_TICK_RATE b/c the
* timer register ignores the bottom 2 bits of the LATCH value.
*/
-#define FREQ 66666000
-#define CLOCK_TICK_RATE (((FREQ / HZ & ~IXP4XX_OST_RELOAD_MASK) + 1) * HZ)
+#define IXP4XX_TIMER_FREQ 66666000
+#define CLOCK_TICK_RATE \
+ (((IXP4XX_TIMER_FREQ / HZ & ~IXP4XX_OST_RELOAD_MASK) + 1) * HZ)
--
1.7.2.3

View File

@ -1,37 +0,0 @@
From fe999ddb3cee7f63676938abdeacd54f28a8e325 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Dec 2010 02:52:35 +0000
Subject: [PATCH 3/3] mips: Add the necessary parameter to mips_sc_is_activated()
This might compile now; no idea whether it actually works.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/mips/mm/sc-mips.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/mips/mm/sc-mips.c b/arch/mips/mm/sc-mips.c
index 505feca..1835ddb 100644
--- a/arch/mips/mm/sc-mips.c
+++ b/arch/mips/mm/sc-mips.c
@@ -66,7 +66,7 @@ static struct bcache_ops mips_sc_ops = {
* 12..15 as implementation defined so below function will eventually have
* to be replaced by a platform specific probe.
*/
-static inline int mips_sc_is_activated(struct cpuinfo_mips *c)
+static inline int mips_sc_is_activated(struct cpuinfo_mips *c, unsigned config2)
{
/* Check the bypass bit (L2B) */
switch (c->cputype) {
@@ -108,7 +108,7 @@ static inline int __init mips_sc_probe(void)
config2 = read_c0_config2();
- if (!mips_sc_is_activated(c))
+ if (!mips_sc_is_activated(c, config2))
return 0;
tmp = (config2 >> 8) & 0x0f;
--
1.7.2.3

View File

@ -1,57 +0,0 @@
From 88f98365032251a826760b3ce8102bb9a7967c69 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Dec 2010 02:52:35 +0000
Subject: [PATCH 4/4] mips: Change mips_sc_is_activated() to do what the comment says
Add the necessary parameter for mips_sc_is_activated() to compile.
Move the cache.linesz initialisation up into mips_sc_probe().
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/mips/mm/sc-mips.c | 16 +++++++++-------
1 files changed, 9 insertions(+), 7 deletions(-)
diff --git a/arch/mips/mm/sc-mips.c b/arch/mips/mm/sc-mips.c
index 505feca..6b513bf 100644
--- a/arch/mips/mm/sc-mips.c
+++ b/arch/mips/mm/sc-mips.c
@@ -66,7 +66,7 @@ static struct bcache_ops mips_sc_ops = {
* 12..15 as implementation defined so below function will eventually have
* to be replaced by a platform specific probe.
*/
-static inline int mips_sc_is_activated(struct cpuinfo_mips *c)
+static inline int mips_sc_is_activated(struct cpuinfo_mips *c, unsigned config2)
{
/* Check the bypass bit (L2B) */
switch (c->cputype) {
@@ -78,11 +78,7 @@ static inline int mips_sc_is_activated(struct cpuinfo_mips *c)
return 0;
}
- tmp = (config2 >> 4) & 0x0f;
- if (0 < tmp && tmp <= 7)
- c->scache.linesz = 2 << tmp;
- else
- return 0;
+ return 1;
}
static inline int __init mips_sc_probe(void)
@@ -108,7 +104,13 @@ static inline int __init mips_sc_probe(void)
config2 = read_c0_config2();
- if (!mips_sc_is_activated(c))
+ if (!mips_sc_is_activated(c, config2))
+ return 0;
+
+ tmp = (config2 >> 4) & 0x0f;
+ if (0 < tmp && tmp <= 7)
+ c->scache.linesz = 2 << tmp;
+ else
return 0;
tmp = (config2 >> 8) & 0x0f;
--
1.7.2.3

View File

@ -1,42 +0,0 @@
From 3b4987bd33af91dd55325da395c236645b0aed16 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 12 Dec 2010 14:48:56 +0000
Subject: [PATCH] mips: Restore dma_cache_sync()
Commit 48e1fd5a81416a037f5a48120bf281102f2584e2 "MIPS: Convert DMA to
use dma-mapping-common.h" renamed and un-exported this function.
Since dma-mapping-common.h does not implement dma_cache_sync(), this
was incorrect.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/mips/mm/dma-default.c | 6 ++++--
1 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/arch/mips/mm/dma-default.c b/arch/mips/mm/dma-default.c
index 4fc1a0f..71d60c4 100644
--- a/arch/mips/mm/dma-default.c
+++ b/arch/mips/mm/dma-default.c
@@ -288,8 +288,8 @@ int mips_dma_supported(struct device *dev, u64 mask)
return plat_dma_supported(dev, mask);
}
-void mips_dma_cache_sync(struct device *dev, void *vaddr, size_t size,
- enum dma_data_direction direction)
+void dma_cache_sync(struct device *dev, void *vaddr, size_t size,
+ enum dma_data_direction direction)
{
BUG_ON(direction == DMA_NONE);
@@ -298,6 +298,8 @@ void mips_dma_cache_sync(struct device *dev, void *vaddr, size_t size,
__dma_sync((unsigned long)vaddr, size, direction);
}
+EXPORT_SYMBOL(dma_cache_sync);
+
static struct dma_map_ops mips_default_dma_map_ops = {
.alloc_coherent = mips_dma_alloc_coherent,
.free_coherent = mips_dma_free_coherent,
--
1.7.2.3

View File

@ -1,30 +0,0 @@
From 9118be3ce2ef2415b4e451c8defb60100e4e095d Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Dec 2010 02:34:49 +0000
Subject: [PATCH 1/3] alpha: Do not use -Werror for arch/alpha/kernel
The alpha headers for I/O currently have illegal combinations of
extern inline and static inline functions calling each other. Make
the warnings non-fatal for now.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/alpha/kernel/Makefile | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/arch/alpha/kernel/Makefile b/arch/alpha/kernel/Makefile
index 1ee9b5b..1c77b1c 100644
--- a/arch/alpha/kernel/Makefile
+++ b/arch/alpha/kernel/Makefile
@@ -4,7 +4,7 @@
extra-y := head.o vmlinux.lds
EXTRA_AFLAGS := $(KBUILD_CFLAGS)
-EXTRA_CFLAGS := -Werror -Wno-sign-compare
+EXTRA_CFLAGS := -Wno-sign-compare
obj-y := entry.o traps.o process.o init_task.o osf_sys.o irq.o \
irq_alpha.o signal.o setup.o ptrace.o time.o \
--
1.7.2.3

View File

@ -1,7 +0,0 @@
- bugfix/mips/mips-Add-the-necessary-parameter-to-mips_sc_is_activ.patch
- bugfix/arm/arm-ixp4xx-Rename-FREQ-macro-to-avoid-collisions.patch
- debian/alpha-Do-not-use-Werror-for-arch-alpha-kernel.patch
+ bugfix/arm/arm-ixp4xx-Rename-FREQ-macro-to-avoid-collisions-2.patch
+ debian/alpha-Do-not-use-Werror-for-arch-alpha.patch
+ bugfix/all/drm-nouveau-Only-select-ACPI_VIDEO-if-its-dependenci.patch
+ bugfix/mips/mips-Change-mips_sc_is_activated-to-do-what-the-comm.patch

View File

@ -1 +0,0 @@
+ bugfix/mips/mips-Restore-dma_cache_sync.patch

View File

@ -41,6 +41,6 @@
+ bugfix/all/dm-Deal-with-merge_bvec_fn-in-component-devices-bett.patch
+ features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch
+ debian/alpha-Do-not-use-Werror-for-arch-alpha-kernel.patch
+ bugfix/arm/arm-ixp4xx-Rename-FREQ-macro-to-avoid-collisions.patch
+ bugfix/mips/mips-Add-the-necessary-parameter-to-mips_sc_is_activ.patch
+ bugfix/arm/arm-ixp4xx-Rename-FREQ-macro-to-avoid-collisions-2.patch
+ debian/alpha-Do-not-use-Werror-for-arch-alpha.patch
+ bugfix/all/drm-nouveau-Only-select-ACPI_VIDEO-if-its-dependenci.patch