linux/debian/patches/debian/alpha-Do-not-use-Werror-for...

31 lines
995 B
Diff

From 9118be3ce2ef2415b4e451c8defb60100e4e095d Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 10 Dec 2010 02:34:49 +0000
Subject: [PATCH 1/3] alpha: Do not use -Werror for arch/alpha/kernel
The alpha headers for I/O currently have illegal combinations of
extern inline and static inline functions calling each other. Make
the warnings non-fatal for now.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/alpha/kernel/Makefile | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/arch/alpha/kernel/Makefile b/arch/alpha/kernel/Makefile
index 1ee9b5b..1c77b1c 100644
--- a/arch/alpha/kernel/Makefile
+++ b/arch/alpha/kernel/Makefile
@@ -4,7 +4,7 @@
extra-y := head.o vmlinux.lds
EXTRA_AFLAGS := $(KBUILD_CFLAGS)
-EXTRA_CFLAGS := -Werror -Wno-sign-compare
+EXTRA_CFLAGS := -Wno-sign-compare
obj-y := entry.o traps.o process.o init_task.o osf_sys.o irq.o \
irq_alpha.o signal.o setup.o ptrace.o time.o \
--
1.7.2.3