[arm] Fix the world famous typo with is_gate_vma()

svn path=/dists/trunk/linux/; revision=20500
This commit is contained in:
Ben Hutchings 2013-08-15 19:48:50 +00:00
commit 6fc4aa1bc4
3 changed files with 25 additions and 0 deletions

1
debian/changelog vendored
View File

@ -6,6 +6,7 @@ linux (3.11~rc5-1~exp1) UNRELEASED; urgency=low
* [arm,mips,s390,sh4] Enable KPROBES
* trace: Enable KPROBE_EVENT (Closes: #640953)
* trace: Enable UPROBES, UPROBE_EVENT (Closes: #691167)
* [arm] Fix the world famous typo with is_gate_vma()
-- Ben Hutchings <ben@decadent.org.uk> Sun, 11 Aug 2013 19:34:47 +0200

View File

@ -0,0 +1,23 @@
From: Russell King <rmk+kernel@arm.linux.org.uk>
Date: Tue, 6 Aug 2013 09:49:14 +0100
Subject: ARM: Fix the world famous typo with is_gate_vma()
Origin: http://ftp.arm.linux.org.uk/pub/linux/arm/kernel/git-cur/linux-arm.git/ commit 1d0bbf428924f94867542d49d436cf254b9dbd06
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
---
arch/arm/kernel/process.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/kernel/process.c b/arch/arm/kernel/process.c
index d03b5bd..e28d43f 100644
--- a/arch/arm/kernel/process.c
+++ b/arch/arm/kernel/process.c
@@ -459,7 +459,7 @@ int in_gate_area_no_mm(unsigned long addr)
{
return in_gate_area(NULL, addr);
}
-#define is_gate_vma(vma) ((vma) = &gate_vma)
+#define is_gate_vma(vma) ((vma) == &gate_vma)
#else
#define is_gate_vma(vma) 0
#endif

View File

@ -78,3 +78,4 @@ features/all/efi-autoload-efivars.patch
bugfix/m68k/ethernat-kconfig.patch
bugfix/all/nl80211-fix-another-nl80211_fam-attrbuf-race.patch
bugfix/arm/ARM-Fix-the-world-famous-typo-with-is_gate_vma.patch