Update to 3.11-rc5

svn path=/dists/trunk/linux/; revision=20499
This commit is contained in:
Ben Hutchings 2013-08-15 19:47:11 +00:00
parent 005ac51bc5
commit b07b19230f
4 changed files with 4 additions and 57 deletions

5
debian/changelog vendored
View File

@ -1,5 +1,8 @@
linux (3.11~rc4-1~exp2) UNRELEASED; urgency=low
linux (3.11~rc5-1~exp1) UNRELEASED; urgency=low
* New upstream release candidate
[ Ben Hutchings ]
* [arm,mips,s390,sh4] Enable KPROBES
* trace: Enable KPROBE_EVENT (Closes: #640953)
* trace: Enable UPROBES, UPROBE_EVENT (Closes: #691167)

View File

@ -1,33 +0,0 @@
From: "Martin K. Petersen" <martin.petersen@oracle.com>
Date: Tue, 30 Jul 2013 22:58:34 -0400
Subject: [SCSI] Don't attempt to send extended INQUIRY command if
skip_vpd_pages is set
Origin: https://git.kernel.org/cgit/linux/kernel/git/jejb/scsi.git/commit?id=7562523e84ddc742fe1f9db8bd76b01acca89f6b
Bug-Debian: http://bugs.debian.org/719002
If a device has the skip_vpd_pages flag set we should simply fail the
scsi_get_vpd_page() call.
Signed-off-by: Martin K. Petersen <martin.petersen@oracle.com>
Acked-by: Alan Stern <stern@rowland.harvard.edu>
Tested-by: Stuart Foster <smf.linux@ntlworld.com>
Cc: stable@vger.kernel.org
Signed-off-by: James Bottomley <JBottomley@Parallels.com>
---
drivers/scsi/scsi.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/scsi/scsi.c b/drivers/scsi/scsi.c
index 3b1ea34..eaa808e 100644
--- a/drivers/scsi/scsi.c
+++ b/drivers/scsi/scsi.c
@@ -1031,6 +1031,9 @@ int scsi_get_vpd_page(struct scsi_device *sdev, u8 page, unsigned char *buf,
{
int i, result;
+ if (sdev->skip_vpd_pages)
+ goto fail;
+
/* Ask for all the pages supported by this device */
result = scsi_vpd_inquiry(sdev, buf, 0, buf_len);
if (result)

View File

@ -1,21 +0,0 @@
From: Theodore Ts'o <tytso@mit.edu>
Date: Mon, 29 Jul 2013 16:12:56 +0000
Subject: ext4: fix retry handling in ext4_ext_truncate()
Origin: https://git.kernel.org/cgit/linux/kernel/git/tytso/ext4.git/commit/?id=94eec0fc3520c759831763d866421b4d60b599b4
We tested for ENOMEM instead of -ENOMEM. Oops.
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Cc: stable@vger.kernel.org
---
--- a/fs/ext4/extents.c
+++ b/fs/ext4/extents.c
@@ -4389,7 +4389,7 @@ void ext4_ext_truncate(handle_t *handle,
retry:
err = ext4_es_remove_extent(inode, last_block,
EXT_MAX_BLOCKS - last_block);
- if (err == ENOMEM) {
+ if (err == -ENOMEM) {
cond_resched();
congestion_wait(BLK_RW_ASYNC, HZ/50);
goto retry;

View File

@ -78,5 +78,3 @@ features/all/efi-autoload-efivars.patch
bugfix/m68k/ethernat-kconfig.patch
bugfix/all/nl80211-fix-another-nl80211_fam-attrbuf-race.patch
bugfix/all/ext4-fix-retry-handling-in-ext4_ext_truncate.patch
bugfix/all/SCSI-Don-t-attempt-to-send-extended-INQUIRY-command-.patch