[m68k] Update 'Revert "m68k: move exports to definitions"' for 4.11 (fixes FTBFS)

Closes: #862393
This commit is contained in:
Ben Hutchings 2017-06-04 02:37:40 +01:00
parent cb023ecab6
commit 65c1808993
2 changed files with 26 additions and 71 deletions

2
debian/changelog vendored
View File

@ -2,6 +2,8 @@ linux (4.11-1~exp3) UNRELEASED; urgency=medium
* [armel] udeb: Add af_packet. firmware_class, nls_base to kernel-image * [armel] udeb: Add af_packet. firmware_class, nls_base to kernel-image
(fixes FTBFS) (fixes FTBFS)
* [m68k] Update 'Revert "m68k: move exports to definitions"' for 4.11
(fixes FTBFS) (Closes: #862393)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 05 May 2017 23:06:37 +0100 -- Ben Hutchings <ben@decadent.org.uk> Fri, 05 May 2017 23:06:37 +0100

View File

@ -6,34 +6,16 @@ Forwarded: not-needed
This reverts commit d13ffb5630443e6112df0263969cbdfc8ab9ab57 because This reverts commit d13ffb5630443e6112df0263969cbdfc8ab9ab57 because
symbols exported from assembly don't automatically get modversions (ABI symbols exported from assembly don't automatically get modversions (ABI
hashes). hashes).
---
arch/m68k/include/asm/export.h | 3 ---
arch/m68k/kernel/Makefile | 2 +-
arch/m68k/kernel/m68k_ksyms.c | 32 ++++++++++++++++++++++++++++++++
arch/m68k/lib/ashldi3.c | 4 ----
arch/m68k/lib/ashrdi3.c | 4 ----
arch/m68k/lib/divsi3.S | 3 ---
arch/m68k/lib/lshrdi3.c | 4 ----
arch/m68k/lib/modsi3.S | 3 ---
arch/m68k/lib/muldi3.c | 4 ----
arch/m68k/lib/mulsi3.S | 4 ++--
arch/m68k/lib/udivsi3.S | 4 ++--
arch/m68k/lib/umodsi3.S | 4 ++--
12 files changed, 39 insertions(+), 32 deletions(-)
delete mode 100644 arch/m68k/include/asm/export.h
create mode 100644 arch/m68k/kernel/m68k_ksyms.c
diff --git a/arch/m68k/include/asm/export.h b/arch/m68k/include/asm/export.h Updated for 4.11: don't revert additions of #include <compiler.h> as
deleted file mode 100644 it's needed for other reasons (see #862393).
index 0af20f48bd07..000000000000 ---
--- a/arch/m68k/include/asm/export.h --- a/arch/m68k/include/asm/export.h
+++ /dev/null +++ /dev/null
@@ -1,3 +0,0 @@ @@ -1,3 +0,0 @@
-#define KSYM_ALIGN 2 -#define KSYM_ALIGN 2
-#define KCRC_ALIGN 2 -#define KCRC_ALIGN 2
-#include <asm-generic/export.h> -#include <asm-generic/export.h>
diff --git a/arch/m68k/kernel/Makefile b/arch/m68k/kernel/Makefile
index 74c898ced8cc..8a1c4d3f91c8 100644
--- a/arch/m68k/kernel/Makefile --- a/arch/m68k/kernel/Makefile
+++ b/arch/m68k/kernel/Makefile +++ b/arch/m68k/kernel/Makefile
@@ -13,7 +13,7 @@ extra-$(CONFIG_SUN3X) := head.o @@ -13,7 +13,7 @@ extra-$(CONFIG_SUN3X) := head.o
@ -45,9 +27,6 @@ index 74c898ced8cc..8a1c4d3f91c8 100644
obj-y += setup.o signal.o sys_m68k.o syscalltable.o time.o traps.o obj-y += setup.o signal.o sys_m68k.o syscalltable.o time.o traps.o
obj-$(CONFIG_MMU_MOTOROLA) += ints.o vectors.o obj-$(CONFIG_MMU_MOTOROLA) += ints.o vectors.o
diff --git a/arch/m68k/kernel/m68k_ksyms.c b/arch/m68k/kernel/m68k_ksyms.c
new file mode 100644
index 000000000000..774c1bd59c36
--- /dev/null --- /dev/null
+++ b/arch/m68k/kernel/m68k_ksyms.c +++ b/arch/m68k/kernel/m68k_ksyms.c
@@ -0,0 +1,32 @@ @@ -0,0 +1,32 @@
@ -83,49 +62,39 @@ index 000000000000..774c1bd59c36
+EXPORT_SYMBOL(__udivsi3); +EXPORT_SYMBOL(__udivsi3);
+EXPORT_SYMBOL(__umodsi3); +EXPORT_SYMBOL(__umodsi3);
+#endif +#endif
diff --git a/arch/m68k/lib/ashldi3.c b/arch/m68k/lib/ashldi3.c
index 8dffd36ec4f2..37234c2df47f 100644
--- a/arch/m68k/lib/ashldi3.c --- a/arch/m68k/lib/ashldi3.c
+++ b/arch/m68k/lib/ashldi3.c +++ b/arch/m68k/lib/ashldi3.c
@@ -13,9 +13,6 @@ but WITHOUT ANY WARRANTY; without even the implied warranty of @@ -14,7 +14,6 @@ MERCHANTABILITY or FITNESS FOR A PARTICU
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details. */ GNU General Public License for more details. */
-#include <linux/compiler.h> #include <linux/compiler.h>
-#include <linux/export.h> -#include <linux/export.h>
-
#define BITS_PER_UNIT 8 #define BITS_PER_UNIT 8
typedef int SItype __mode(SI); @@ -58,4 +57,3 @@ __ashldi3 (DItype u, word_type b)
@@ -58,4 +55,3 @@ __ashldi3 (DItype u, word_type b)
return w.ll; return w.ll;
} }
-EXPORT_SYMBOL(__ashldi3); -EXPORT_SYMBOL(__ashldi3);
diff --git a/arch/m68k/lib/ashrdi3.c b/arch/m68k/lib/ashrdi3.c
index e6565a3ee2c3..1d59345f36c6 100644
--- a/arch/m68k/lib/ashrdi3.c --- a/arch/m68k/lib/ashrdi3.c
+++ b/arch/m68k/lib/ashrdi3.c +++ b/arch/m68k/lib/ashrdi3.c
@@ -13,9 +13,6 @@ but WITHOUT ANY WARRANTY; without even the implied warranty of @@ -14,7 +14,6 @@ MERCHANTABILITY or FITNESS FOR A PARTICU
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details. */ GNU General Public License for more details. */
-#include <linux/compiler.h> #include <linux/compiler.h>
-#include <linux/export.h> -#include <linux/export.h>
-
#define BITS_PER_UNIT 8 #define BITS_PER_UNIT 8
typedef int SItype __mode(SI); @@ -59,4 +58,3 @@ __ashrdi3 (DItype u, word_type b)
@@ -59,4 +56,3 @@ __ashrdi3 (DItype u, word_type b)
return w.ll; return w.ll;
} }
-EXPORT_SYMBOL(__ashrdi3); -EXPORT_SYMBOL(__ashrdi3);
diff --git a/arch/m68k/lib/divsi3.S b/arch/m68k/lib/divsi3.S
index 3a2143f51631..2c0ec85ac661 100644
--- a/arch/m68k/lib/divsi3.S --- a/arch/m68k/lib/divsi3.S
+++ b/arch/m68k/lib/divsi3.S +++ b/arch/m68k/lib/divsi3.S
@@ -33,8 +33,6 @@ General Public License for more details. */ @@ -33,8 +33,6 @@ General Public License for more details.
D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992 D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992
*/ */
@ -139,30 +108,24 @@ index 3a2143f51631..2c0ec85ac661 100644
rts rts
- EXPORT_SYMBOL(__divsi3) - EXPORT_SYMBOL(__divsi3)
diff --git a/arch/m68k/lib/lshrdi3.c b/arch/m68k/lib/lshrdi3.c
index 039779737c7d..49e1ec8f2cc2 100644
--- a/arch/m68k/lib/lshrdi3.c --- a/arch/m68k/lib/lshrdi3.c
+++ b/arch/m68k/lib/lshrdi3.c +++ b/arch/m68k/lib/lshrdi3.c
@@ -13,9 +13,6 @@ but WITHOUT ANY WARRANTY; without even the implied warranty of @@ -14,7 +14,6 @@ MERCHANTABILITY or FITNESS FOR A PARTICU
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details. */ GNU General Public License for more details. */
-#include <linux/compiler.h> #include <linux/compiler.h>
-#include <linux/export.h> -#include <linux/export.h>
-
#define BITS_PER_UNIT 8 #define BITS_PER_UNIT 8
typedef int SItype __mode(SI); @@ -58,4 +57,3 @@ __lshrdi3 (DItype u, word_type b)
@@ -58,4 +55,3 @@ __lshrdi3 (DItype u, word_type b)
return w.ll; return w.ll;
} }
-EXPORT_SYMBOL(__lshrdi3); -EXPORT_SYMBOL(__lshrdi3);
diff --git a/arch/m68k/lib/modsi3.S b/arch/m68k/lib/modsi3.S
index 1c967649a4e0..1d9e0efdf31d 100644
--- a/arch/m68k/lib/modsi3.S --- a/arch/m68k/lib/modsi3.S
+++ b/arch/m68k/lib/modsi3.S +++ b/arch/m68k/lib/modsi3.S
@@ -33,8 +33,6 @@ General Public License for more details. */ @@ -33,8 +33,6 @@ General Public License for more details.
D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992 D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992
*/ */
@ -176,30 +139,24 @@ index 1c967649a4e0..1d9e0efdf31d 100644
rts rts
- EXPORT_SYMBOL(__modsi3) - EXPORT_SYMBOL(__modsi3)
diff --git a/arch/m68k/lib/muldi3.c b/arch/m68k/lib/muldi3.c
index 6459af5b2af0..9006d15b8721 100644
--- a/arch/m68k/lib/muldi3.c --- a/arch/m68k/lib/muldi3.c
+++ b/arch/m68k/lib/muldi3.c +++ b/arch/m68k/lib/muldi3.c
@@ -14,9 +14,6 @@ but WITHOUT ANY WARRANTY; without even the implied warranty of @@ -15,7 +15,6 @@ MERCHANTABILITY or FITNESS FOR A PARTICU
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details. */ GNU General Public License for more details. */
-#include <linux/compiler.h> #include <linux/compiler.h>
-#include <linux/export.h> -#include <linux/export.h>
-
#ifdef CONFIG_CPU_HAS_NO_MULDIV64 #ifdef CONFIG_CPU_HAS_NO_MULDIV64
#define SI_TYPE_SIZE 32 @@ -93,4 +92,3 @@ __muldi3 (DItype u, DItype v)
@@ -93,4 +90,3 @@ __muldi3 (DItype u, DItype v)
return w.ll; return w.ll;
} }
-EXPORT_SYMBOL(__muldi3); -EXPORT_SYMBOL(__muldi3);
diff --git a/arch/m68k/lib/mulsi3.S b/arch/m68k/lib/mulsi3.S
index 855675e69a8a..c39ad4e738e9 100644
--- a/arch/m68k/lib/mulsi3.S --- a/arch/m68k/lib/mulsi3.S
+++ b/arch/m68k/lib/mulsi3.S +++ b/arch/m68k/lib/mulsi3.S
@@ -32,7 +32,7 @@ General Public License for more details. */ @@ -32,7 +32,7 @@ General Public License for more details.
Some of this code comes from MINIX, via the folks at ericsson. Some of this code comes from MINIX, via the folks at ericsson.
D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992 D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992
*/ */
@ -214,11 +171,9 @@ index 855675e69a8a..c39ad4e738e9 100644
rts rts
- EXPORT_SYMBOL(__mulsi3) - EXPORT_SYMBOL(__mulsi3)
+ +
diff --git a/arch/m68k/lib/udivsi3.S b/arch/m68k/lib/udivsi3.S
index 78440ae513bf..35a5446572a5 100644
--- a/arch/m68k/lib/udivsi3.S --- a/arch/m68k/lib/udivsi3.S
+++ b/arch/m68k/lib/udivsi3.S +++ b/arch/m68k/lib/udivsi3.S
@@ -32,7 +32,7 @@ General Public License for more details. */ @@ -32,7 +32,7 @@ General Public License for more details.
Some of this code comes from MINIX, via the folks at ericsson. Some of this code comes from MINIX, via the folks at ericsson.
D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992 D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992
*/ */
@ -233,11 +188,9 @@ index 78440ae513bf..35a5446572a5 100644
#endif /* __mcf5200__ || __mcoldfire__ */ #endif /* __mcf5200__ || __mcoldfire__ */
- EXPORT_SYMBOL(__udivsi3) - EXPORT_SYMBOL(__udivsi3)
+ +
diff --git a/arch/m68k/lib/umodsi3.S b/arch/m68k/lib/umodsi3.S
index b6fd11f58948..099da514a8fd 100644
--- a/arch/m68k/lib/umodsi3.S --- a/arch/m68k/lib/umodsi3.S
+++ b/arch/m68k/lib/umodsi3.S +++ b/arch/m68k/lib/umodsi3.S
@@ -32,7 +32,7 @@ General Public License for more details. */ @@ -32,7 +32,7 @@ General Public License for more details.
Some of this code comes from MINIX, via the folks at ericsson. Some of this code comes from MINIX, via the folks at ericsson.
D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992 D. V. Henkel-Wallace (gumby@cygnus.com) Fete Bastille, 1992
*/ */