[i386] udeb: Add viafb to fb-modules (Closes: #705788)

- [i386] udeb: Move i2c-algo-bit to i2c-modules and make fb-modules depend on it
- viafb: Autoload on OLPC XO 1.5 only

svn path=/dists/sid/linux/; revision=20224
This commit is contained in:
Ben Hutchings 2013-06-10 00:00:54 +00:00
parent 946c9a1bd4
commit 64aaa7d119
6 changed files with 43 additions and 0 deletions

4
debian/changelog vendored
View File

@ -53,6 +53,10 @@ linux (3.9.5-1) UNRELEASED; urgency=low
* [armel/iop32x,armel/ixp4xx] Disable OABI_COMPAT, PCI_QUIRKS to reduce
kernel size (fixes FTBFS)
* ath9k: Disable PowerSave by default (Closes: #695968)
* [i386] udeb: Add viafb to fb-modules (Closes: #705788)
- [i386] udeb: Move i2c-algo-bit to i2c-modules and make fb-modules
depend on it
- viafb: Autoload on OLPC XO 1.5 only
-- Ben Hutchings <ben@decadent.org.uk> Sat, 08 Jun 2013 15:25:11 +0100

View File

@ -2,3 +2,4 @@ fbcon ?
lxfb ?
vesafb ?
vga16fb
viafb

View File

@ -1 +1,2 @@
#include <i2c-modules>
i2c-algo-bit

View File

@ -21,3 +21,6 @@ Depends: kernel-image, core-modules
Package: nbd-modules
Depends: kernel-image
Package: fb-modules
Depends: kernel-image, i2c-modules

View File

@ -0,0 +1,33 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 20 Apr 2013 15:52:02 +0100
Subject: viafb: Autoload on OLPC XO 1.5 only
Bug-Debian: http://bugs.debian.org/705788
It appears that viafb won't work automatically on all the boards for
which it has a PCI device ID match. Currently, it is blacklisted by
udev along with most other framebuffer drivers, so this doesn't matter
much.
However, this driver is required for console support on the XO 1.5.
We need to allow it to be autoloaded on this model only, and then
un-blacklist it in udev.
---
--- a/drivers/video/via/via-core.c
+++ b/drivers/video/via/via-core.c
@@ -753,7 +753,14 @@ static struct pci_device_id via_pci_tabl
.driver_data = UNICHROME_VX900 },
{ }
};
-MODULE_DEVICE_TABLE(pci, via_pci_table);
+
+static const struct pci_device_id via_pci_autoload_table[] __initconst = {
+ /* OLPC XO 1.5 */
+ { PCI_DEVICE(PCI_VENDOR_ID_VIA, UNICHROME_VX855_DID),
+ .subvendor = 0x152d, .subdevice = 0x0833 },
+ { }
+};
+MODULE_DEVICE_TABLE(pci, via_pci_autoload_table);
static struct pci_driver via_driver = {
.name = "viafb",

View File

@ -107,3 +107,4 @@ features/arm/0001-ARM-mvebu-Add-thermal-support-to-Armada-XP-device-tr.patch
bugfix/s390/s390-add-pgste-to-ptep_modify_prot_start.patch
bugfix/powerpc/powerpc-fix-build-error-in-stable-3.9.patch
bugfix/all/ath9k-Disable-PowerSave-by-default.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch