ath9k: Disable PowerSave by default (Closes: #695968)

svn path=/dists/sid/linux/; revision=20223
This commit is contained in:
Ben Hutchings 2013-06-09 23:55:04 +00:00
parent d3ecfab948
commit 946c9a1bd4
3 changed files with 34 additions and 0 deletions

1
debian/changelog vendored
View File

@ -52,6 +52,7 @@ linux (3.9.5-1) UNRELEASED; urgency=low
* [powerpc] Fix build error in stable/3.9
* [armel/iop32x,armel/ixp4xx] Disable OABI_COMPAT, PCI_QUIRKS to reduce
kernel size (fixes FTBFS)
* ath9k: Disable PowerSave by default (Closes: #695968)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 08 Jun 2013 15:25:11 +0100

View File

@ -0,0 +1,32 @@
From: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Date: Sat, 1 Jun 2013 07:08:09 +0530
Subject: ath9k: Disable PowerSave by default
commit 73c79617596b89a3693ff0d89d42bcd5ddedcf15 upstream.
Almost all the DMA issues which have plagued ath9k (in station mode)
for years are related to PS. Disabling PS usually "fixes" the user's
connection stablility. Reports of DMA problems are still trickling in
and are sitting in the kernel bugzilla. Until the PS code in ath9k is
given a thorough review, disbale it by default. The slight increase
in chip power consumption is a small price to pay for improved link
stability.
Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/ath/ath9k/init.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
@@ -766,8 +766,7 @@ void ath9k_set_hw_capab(struct ath_softc
hw->wiphy->iface_combinations = &if_comb;
hw->wiphy->n_iface_combinations = 1;
- if (AR_SREV_5416(sc->sc_ah))
- hw->wiphy->flags &= ~WIPHY_FLAG_PS_ON_BY_DEFAULT;
+ hw->wiphy->flags &= ~WIPHY_FLAG_PS_ON_BY_DEFAULT;
hw->wiphy->flags |= WIPHY_FLAG_IBSS_RSN;
hw->wiphy->flags |= WIPHY_FLAG_SUPPORTS_TDLS;

View File

@ -106,3 +106,4 @@ features/arm/0001-ARM-mvebu-Add-thermal-support-to-Armada-XP-device-tr.patch
bugfix/s390/s390-add-pgste-to-ptep_modify_prot_start.patch
bugfix/powerpc/powerpc-fix-build-error-in-stable-3.9.patch
bugfix/all/ath9k-Disable-PowerSave-by-default.patch