Add stable release 2.6.31.3

svn path=/dists/trunk/linux-2.6/; revision=14344
This commit is contained in:
Ben Hutchings 2009-10-08 00:14:15 +00:00
parent 6a006dce6e
commit 59f71fbb12
3 changed files with 26 additions and 0 deletions

1
debian/changelog vendored
View File

@ -13,6 +13,7 @@ linux-2.6 (2.6.31-1~experimental.2) UNRELEASED; urgency=low
* Improve package descriptions
- Clarify the differences between i386 flavours (Closes: #414690)
- Simplify wording of the description template
* Add stable release 2.6.31.3
[ maximilian attems ]
* Add stable release 2.6.31.2 (Closes: #522828)

View File

@ -0,0 +1,24 @@
diff --git a/Makefile b/Makefile
index d3a69fd..0138557 100644
diff --git a/drivers/char/tty_port.c b/drivers/char/tty_port.c
index 549bd0f..fa4ce67 100644
--- a/drivers/char/tty_port.c
+++ b/drivers/char/tty_port.c
@@ -99,7 +99,7 @@ EXPORT_SYMBOL(tty_port_tty_set);
static void tty_port_shutdown(struct tty_port *port)
{
if (port->ops->shutdown &&
- test_and_clear_bit(ASYNC_INITIALIZED, &port->flags))
+ test_and_clear_bit(ASYNCB_INITIALIZED, &port->flags))
port->ops->shutdown(port);
}
@@ -309,7 +309,7 @@ int tty_port_close_start(struct tty_port *port, struct tty_struct *tty, struct f
port->ops->drop(port);
return 0;
}
- set_bit(ASYNC_CLOSING, &port->flags);
+ set_bit(ASYNCB_CLOSING, &port->flags);
tty->closing = 1;
spin_unlock_irqrestore(&port->lock, flags);
/* Don't block on a stalled port, just pull the chain */

View File

@ -41,3 +41,4 @@
- bugfix/x86/fix-i8xx-agp-flush.patch
+ bugfix/all/stable/2.6.31.2.patch
+ bugfix/all/drivers-net-sfc-fix-initial-link-state.patch
+ bugfix/all/stable/2.6.31.3.patch