[sparc] build zImage by default, fixes build

svn path=/dists/trunk/linux-2.6/; revision=14343
This commit is contained in:
dann frazier 2009-10-06 23:48:42 +00:00
parent e775ea3ceb
commit 6a006dce6e
3 changed files with 60 additions and 17 deletions

3
debian/changelog vendored
View File

@ -17,6 +17,9 @@ linux-2.6 (2.6.31-1~experimental.2) UNRELEASED; urgency=low
[ maximilian attems ]
* Add stable release 2.6.31.2 (Closes: #522828)
[ dann frazier ]
* [sparc] build zImage by default, fixes build
-- Ben Hutchings <ben@decadent.org.uk> Sun, 04 Oct 2009 19:48:35 +0100
linux-2.6 (2.6.31-1~experimental.1) experimental; urgency=low

View File

@ -1,6 +1,58 @@
diff -urpN linux-source-2.6.29.orig/arch/sparc/boot/Makefile linux-source-2.6.29/arch/sparc/boot/Makefile
--- linux-source-2.6.29.orig/arch/sparc/boot/Makefile 2009-03-23 17:12:14.000000000 -0600
+++ linux-source-2.6.29/arch/sparc/boot/Makefile 2009-05-15 16:14:09.000000000 -0600
commit 48e46b7b311c54525712c28004f0a59f2c931d30
Author: Jurij Smakov <jurij@wooyd.org>
Date: Sun Aug 16 18:21:47 2009 -0700
sparc64: build compressed image (zImage) by default
Besides creating the uncompressed vmlinux image for sparc64, also
create a compressed zImage. This is more consistent with other
architectures and required to make the 'deb-pkg' target work.
Signed-off-by: Jurij Smakov <jurij@wooyd.org>
Signed-off-by: Frans Pop <elendil@planet.nl>
Signed-off-by: David S. Miller <davem@davemloft.net>
diff --git a/arch/sparc/Makefile b/arch/sparc/Makefile
index 2003ded..467221d 100644
--- a/arch/sparc/Makefile
+++ b/arch/sparc/Makefile
@@ -38,10 +38,6 @@ CPPFLAGS_vmlinux.lds += -m32
# Actual linking is done with "make image".
LDFLAGS_vmlinux = -r
-# Default target
-all: zImage
-
-
else
#####
# sparc64
@@ -91,6 +87,9 @@ endif
boot := arch/sparc/boot
+# Default target
+all: zImage
+
image zImage tftpboot.img vmlinux.aout: vmlinux
$(Q)$(MAKE) $(build)=$(boot) $(boot)/$@
@@ -109,8 +108,9 @@ define archhelp
endef
else
define archhelp
- echo '* vmlinux - Standard sparc64 kernel'
- echo ' vmlinux.aout - a.out kernel for sparc64'
+ echo '* vmlinux - standard sparc64 kernel'
+ echo '* zImage - stripped and compressed sparc64 kernel ($(boot)/zImage)'
+ echo ' vmlinux.aout - a.out kernel for sparc64'
echo ' tftpboot.img - image prepared for tftp'
endef
endif
diff --git a/arch/sparc/boot/Makefile b/arch/sparc/boot/Makefile
index 1ff0fd9..97e3feb 100644
--- a/arch/sparc/boot/Makefile
+++ b/arch/sparc/boot/Makefile
@@ -79,6 +79,9 @@ $(obj)/image: vmlinux FORCE
$(call if_changed,strip)
@echo ' kernel: $@ is ready'
@ -8,18 +60,6 @@ diff -urpN linux-source-2.6.29.orig/arch/sparc/boot/Makefile linux-source-2.6.29
+$(obj)/zImage: $(obj)/image
+ $(call if_changed,gzip)
+
$(obj)/tftpboot.img: vmlinux $(obj)/piggyback_64 System.map $(ROOT_IMG) FORCE
$(obj)/tftpboot.img: $(obj)/image $(obj)/piggyback_64 System.map $(ROOT_IMG) FORCE
$(call if_changed,elftoaout)
$(call if_changed,piggy)
diff -urpN linux-source-2.6.29.orig/arch/sparc/Makefile linux-source-2.6.29/arch/sparc/Makefile
--- linux-source-2.6.29.orig/arch/sparc/Makefile 2009-03-23 17:12:14.000000000 -0600
+++ linux-source-2.6.29/arch/sparc/Makefile 2009-05-15 16:14:44.000000000 -0600
@@ -91,6 +91,8 @@ endif
boot := arch/sparc/boot
+all: zImage
+
image zImage tftpboot.img vmlinux.aout: vmlinux
$(Q)$(MAKE) $(build)=$(boot) $(boot)/$@

View File

@ -27,7 +27,7 @@
+ bugfix/powerpc/lpar-console.patch
#+ bugfix/all/wireless-regulatory-default-EU.patch
#+ features/sparc/video-sunxvr500-intergraph.patch
#+ bugfix/sparc/arch-zimage-target.patch
+ bugfix/sparc/arch-zimage-target.patch
+ features/arm/openrd-machtype.patch
+ features/arm/openrd.patch
+ features/arm/openrd-sata.patch