lockdep: Add more missing macros

This commit is contained in:
Ben Hutchings 2016-02-23 01:28:10 +00:00
parent 50f3a5b708
commit 53b6b7a143
2 changed files with 4 additions and 1 deletions

1
debian/changelog vendored
View File

@ -7,6 +7,7 @@ linux-tools (4.5~rc5-1~exp4) UNRELEASED; urgency=medium
* debian/control: Build-Depend on dh-python, as dh_python2 warns we should
* lockdep: Add '+' prefix to make invocation, so it can be parallelised
* tools/build: Fix 'unused variable' warning in the bpf() feature check
* lockdep: Add more missing macros
-- Ben Hutchings <ben@decadent.org.uk> Mon, 22 Feb 2016 23:21:57 +0000

View File

@ -17,8 +17,10 @@ doesn't have substitutes for.
#define container_of(ptr, type, member) ({ \
--- a/tools/lib/lockdep/uinclude/linux/list.h
+++ b/tools/lib/lockdep/uinclude/linux/list.h
@@ -1 +1,2 @@
@@ -1 +1,4 @@
#include "../../../include/linux/list.h"
+#define hlist_add_head_rcu hlist_add_head
+#define hlist_del_rcu hlist_del
+#define hlist_for_each_entry_rcu hlist_for_each_entry
--- a/tools/lib/lockdep/uinclude/linux/compiler.h
+++ b/tools/lib/lockdep/uinclude/linux/compiler.h