tools/build: Fix 'unused variable' warning in the bpf() feature check

I deleted slightly too much when removing the run-time check.
This commit is contained in:
Ben Hutchings 2016-02-23 01:14:08 +00:00
parent ad25e86edb
commit 50f3a5b708
2 changed files with 3 additions and 3 deletions

1
debian/changelog vendored
View File

@ -6,6 +6,7 @@ linux-tools (4.5~rc5-1~exp4) UNRELEASED; urgency=medium
* hyperv-daemons: Fix rule redefinition that 'make' warns about
* debian/control: Build-Depend on dh-python, as dh_python2 warns we should
* lockdep: Add '+' prefix to make invocation, so it can be parallelised
* tools/build: Fix 'unused variable' warning in the bpf() feature check
-- Ben Hutchings <ben@decadent.org.uk> Mon, 22 Feb 2016 23:21:57 +0000

View File

@ -10,11 +10,10 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/build/feature/test-bpf.c
+++ b/tools/build/feature/test-bpf.c
@@ -27,10 +27,5 @@ int main(void)
attr.log_level = 0;
@@ -28,9 +28,5 @@ int main(void)
attr.kern_version = 0;
- attr = attr;
attr = attr;
- /*
- * Test existence of __NR_bpf and BPF_PROG_LOAD.
- * This call should fail if we run the testcase.